Closed Bug 1860992 Opened 4 months ago Closed 3 months ago

[meta] Run pdf.js Puppeteer integration tests with WebDriver BiDi

Categories

(Remote Protocol :: WebDriver BiDi, enhancement)

enhancement

Tracking

(firefox122 fixed)

RESOLVED FIXED
Tracking Status
firefox122 --- fixed

People

(Reporter: whimboo, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Keywords: meta, Whiteboard: [webdriver:m9])

The PDF.js project as owned by Mozilla has a couple of tests suites that make use of Puppeteer. Right now the CDP protocol is used, but we would like to actually switch over to WebDriver BiDi.

Tests that are affected are basically the integration tests. Those can be run with:

gulp integrationtest --noChrome

This meta bug tracks the remaining work before we can actually do the switch. A draft PR can already be found at https://github.com/mozilla/pdf.js/pull/17172.

No longer depends on: 1854942

Right now a lot of integration tests make use of the Control key, which is actually broken on MacOS because it needs Meta. With a fix for that a lot of hangs that I was able to see will be fixed. I filed https://github.com/mozilla/pdf.js/issues/17181.

More investigations have shown that there are a lot of issues with the tests themselves and Calixte is working on getting them fixed.

Beside that I also noticed a bug when a non-supported JavaScript DOM object is serialized. For those objects we only serialize a type but no value. And Puppeteer seems to expect a value. The issue can be found at: https://github.com/puppeteer/puppeteer/issues/11259.

No longer depends on: 1853988

(In reply to Henrik Skupin [:whimboo][⌚️UTC+2] from comment #1)

Right now a lot of integration tests make use of the Control key, which is actually broken on MacOS because it needs Meta. With a fix for that a lot of hangs that I was able to see will be fixed. I filed https://github.com/mozilla/pdf.js/issues/17181.

Tests have been refactored and now they all work for CDP. There are no further changes needed for WebDriver BiDi.

Also the Puppeteer issue has been fixed and only awaits a new Puppeteer release. Once done I'll re-check the pdf.js tests with BiDi including Chrome.

I've added https://github.com/mozilla/pdf.js/pull/17392 which actually bumps Puppeteer to the actual version that is needed for the experimental support. It also needs a workaround for a regression that got introduced with Firefox and CDP.

Since late Friday last week the pdf.js integration tests now run with WebDriver BiDi enabled. As such we can close this meta bug now.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Whiteboard: [webdriver:m9]
You need to log in before you can comment on or make changes to this bug.