Closed Bug 208385 Opened 17 years ago Closed 4 years ago

Drag and drop (from desktop or Windows Explorer) onto browser at FTP site does not upload

Categories

(Core :: Networking: FTP, enhancement)

enhancement
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: wbayer, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529

Using Netscape 4.7x/4.8/IE6 when a file is dragged from Windows explorer to the
browser, and the browser is on an ftp site that allows uploads, the file is
uploaded to the ftp site.

I've verified that Netscape 7.01 on Windows 2000 Mozilla 1.4RC1 on both Windows
2000 and Windows 98 both will either displays the file (if it is a known file
type like .txt or .html) or open a Download Manager window asking "What should
Mozilla do with this file".

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
I've verified that Netscape 7.01 on Windows 2000 and Mozilla 1.4RC1 on both
Windows 2000 and Windows 98 will either display the file (if it is a known file
type like .txt) or open a Download Manager window asking "What should Mozilla do
with this file".

Expected Results:  
Simply upload the "drag and dropped" file to the ftp site.

*** This bug has been marked as a duplicate of 24867 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Reopening - not fixed in bug 24867.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
*** Bug 107588 has been marked as a duplicate of this bug. ***
Assignee: firefox → dougt
Severity: major → normal
Status: UNCONFIRMED → NEW
Component: Download Manager → Networking: FTP
Ever confirmed: true
Keywords: 4xp
QA Contact: chrispetersen → benc
Summary: Drag and drop from Windows Explorer to Mozilla on an ftp site does not result in an upload → Drag and drop from Windows Explorer to Mozilla on an FTP site does not result in an upload
Shouldn't this be platform ALL?
>>Drag and drop from Windows Explorer to Mozilla on an FTP site 
>>does not result in an upload.

1) I wonder about the drag and drop from anything beside Windows Explorer, like
the desktop or something.  Umm...
2) I wonder about the copy and paste beside the drag and drop too.  Umm...
Yike!  From the look of bug #224414 & #191400, since the drag and drop the ftp
part is not implemented so no way of knowing if this same effect will be felt
here or not.  If it does then it would be a good idea to have those two bug,
#224414 and #191400 be a blocker to this one regardless of whether it apply to
FTP or not because it is not know if there is some code sharing being involved
or not.  Just something to keep our eye out on this one.
Summary: Drag and drop from Windows Explorer to Mozilla on an FTP site does not result in an upload → Drag and drop from Windows Explorer browser FTP site does not upload
Whiteboard: dupeme
The original bug that asked for DND support for FTP upload was Bug 107588. For
some reason it was marked as dupe of this one, while the opposite might have
been more fitting.

Prog.
Whiteboard: dupeme
This is still broken and annoying as it provides a tremendously useful way for
users to upload files. Sites that require this as their folder-upload strategy
are forced to demand their users use IE, which is sad.
*** Bug 180458 has been marked as a duplicate of this bug. ***
This is an desirable enhancement on all platforms, I just got a request for this
on OS/2 when doing d'n'd from the WPS and I confirmed it on Linux by dropping
from Konqueror, hence I changed the title a bit. (This is probably not
"Networking: FTP" because that part already works but instead something like XP
Toolkit or Widgets.)

The problem I see: if one is on an FTP site and wants to load/display an HTML
file using d'n'd how should that be communicated to the browser? Could one
instead signal an FTP upload with Shift-Drag or Shift-Ctrl-Drag or some other
key/mouse combo? Or are those already used for something else?
Severity: normal → enhancement
OS: Windows 2000 → All
Hardware: PC → All
Summary: Drag and drop from Windows Explorer browser FTP site does not upload → Drag and drop (from desktop or Windows Explorer) onto browser at FTP site does not upload
*** Bug 275056 has been marked as a duplicate of this bug. ***
From a user convenience viewpoint, providing Firefox with drag and drop ftp upload capability would be very useful. Firefox is our default browser, but our Service staff must use IE to "drag and drop" digital photographs for ftp upload. 

The UI for ftp upload was created in August 2004 for SeaMonkey 1.0a (bug 24867), but for Firefox, this functionality could be provided with no UI changes.
*** Bug 352909 has been marked as a duplicate of this bug. ***
Depends on: 391855
mass reassigning to nobody.
Assignee: dougt → nobody
(In reply to comment #10)
> This is an desirable enhancement on all platforms

I agree. It just much easier to give a link to non-technical users, so they can upload few files. They do not need any advanced functionality, which will in fact confuse them a lot....

> The problem I see: if one is on an FTP site and wants to load/display an HTML
> file using d'n'd how should that be communicated to the browser?

What about a simple dialog asking the user if he wants to upload or open? Possibly with checkbox do not show again for this session or something.. nothing fancy.
no more ftp enhancements in core
Status: NEW → RESOLVED
Closed: 17 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.