Closed Bug 211551 Opened 19 years ago Closed 14 years ago

bottom of page not displayed in fullscreen

Categories

(Firefox :: Menus, defect)

All
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 307340

People

(Reporter: hramrach, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

The bottom of pages that are long enough that they need scrollbars is not
accessible in fullscreen. It looks as if the window extended past the bottom of
the screen.

Reproducible: Always

Steps to Reproduce:
1. Start Firebird
2. Open a long page
3. Switch to fullscreen

Actual Results:  
unable to scroll to the bottom of the page (or no scrollbar is displayed if the
page is just 1-2 lines longer than the screen)

Expected Results:  
see whole pages
confirmed, mac firebird 20030627.  seems like mac firebird fullscreen mode is
not at all like windows fullscreen mode.
indeed... 

(a) the "full screen" behavior on the mac builds are much more like a "maximize"
would be.

(b) The height given to the window looks like the screen height -- but doesn't
take into account that the menu bar won't dissapear giving you that extra few
pixels off the bottom.

given that the mac UI provides an enlarge/maximize button already a short term
fix might be just to disable/remove full screen from the mac UI

Confirming and sending to menus
Status: UNCONFIRMED → NEW
Component: General → Menus
Ever confirmed: true
QA Contact: asa → bugzilla
It would be nicer if the fullscreen window did not have the titlebar.
However, I would not remove the fullscreen mode. It does not break anything -
the window can be easily un-fullscreened.

And there are fullscreen applications and windows without title bar on OS X. So
it is certainly possible to fix it.
--> me

Not only is it cut off, it's not respecting the dock either.  It should either
hide the dock somehow (by drawing over it), or it should respect the dock and
not intrude into the dock's space.

If we can't fix this issue, we will have to disable Full Screen mode on Mac.
Status: NEW → ASSIGNED
Target Milestone: --- → Firebird0.9
--> me
Assignee: blake → hyatt
Status: ASSIGNED → NEW
Full screen on Mac is merely another way of maximising the window - I believe
this feature should either be removed, or refined so that the browser goes full
screen, hiding the menu bar and Dock in the process.
Fullscreen was never implemented properly on OS X. It needs to be hooked up in
nsMacWindow etc. 

Setting Window attributes:
http://developer.apple.com/documentation/Carbon/Reference/Window_Manager/index.html#//apple_ref/doc/uid/TP30000176

Assignee: hyatt → bugs
Priority: -- → P3
Target Milestone: Firefox0.9 → Firefox1.0beta
*** Bug 246220 has been marked as a duplicate of this bug. ***
I think that this is a relatively obvious bug that has high cost:benefit ratio.
 It still exists on Firebird 0.9.1 on OS X 10.3.4.
This bug is also happening for me on Linux, Mandrake 10, running Gnome with
Firefox 1.0PR. I see about 1 line or so missing at the bottom of the screen in
full screen mode, which is rather annoying.

The menus only allow one platform to be selected, so I have left it on "MacOS X"
rather than change it to "Linux" or "All", ditto for the hardware field.
*** Bug 268186 has been marked as a duplicate of this bug. ***
This is something that really would be nice to get fixed before 1.1, since
there's an emphasis on Mac polish :) Resetting the target milestone.

I assume the intention is for it to behave like zoom (which expands the window
without intruding on the dock), but maximize the window horizontally as well,
and hide the status bar. In the windows of some applications, zoom behaves that
way by default (the horizontal-maximizing, not the status bar hiding). Could we
emulate that?

If we went for true full-screen mode, it'd be really nice to do something like
Apple DVD Player does, where the window contents take up the entire screen, the
toolbars and the dock are hidden, and the application menu only appears if you
mouse over it. But I imagine that'd take a lot of work to achieve. The Apple
developer pages mentioned something about it, but not much.
Target Milestone: Firefox1.0beta → Firefox1.1
(In reply to comment #12)
> If we went for true full-screen mode, it'd be really nice to do something like
> Apple DVD Player does, where the window contents take up the entire screen, the
> toolbars and the dock are hidden, and the application menu only appears if you
> mouse over it. But I imagine that'd take a lot of work to achieve. The Apple
> developer pages mentioned something about it, but not much.

It would be really amazing to finally get true full-screen support in Firefox on
OS X. In fact, I don't think _any_ other modern/recent Mac browser has ever done
true full-screen mode which hides the menubar (most important) and then enables
the build-in Dock Auto-Hiding feature. I would love to see a true full-screen
Firefox on Mac just as Firefox/IE does full-screen on Windows (everything hidden
but browser toolbars optional). I can't hope for this feature enough....
I'm getting the same problem when full screen mode is off as well.  But maybe my
case started when I had full screen mode on, and then when I switched it off the
bottom bar was still beyond the bottom the screen.
A possible work around seems to be just to use the maximise button in the title
bar.  This appears to display the whole page and the scrollbars are accessable.
 So this seems to solve the problems stated originally.  However, this is not
really a 'fullscreen' mode.  
Depends on: 304089
QA Contact: bugzilla → menus
It should be a good idea to remove the item from the menu on Mac OS X. 

As the feature is still unusable on Firefox 1.5 beta 1, I think it should be removed, or maybe disabled by 
default with an about:config option. Giving to the user a feature that does not work does not seem really 
nice to me.

When Firefox 1.5 will be out, someone could start reimplementing that. 
Forget about that, I did not see bug #307340
The ability to hide the menubar and dock are two things that would help people wanting to make a kiosk 
type solution on the Mac, using Firefox as the basis.
Assignee: bugs → joshmoz
Is this the proper bug or 307371?

Technical Note TN2062: Guide to Creating Kiosks on Mac OS X
http://developer.apple.com/technotes/tn2002/tn2062.html

Available on 10.2 and Higher.
Assignee: joshmoz → nobody
Depends on: 370857
We never had a real fullscreen mode and the implementation which simulate this one was removed by a patch on bug 307340.

This is a dupe of bug 307340 which has also handled this feature.
Status: NEW → RESOLVED
Closed: 14 years ago
No longer depends on: 370857
Priority: P3 → --
Hardware: Macintosh → All
Resolution: --- → DUPLICATE
Target Milestone: Firefox1.5 → ---
Duplicate of bug: 307340
You need to log in before you can comment on or make changes to this bug.