Closed Bug 214763 Opened 17 years ago Closed 14 years ago

Add option not to use signature when replying or forwarding

Categories

(Thunderbird :: Preferences, enhancement)

enhancement
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 167319

People

(Reporter: ed, Assigned: mscott)

References

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: ThunderBird

This is related to Bug 62429, but I was advised to submit a new bug.  
Nonetheless decisions regarding 62429 will affect this bug.

I'd like to request a feature that would allow a user to omit his or her e-mail 
signature entirely when replying or forwarding.  Currently the signature is 
apended universally if activated.  Bug 62429 suggests allowing the signature to 
appear *above* inline quoted text in a reply or forward; this enhances that 
idea with a set of three radio button options that could look like this:

 When forwarding or replying, append signature ...
 * below quoted text
 - above quoted text
 - nowhere (omit signature)

The first setting, which is the current behavior, could be the default.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
*** Bug 214730 has been marked as a duplicate of this bug. ***
Updating summary.

Also, this bug is currently classified under Thunderbird. Would it be beneficial
to try it in Seamonkey first?
Summary: Enhanced signature options → Add option not to use signature when replying or forwarding
The relevant bug in seamonkey is Bug 167319

Perhaps this should be duped there as it is a much older bug?
QA Contact: asa
*** Bug 264509 has been marked as a duplicate of this bug. ***
May I suggest the following, which some will no doubt find desirable:

That when the option not to sign messages has been chosen, a button or menu item
on the compose window would still allow one to insert one's signature in
individual, self-chosen messages. (if this were to be implemented, when "insert
signature ..." is deactivated in account settings, the choice of a signature
file would have to remain active of course).

Thanks.

Michel  
Duping to what is now a Core bug.

*** This bug has been marked as a duplicate of 167319 ***
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.