Closed Bug 167319 Opened 17 years ago Closed 11 years ago

[RFE] "Don't add signature to replies and forwards" option in preferences

Categories

(MailNews Core :: Composition, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b3

People

(Reporter: bugzilla3, Assigned: mkmelin)

References

Details

(Whiteboard: [penelope_wants])

Attachments

(2 files, 3 obsolete files)

A nice feature of Outlook Express: it has a "Don't add signatures to replies &
forwards" setting. Why don't we add a similar setting in our preferences ?
(together with the ability to add signature on request, which is bug 147854)

It seems like a partial alternative to the infamous bug 62429 or bug 141531,
which no one at mozilla.org is willing to fix. I am explaining why this rfe
might be useful:
1. When you know the person you answer, it isn't elegant to add that clutter in
your mail. Especially when there are more than one replies in the message.
2. International users might want to use signatures written in their local
languages. But, when replying in another (non-local) language, you obviously
must ommit the signature. Especially when replying above, since the signature
might be buried many lines below. It's too easy to forget erasing it (I fell
into this many times in my business mail replies). Nevertheless, erasing is time
consuming.
3. Newsgroup and mailing list users might want to preserve their anonymity. Why
forcing them to erase their signatures? Or exposing them in the risk of
forgetting to erase it?

Well, I'm not an optimist. This rfe will probably end wontfixed (or duped but I
didn't find something similar in Bugzilla).
Severity: normal → enhancement
Summary: [rfe] "Don't add signature to replies and forwards" option in preferences → [RFE] "Don't add signature to replies and forwards" option in preferences
don't be pessimist! sound to be a good idea. The only problem is time...
-->varada
Assignee: ducarroz → varada
taking all of varada's bugs.
Assignee: varada → sspitzer
*** Bug 215247 has been marked as a duplicate of this bug. ***
I'm voting for this since this is very easy to do
and it makes all the sense in the world for corporate users.

Also I suggest that someone suficiently empowered should change
the OS to all since this happens in all mozilla mail clients.
OS: Windows 2000 → All
Hardware: PC → All
*** Bug 186511 has been marked as a duplicate of this bug. ***
*** Bug 226433 has been marked as a duplicate of this bug. ***
From the last dupe, this would be especially useful when replying to digests.
I actually wouldn't mind getting options similar to those that solved the
"infamous" bugs that were mentioned in the original description.  I actually
want the signature, I just want it before the forwarded message.
Attached patch Proposed fix for this RFE (obsolete) — Splinter Review
This patch adds a checkbox to the Account Prefs UI which allows the user
to choose whether to attach a signature to quoted messages or not.
Product: MailNews → Core
*** Bug 214763 has been marked as a duplicate of this bug. ***
*** Bug 314443 has been marked as a duplicate of this bug. ***
A patch was provided for this over two years ago. Can this go in?
Comment on attachment 151286 [details] [diff] [review]
Proposed fix for this RFE

reviews must be requested and completed before any patch can land...this patch languished because no one ever requested a review :-(

I'm not sure we want a UI for this, but the composition and addressing page does have plenty of space at the moment.
Attachment #151286 - Flags: review?(mscott)
Flags: blocking1.8.1.1?
Flags: blocking1.8.1.1?
Assignee: sspitzer → nobody
QA Contact: esther → composition
*** Bug 362974 has been marked as a duplicate of this bug. ***
a lot of amazing features coming into new versions. can't this come together with the TB release?
This is ridiculous.
<rant>This was first posted in 2002.  That was 5 years ago!  Someone even posted a patch in 2002 for it, but apparently it was never "reviewed".  How do I request it to be "reviewed"?  What's the point of having bugzilla or a similar system if it takes 5 years for something to happen (or in this case, nothing)?
This is like me hoping that Microsoft will improve their IMAP support in Outlook!</rant>
On the other hand, I do hold the highest respect for the developers.  They are working on all this without pay, so I can't really expect them to do anything that they don't feel like doing.  It would just be nice if we had a little more throughput in certain areas.
A similar RFE that has been waiting since 2004: Bug 273114
I came here to request this feature also. Just fix it! I started using Thunderbird yesterday and this is an annoyance when you have been using Outlook Express for 7 years before.
(In reply to comment #18)
> This is ridiculous.

I'd like to edit or rescind my previous comment (#18).  I think it was just a bad day.  I understand the developers are under no obligation to do anything they do not want to.

I hope it didn't hurt this bug report.  Perhaps I just have to learn how to program more. 
Flags: wanted-thunderbird3.0a1?
Moving from wanted‑thunderbird3.0a1? flag to wanted‑thunderbird3.0a2? flag since code for Thunderbird 3 Alpha 1 has been frozen.
Flags: wanted-thunderbird3.0a1? → wanted-thunderbird3.0a2?
Yeah why not add this into upcoming tb3?

Flags: wanted-thunderbird3.0a2? → wanted-thunderbird3?
Product: Core → MailNews Core
adding bryan to the mix to comment. 
Whiteboard: [patchlove]
Comment on attachment 151286 [details] [diff] [review]
Proposed fix for this RFE

mscott no longer actively reviewing, so canceling review

once a direction is (re)decided someone can take up the torch on this request
Attachment #151286 - Flags: review?(mscott)
Can you re-request the review please?
need a patch owner first.
also need UI review.
Duplicate of this bug: 456823
This seems like a good idea to me, probably should default to being on.

Is anyone willing to work on the patch?
Taking.
Assignee: nobody → mkmelin+mozilla
Flags: wanted-thunderbird3? → wanted-thunderbird3+
Target Milestone: --- → Thunderbird 3.0rc1
This is big problem for business use, I think feature should be implemented as soon as possible. Thanks.
Flags: blocking-thunderbird3?
Comment on attachment 151286 [details] [diff] [review]
Proposed fix for this RFE

Patch has bitrotted.

$ patch  --dry-run < ~/Desktop/tbTestPatches/patch_for_167319.diff 
(Stripping trailing CRs from patch.)
patching file am-addressing.js
Hunk #1 succeeded at 95 with fuzz 1 (offset -8 lines).
(Stripping trailing CRs from patch.)
patching file am-addressing.xul
Hunk #1 FAILED at 89.
1 out of 1 hunk FAILED -- saving rejects to file am-addressing.xul.rej
(Stripping trailing CRs from patch.)
can't find file to patch at input line 84
Perhaps you should have used the -p or --strip option?
The text leading up to this was:
--------------------------
|Index: mailnews/base/public/nsIMsgIdentity.idl
|===================================================================
|RCS file: /cvsroot/mozilla/mailnews/base/public/nsIMsgIdentity.idl,v
|retrieving revision 1.33
|diff -u -8 -p -r1.33 nsIMsgIdentity.idl
|--- mailnews/base/public/nsIMsgIdentity.idl    17 Apr 2004 18:32:15 -0000      1.33
|+++ mailnews/base/public/nsIMsgIdentity.idl    20 Jun 2004 13:10:39 -0000
--------------------------
File to patch:
Attachment #151286 - Attachment is obsolete: true
This would not block a release, but work on the patch would be great.
Flags: blocking-thunderbird3? → blocking-thunderbird3-
Whiteboard: [patchlove] → [patchlove][penelope_wants]
Duplicate of this bug: 395154
Attached patch proposed fix (obsolete) — Splinter Review
Defaulting to use signature for replies but not for forwards.
Screen shot coming up.
Attachment #371490 - Flags: ui-review?(clarkbw)
Attachment #371490 - Flags: superreview?(neil)
Attachment #371490 - Flags: review?(bugzilla)
Status: NEW → ASSIGNED
Whiteboard: [patchlove][penelope_wants] → [penelope_wants]
Attached image screenshot
Target Milestone: Thunderbird 3.0rc1 → Thunderbird 3.0b3
Comment on attachment 371490 [details] [diff] [review]
proposed fix

Can you point me to the bug for redirect, so I can decide whether I agree with your signature decision?

If you change your identity in the Compose window then you'll always get a new signature; is that likely to be a problem?
Comment on attachment 371490 [details] [diff] [review]
proposed fix

looks good to me from the screenshot
Attachment #371490 - Flags: ui-review?(clarkbw) → ui-review+
The redirect implementation was bug 359226. (AFAIK, it's just an easy way for forward + set reply-to.)
Comment on attachment 371490 [details] [diff] [review]
proposed fix

One thing I did notice was this patch doesn't disable the reply/forward preference when the user has no signature (compare with the "place my signature" dropdown).

>diff --git a/mailnews/base/prefs/resources/content/am-addressing.js b/mailnews/base/prefs/resources/content/am-addressing.js
Part of some other patch?

>-    
>+
Nit: lots of random whitespace cleanup

>+  PRBool includeSignature;
Nit: prefer to init to PR_TRUE here, and don't bother with the default:

>+
>+    default:
Nit: inconsistent spacing

>-    if (!aSignature.IsEmpty() )
>+    if (includeSignature && !aSignature.IsEmpty())
Is it possible to avoid fetching the signature if we won't need it?

> <!ENTITY place.label                          "and place my signature">
> <!ENTITY place.accesskey                      "s">
> <!ENTITY belowText.label                      "below the quote (recommended)">
> <!ENTITY aboveText.label                      "below my reply (above the quote)">
>+<!ENTITY includeSigOnReply.label "Include signature for replies">
>+<!ENTITY includeSigOnReply.accesskey "s">
>+<!ENTITY includeSigOnForward.label "Include signature for forwards">
>+<!ENTITY includeSigOnForward.accesskey "w">
Nit: strings should align
(In reply to comment #36)
> (From update of attachment 371490 [details] [diff] [review])
> Can you point me to the bug for redirect, so I can decide whether I agree with
> your signature decision?

Redirect is not an issue in the next iteration.

> If you change your identity in the Compose window then you'll always get a new
> signature; is that likely to be a problem?

Fixed.
(In reply to comment #39)
> (From update of attachment 371490 [details] [diff] [review])
> One thing I did notice was this patch doesn't disable the reply/forward
> preference when the user has no signature (compare with the "place my
> signature" dropdown).

Yeah, I think the disabling is confusing and should go, plan to attack bug 277187 at some point.

> >diff --git a/mailnews/base/prefs/resources/content/am-addressing.js b/mailnews/base/prefs/resources/content/am-addressing.js
> Part of some other patch?

Drive-by cleanup, have removed that from the patch...

> Nit: lots of random whitespace cleanup

Not a bug ;)

> Is it possible to avoid fetching the signature if we won't need it?

Fixed.
Attached patch proposed fix, v2 (obsolete) — Splinter Review
Carrying fwd ui-r=clarkbw
Attachment #371490 - Attachment is obsolete: true
Attachment #371826 - Flags: ui-review+
Attachment #371826 - Flags: superreview?(neil)
Attachment #371826 - Flags: review?(bienvenu)
Attachment #371490 - Flags: superreview?(neil)
Attachment #371490 - Flags: review?(bugzilla)
Attachment #371826 - Flags: superreview?(neil) → superreview+
Comment on attachment 371826 [details] [diff] [review]
proposed fix, v2

And to think I'd decided to go with your decision on signing redirects too...
Comment on attachment 371826 [details] [diff] [review]
proposed fix, v2

this patch has bit-rotted. In general, it looks good, but I'd like to try running it. Do you have a non-bitrotted version?
Attached patch proposed fix, v3Splinter Review
Unbitrotted.
Attachment #371826 - Attachment is obsolete: true
Attachment #373362 - Flags: ui-review+
Attachment #373362 - Flags: superreview+
Attachment #373362 - Flags: review?(bienvenu)
Attachment #371826 - Flags: review?(bienvenu)
Comment on attachment 373362 [details] [diff] [review]
proposed fix, v3

thx, Magnus.
Attachment #373362 - Flags: review?(bienvenu) → review+
Comment on attachment 373362 [details] [diff] [review]
proposed fix, v3

one thought, however, is to use the doxygen /// comment. format for the one line comments. There's a possibility the comment needs to end with a "." for doxygen to pick it up, though I don't know if that was ultimately figured out or not.
I thought about that, but it looks a bit inconsistent in the file when some attributes still need more than one line for the comment, so it'd be mixed formats.
changeset:   2414:7f2485cc359a
http://hg.mozilla.org/comm-central/rev/7f2485cc359a

->FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.