Delete (backspace) key should go back

RESOLVED FIXED in Firefox1.5

Status

()

Firefox
Keyboard Navigation
--
enhancement
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: Aaron Namba, Assigned: Mark Mentovai)

Tracking

({fixed1.8})

unspecified
Firefox1.5
PowerPC
Mac OS X
fixed1.8
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8rc1 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20030926 Firebird/0.7+/jtalkington-nightly
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20030926 Firebird/0.7+/jtalkington-nightly

Delete (Backspace) should go back. This is present in Safari and IE and is really
handy.

Reproducible: Always

Steps to Reproduce:
1. Hit Delete.
Actual Results:  
Nothing.

Expected Results:  
Go back.

Comment 1

14 years ago
For purpose of discussion movement is leaning towards removing this behavior
from Camino. See bug 181198 / bug 192117

Comment 2

14 years ago
This behavior is annoying. The delete key should delete (hence its name). It
should not go back a page if the focus is (unexpectedly possibly) out of an edit
field.

Please do not implement this.

Comment 3

14 years ago
agreed, it's not a good shortcut at all.  however, it is a shortcut supplied by
safari, so i'm confirming this.  (i'll let someone else decide its fate. :)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
*** Bug 243577 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
I can understand the rationale behind not wanting delete == page back, in the
general case.  Is is possible to (possibly with magic keybindings?) accomplish
this for people who want it?
Assignee: firefox → aaronleventhal
Component: General → Keyboard Navigation
QA Contact: bugzilla

Updated

13 years ago
Keywords: helpwanted

Comment 6

13 years ago
1) Delete should function as a follows - If current focus is a caret, then
Delete works as expected to backspace over a character.  If current focus is not
a caret, then Delete functions as the Back Keyboard Shorcut.
2) In this context, there is not contention for Delete to be used as a Keyboard
Shortcut
3) This functionality, as described is implemented in Safari, Internet Explorer
5.2 for Mac, and Opera
4) This is one of very few universal keyboard shorcuts across browsers and
platforms.  It is as standard as you can get.  99% of users will expect this
behavior and try it intuitively.  Why make it default the other way for the 1%
who find this annoying?  I grant them their preference, but defaults should be
those which are intuitive, or which the user would expect based on experience
with similiar applications.

Comment 7

13 years ago
*** Bug 263675 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Summary: Delete key should go back → Delete (backspace) key should go back

Comment 8

13 years ago
*** Bug 266500 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago
This should be reclassified as a major or critical bug, not an enhancement. 
Backspace works as Previous Page shorcut on all other Firefox versions, an all
other Mac browsers.  This is core expected browser functionality.

Updated

13 years ago
Flags: blocking-aviary1.0mac?
1.0mac has been canceled. I will probably take it for 1.1.
Flags: blocking-aviary1.0mac?
Target Milestone: --- → Firefox1.1

Comment 11

13 years ago
By Camino, the non-English(IME) user had been afflicted about this function for
a long time.
If it does not carry out carefully, it will be afflicted like bug259454.
Please do not forget existence of IME.

Comment 12

13 years ago
I understand that this "shortcut" exists in most Windows browsers (including
Firefox), and in many Mac browsers too.  But I have ALWAYS hated this
functionality, ever since I discovered it.  Why should the backspace key send
the browser back one page?  That key is for text editing, and nothing else. 
This causes many issues where one accidentally presses it, or accidentally
presses it while the focus is not in a form field and loses data.  That used to
happen to me in IE all the time.

It especially doesn't make sense on the Mac, where there is no key called
"Backspace".  Why should a key marked "Delete" go back one page?  That is what
cmd-[left arrow] is for!  The alt-arrow (cmd-arrow on Mac) keyboard shortcuts
work in every modern browser I've used (except browsers like lynx, of course),
so there is your universal shortcut across all browsers.  I just don't
understand why someone decided it was intuitive for the backspace key to do
that, other than the fact that the word "back" is on it.  If that is the case,
then why should the Mac's "Delete" key do it?

I suggest that this "bug" NOT be fixed.  If it does get fixed, it should be
configurable (on/off) on ALL platforms.
(Reporter)

Comment 13

13 years ago
(In reply to comment #12)
> But I have ALWAYS hated this functionality, ever since I discovered it.
Actually, I am not entirely supportive of it either. I suppose the title could
have read "Should backspace key go back?" or something to that effect. Mainly I
reported this for the sake of consistency across platforms, although there are
subtle differences from one platform to the next (the behavior of the middle
button on Linux for example).

> That key is for text editing, and nothing else.
One could argue that Cmd-Left and Cmd-Right should go to the beginning and the
end of the line, and nothing else.

> This causes many issues where one accidentally presses it, or accidentally
> presses it while the focus is not in a form field and loses data.  That used to
> happen to me in IE all the time.
Yes, this happens a lot in IE. However, you'll notice that Firefox generally
retains form data if accidentally go back, then go forward again. Also if you
refresh, your form data is generally retained. This is especially handy when you
encounter "mid-air collisions" in bugzilla.

> The alt-arrow (cmd-arrow on Mac) keyboard shortcuts
> work in every modern browser I've used (except browsers like lynx, of course),
> so there is your universal shortcut across all browsers.
Also note that backspace works in many browsers.

> If it does get fixed, it should be configurable (on/off) on ALL platforms.
Agreed.

Comment 14

13 years ago
This really should be consistent. It shouldn't go back on Linux and Windows, and do nothing on Mac. If 
it's not fixed, it should be dropped on every platform, not just Mac.

Comment 15

12 years ago
> If it does get fixed, it should be configurable (on/off) on ALL platforms.

> If it's not fixed, it should be dropped on every platform, not just Mac.

Agree heartily with both of these. This annoying "functionality" should be
disabled, or the user allowed to disable it, as soon as possible.

Comment 16

12 years ago
You know, I don't want to debate the semantics and functionality of what a
Delete key should do.  The facts are:  

1. my Mac keyboard does not have a "browser back" key

2. all my other browsers work around this by having "delete" be the way to go
pack a page

It's generally accepted behavior, please adopt it.  It's very frustrating to
have FF be the only browser to not support this!  Until they redesign keyboards,
the existing keys sometimes have to serve additional and maybe even odd
purposes.  This is one of those cases.  PLEASE fix this bug and wire the Delete
key.  At least make it a user pref, in about or user.js.

Comment 17

12 years ago
(In reply to comment #16)
> 1. my Mac keyboard does not have a "browser back" key

My Windows and Linux keyboards do not have a "browser forward" key. The reason
this is not an issue is because we have 

> 2. all my other browsers work around this by having "delete" be the way to go
pack a page

You have a way to go back a page, it's called Alt (or Command, I think, for
Apple people)-Left. It works remarkably well in combination with Alt-Right. I
just tried this navigation out in Internet Explorer, and it worked just as I
expected it to. I also just installed Opera 8 and tried it there, with the same
result. So clearly the consistency you are wishing for is already extant.

> Until they redesign keyboards, the existing keys sometimes have to serve
additional and maybe even odd purposes.  This is one of those cases. 

Until they redesign keyboards, it is extremely easy to mis-strike
Backspace/Delete and cause the browser to jump back a page when you are not
expecting, let alone wishing, it to. On the other hand, it is near-impossible to
do this with Alt-Back.

Comment 18

12 years ago
(In reply to comment #17)
> because we have 

Sigh. Sorry. "...because we have the Alt-[Cursor] navigation method."

Updated

12 years ago
Blocks: 262905

Updated

12 years ago
Assignee: aaronleventhal → nobody
QA Contact: bugzilla → keyboard.navigation
(Assignee)

Comment 19

12 years ago
Created attachment 199112 [details] [diff] [review]
Enable backspace (delete) for history-back (and shifted equivalent for forward)

I used to think that backspace/delete was an evil shortcut, but I apparently
got accustomed enough to it after spending more time using non-Macs that I
found myself missing it today.

The arguments for doing this are platform parity and "everyone else does it on
the Mac."  Supply your own arguments against.
If Safari and IE do it, there isn't a compelling reason against that doesn't
apply to all platforms already using this.
(Assignee)

Comment 21

12 years ago
Comment on attachment 199112 [details] [diff] [review]
Enable backspace (delete) for history-back (and shifted equivalent for forward)

In that case, this is a quick and easy change that only involves removing
conditionals.
Attachment #199112 - Flags: review?(mconnor)
(Assignee)

Updated

12 years ago
Assignee: nobody → mark

Updated

12 years ago
Attachment #199112 - Flags: review?(mconnor) → review+
(Assignee)

Updated

12 years ago
Attachment #199112 - Flags: approval1.8rc1?
(Assignee)

Comment 22

12 years ago
Checked in on trunk.  This is a fast and easy fix that brings the Mac Firefox
keymappings in line with Firefox on other platforms, and in line with other Mac
browsers.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Flags: blocking1.8rc1?
Resolution: --- → FIXED

Comment 23

12 years ago
(In reply to comment #19)
> Supply your own arguments against.

Comment #17 was arguments against. As was comment #12. And many, many comments
in bug 262905.

So is this going to be a configurable preference, and if not, why not?

Updated

12 years ago
Blocks: 312089

Updated

12 years ago
Keywords: helpwanted

Updated

12 years ago
Attachment #199112 - Flags: approval1.8rc1? → approval1.8rc1+

Updated

12 years ago
Flags: blocking1.8rc1? → blocking1.8rc1+
(Assignee)

Comment 24

12 years ago
Fixed on the branch.
Keywords: fixed1.8
You need to log in before you can comment on or make changes to this bug.