Don't use sheet for the about box

VERIFIED FIXED in Firefox1.5

Status

()

Firefox
General
P2
normal
VERIFIED FIXED
14 years ago
13 years ago

People

(Reporter: Manfred Schubert, Assigned: Josh Aas)

Tracking

(Blocks: 1 bug)

unspecified
Firefox1.5
PowerPC
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Do not use a sheet for the about box. A sheet is for document modal dialogs. The
about box is neither document modal since it applies to the whole application,
nor is there a good reason for the about box to be modal at all.
Make the about box a modeless dialog window.

Reproducible: Always

Steps to Reproduce:
1. Select the menu Mozilla Firebird -> About Mozilla Firebirg
Actual Results:  
About sheet.

Expected Results:  
Modeless about box window.

Comment 1

14 years ago
confirmed Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6b)
Gecko/20031215 Firebird/0.7+

for reference, on winxp the about box is modal also, but i agree that a) it
certainly doesn't need to be a sheet and b) it doesn't need to be modal at all.
Severity: major → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

14 years ago
I like the about box being a sheet.
Re: comment #2 - this isn't really an issues of preference. The Apple Human
Interface Guidelines do not suggest using a sheet for the about box. Their
examples are modal windows:
http://developer.apple.com/documentation/UserExperience/Conceptual/OSXHIGuidelines/XHIGWindows/chapter_16_section_6.html#//apple_ref/doc/uid/20000961/TPXREF18

Comment 4

14 years ago
Quite correct, the About box is a window, not a sheet.

In fact, I found this bug while writing mine on similar issues: The XUL apps on
Mac OS X tend to overuse sheets. There are several windows that are sheets that
shouldn't be.
 
Here is the URL for this bug that offers details for when to use sheets (and
when not to use them). 

http://developer.apple.com/documentation/UserExperience/Conceptual/OSXHIGuidelines/XHIGDialogs/chapter_9_section_2.html#

About
Preferences
Mail/News Account Settings (Thunderbird and Mozilla)

Rather than creating a new bug, this bug will serve as my intended target for
these issues.

The items mentioned above can definately be stand-alone windows instead of
sheets per AHIG.

CCing myself to monitor as well as look into furter.
Flags: blocking-aviary1.0mac?

Comment 5

13 years ago
Wouldn't this bug fixed by bug 257546?  That's a general fix for using sheets
less and floating modal windows more.
(In reply to comment #5)
> Wouldn't this bug fixed by bug 257546?  That's a general fix for using sheets
> less and floating modal windows more.

Yep.

Updated

13 years ago
Depends on: 257546
No longer depends on: 257546

Updated

13 years ago
Depends on: 257546

Updated

13 years ago
Flags: blocking-aviary1.0mac?
The tb version of this bug is fixed (bug 271855). I will "port" its patch soon.
Assignee: firefox → bugs.mano
Severity: trivial → normal
No longer depends on: 257546
Priority: -- → P3
Target Milestone: --- → Firefox1.1
Blocks: 237584
Status: NEW → ASSIGNED
Priority: P3 → P2

Updated

13 years ago
Blocks: 277001

Updated

13 years ago
Flags: blocking-aviary1.1?

Comment 8

13 years ago
Yes, definitely make the about box a window, just like it is in every other Mac
OS X application.

And definitely do NOT make the about box modal. It shouldn't be restrictive.
What if the about box needs to be referred to while using the application, such
as filling out a web form?

Again, just check other applications, if not the guidelines themselves freely
available online and easy to peruse.
(Assignee)

Comment 9

13 years ago
Created attachment 178195 [details] [diff] [review]
fix v1.0
Assignee: bugs.mano → joshmoz
Attachment #178195 - Flags: review?(mconnor)

Updated

13 years ago
Attachment #178195 - Flags: review?(mconnor) → review+
Comment on attachment 178195 [details] [diff] [review]
fix v1.0

This isn't complete. In order to be HIG compatible, you need to get rid of the
"OK" button and the window title (but not the titlebar).

Ah, and get Command+W working...
Created attachment 178206 [details] [diff] [review]
complete fix
Attachment #178195 - Attachment is obsolete: true
Attachment #178206 - Flags: superreview?(mconnor)
Attachment #178206 - Flags: review?(joshmoz)
Comment on attachment 178206 [details] [diff] [review]
complete fix

err, i tought this tree was clean...
Attachment #178206 - Attachment is obsolete: true
Attachment #178206 - Flags: superreview?(mconnor)
Attachment #178206 - Flags: review?(joshmoz)
Created attachment 178207 [details] [diff] [review]
complete fix
Attachment #178207 - Flags: superreview?(mconnor)
Attachment #178207 - Flags: review?(joshmoz)

Comment 14

13 years ago
In Thunderbird branch build, there is trifling bug of bug274273. 
In Firefox, is the same problem brought up?
(In reply to comment #14)
> In Thunderbird branch build, there is trifling bug of bug274273. 
> In Firefox, is the same problem brought up?

Yes, and it's a general mac widget bug (we've a collapse toolbar button in every
window which isn't a dialog).
Comment on attachment 178207 [details] [diff] [review]
complete fix

r=me, as long as our resident Mac guru signs off.
Attachment #178207 - Flags: superreview?(mconnor) → superreview+
(Assignee)

Updated

13 years ago
Attachment #178207 - Flags: review?(joshmoz) → review+
(Assignee)

Comment 17

13 years ago
landed on trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Flags: blocking-aviary1.1?

Comment 18

13 years ago
Minor thing, the about dialog appears in the middle of the screen (vertically).
Compared to other mac apps (safari, IE, about this mac etc) it appears in a too
low position.
Blocks: 290389
Status: RESOLVED → VERIFIED
Blocks: 299713
You need to log in before you can comment on or make changes to this bug.