Closed Bug 230922 Opened 17 years ago Closed 16 years ago

Firefox should have sane defaults for set as default browser

Categories

(Firefox :: Preferences, defect)

x86
Windows 2000
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 216432

People

(Reporter: mconnor, Assigned: mconnor)

References

Details

(Keywords: conversion)

From bug 216501, we don't want to steal images, or other unsuitable filetypes.

Also need to ensure that the prompt to set as default browser follows the same 
process.  Possible solution is to modify winhooks to use a set of Mozilla prefs 
to determine what the "set as default" action from either the prefwindow or the 
dialog will set.  This seems like the most sane option for sharing the 
information, and allows for customization on an embeddor or end-user level.  It 
will also avoid the need to #ifdef winhooks any further.
*** Bug 230921 has been marked as a duplicate of this bug. ***
See also:
bug 131106, same bug for Seamonkey
bug 216501, Ability to pick and choose file associations when setting as default
browser (WONTFIX)
Is this prefs code shared with Seamonkey?  If so, this is a really easy fix.
this "prefs code" doesn't exist yet, I haven't looked at the relevant bits in
winhooks yet to determine what all needs to be done, however changing anything
in winhooks will require fixing seamonkey to use the new interface too
In that case, we should take the opportunity to fix bug 160896, which will solve
all sorts of problems.
that's nontrivial, timeless is working/planning on building a better winhooks,
but that won't be ready in time to fix this bug that way
Adding dependency on bug 131106

It is filed for seamonkey, and the status whiteboard says 'firebird 0.9', and
has been taken by Ben, so its reasonable to assume it will be fixed for both
browsers.
Depends on: 131106
Summary: Firebird should have sane defaults for set as default default browser → Firebird should have sane defaults for set as default browser
Keywords: conversion
Summary: Firebird should have sane defaults for set as default browser → Firefox should have sane defaults for set as default browser

*** This bug has been marked as a duplicate of 216432 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
that wasn't such a good assumption... removing that dependency, and also the bug
that's been duped.
No longer blocks: 216432
Status: RESOLVED → VERIFIED
No longer depends on: 131106
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.