Closed Bug 233028 Opened 17 years ago Closed 8 years ago

Make the account manager resizeable

Categories

(SeaMonkey :: MailNews: Account Configuration, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mscott, Unassigned)

References

Details

(Whiteboard: [Halloween2011Bug][2012 Fall Equinox])

Attachments

(1 file)

summary says it all
Attached patch the fixSplinter Review
Attachment #140585 - Flags: superreview?(bienvenu)
Attachment #140585 - Flags: review?(neil.parkwaycc.co.uk)
Respectively bug 89212
Attachment #140585 - Flags: superreview?(bienvenu) → superreview+
I disagree with that old assessment of Jennifer's. Besides, both our options and
account manager dialogs have way to many clipping issues when running with large
fonts vs. small fonts on windows (whic is a separate bug of course).

And making it resizeable does not mean that we have scrollbars along the right
hand side of the account manager which is something I remember Jennifer being
worried about at the time IIRC.
I think the Preferences dialog has a fixed size to prevent developers and
extension authors from putting to many widgets into a single pane. See bug 79948
and e.g. http://bugzilla.mozilla.org/show_bug.cgi?id=150251#c5.

The Account Manager is very similar to the Preferences dialog and thus shouldn't
be resizable for the same reasons and for consistency with the Preferences dialog.
OS: Windows XP → All
Hardware: PC → All
I'm happy to ifdef or fork this file if I can't get David and Neil to agree that
this is ok to do. But I'd rather avoid doing that. 
Status: NEW → ASSIGNED
We did make the account manager scale with the font size, which should eliminate
the large font problem... we also resized some of the panels (bug 222940). We
even stopped the header from pushing the panels out of the window (bug 222585).

Don't you want to back out the AccountManager.xul changes to attachment 133504 [details] [diff] [review]
(well, the id and persist changes, anyway) too?
Well, I tried bumping my fonts up to 16px with no ill-effects...
> We did make the account manager scale with the font size

Hey Neil, do you remember what change was made to do that? There are some other
dialogs (most notably the filter dialog) which don't scale with the font size
that I'd like to fix too. 

(In reply to comment #9)
> > We did make the account manager scale with the font size
> 
> Hey Neil, do you remember what change was made to do that? There are some other
> dialogs (most notably the filter dialog) which don't scale with the font size
> that I'd like to fix too. 

Ok, I'm not Neil, but since I introduced this change to the Account Manager,
I'll just answer the question anyway. ;-)

Example: Replace the width="100" and height="200" attributes of
<window>/<dialog>/<wizard> with style="width: 10em; height: 20em;". This way the
it gets a size proportional to the size of the used font.

See
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=AccountManager.xul&branch=&root=/cvsroot&subdir=mozilla/mailnews/base/prefs/resources/content&command=DIFF_FRAMESET&rev1=1.76&rev2=1.77

If you want to have this everywhere in MailNews/Thunderbird, I can offer to
contribute a patch to that effect in the 1.7b-cycle. Just file a bug on me.
I'm not too sure what's being refered to as the 'Preferences' dialog (as I don't
have the suite installed), but I know that the Options dialog boxes for both
Thunderbird and Firefox are resizable.  The Account Settings dialog box serves
much the same purpose as the Options dialog box in these programs, so it does
not make much sense that one box should be resizable and one should not.

Now, an argument for the case that both should be resizable over the case that
both be of fixed size is that I've been running into problems with information
being outside the fixed size of the Account Settings dialog box for a very long
time.  Some builds it's not an issue, some builds it is, sometimes it depends on
what theme I'm using, sometimes it depends on what Windows XP style I'm using
(not even an application-related issue).  The comment made in this related bug
report (http://bugzilla.mozilla.org/show_bug.cgi?id=79948#c22) implies that
leaving dialog boxes non-resizable serves a purpose of forcing developers to
make sure everything fits.  Three years after that comment was made there are
still occasional clipping issues in the dialog box; scaling with the font did
not eliminate this, and I doubt that anything else will eliminate this in the
next 3 years either.  Trying to conform to some pseudo-standard that Windows
dialog boxes shouldn't be resizable ("Why not?"  "Just because.") is silly and
continues to be an off-again/on-again pain in the average user's ass (read: my ass).

Making the Account Settings dialog box resizable would be very nice from an
average user's point of view, and would certainly not be the end of the world.
*** Bug 253040 has been marked as a duplicate of this bug. ***
Comment on attachment 140585 [details] [diff] [review]
the fix

You should also make the dialog's size persistent.
Product: Browser → Seamonkey
i have selected "arial unicode MS" as my systemwide font. the preferences dialog
and the account dialog get unusable because some widgets are not accessible any
more. the same is true for the firefox preferences/account dialog.
Scott, Neil,
Are you still working on this ?
QA Contact: nbaca → nobody
Assignee: mscott → nobody
Status: ASSIGNED → NEW
Duplicate of this bug: 630824
Blocks: 630824
Isn't is already fixed? Just check, account window is perfectly resizing on
Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20110928 Firefox/7.0.1 SeaMonkey/2.4.1
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111017 Firefox/10.0a1 SeaMonkey/2.7a1
Attachment #140585 - Flags: review?(neil)
This is partially fixed:
mailnews/base/prefs/content/accountUtils.js now has resizable, but the following two do not:
http://mxr.mozilla.org/comm-central/source/mailnews/base/prefs/content/accountcreation/emailWizard.js#1354
http://mxr.mozilla.org/comm-central/source/mail/base/content/featureConfigurators/autosync.js#257
Whiteboard: [Halloween2011Bug][good first bug]
Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1 ID:20120921110141 c-c:f181aef1ee3f m-c:3c68fdd4f77a

I've tried three different themes including both Modern and Default, and AFAICT all pages of both the Preferences dialog and the Account wizard can be resized (here on Linux) by dragging their bottom-right corner.

AFAICT the "smart" account-creation wizard (which can guess values based on your email address) is Thunderbird-only. I tried to start the account-creation wizard on gmail.com and it didn't know the right port or the right server.

Also, autosync.js has moved. The only file of that name is now found at http://mxr.mozilla.org/comm-central/source/mail/components/activity/modules/autosync.js

So:
- Did I misunderstand what is meant by "resizable"? Or is this bug not felt on Linux?
- Is this bug relevant for SeaMonkey? (neither of the files mentioned in comment #18 is in the suite/ hierarchy). If it is, by which sequence of mouse and/or keyboard actions can I display the "unresizable" dialog?
Whiteboard: [Halloween2011Bug][good first bug] → [Halloween2011Bug][good first bug][2012 Fall Equinox]
The account manager is resizable when called from SeaMonkey. There is one path reachable only in Thunderbird which opens the account manager without the resizable attribute.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Whiteboard: [Halloween2011Bug][good first bug][2012 Fall Equinox] → [Halloween2011Bug][2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.