MailViews and Search on custom-header: implement new choices for matching criteria

RESOLVED FIXED in Thunderbird 3.0b4

Status

MailNews Core
Search
--
enhancement
RESOLVED FIXED
14 years ago
8 years ago

People

(Reporter: Mike Cowperthwaite, Assigned: rkent)

Tracking

(Blocks: 1 bug)

Trunk
Thunderbird 3.0b4

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
In bug 224318, message filters were enhanced such that when a custom filter was 
selected as a criterion, the match selections now include "doesn't contain" and 
"isn't".  These options should be brought over to MailViews and Search.
(Reporter)

Updated

13 years ago
Summary: MailViews and Search on custom-header: implement new choices for matching → MailViews and Search on custom-header: implement new choices for matching criteria
(Reporter)

Comment 1

13 years ago
*** Bug 260777 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Updated

12 years ago
Assignee: sspitzer → mail
(Reporter)

Comment 2

12 years ago
David, is this hard?  I was trying to figure this out, and I think the code that 
needs to be tweaked is in  nsMsgLocalSearch.cpp  at
  nsMsgSearchValidityManager::InitLocalNewsTable()

But this stuff is pretty confusing; for instance, I don't know why the word 
"News" is part of that method name.

I didn't even look at the IMAP case.
(Reporter)

Comment 3

12 years ago
See also bug 146676.

Updated

11 years ago
Blocks: 201500
(Reporter)

Updated

11 years ago
Duplicate of this bug: 366485

Updated

9 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
Assignee: mail → nobody
QA Contact: search → message-display
(Assignee)

Comment 5

8 years ago
These criteria also affect manual filters, which use the same validity table. I think they work, it is as simple as enabling them.
Assignee: nobody → kent
Status: NEW → ASSIGNED
Component: MailNews: Message Display → Search
Product: SeaMonkey → MailNews Core
QA Contact: message-display → search
Target Milestone: --- → Thunderbird 3.0b4
(Assignee)

Comment 6

8 years ago
Created attachment 391196 [details] [diff] [review]
turn on new operators for offline mail
Attachment #391196 - Flags: superreview?(neil)
Attachment #391196 - Flags: review?(neil)
(Assignee)

Updated

8 years ago
Whiteboard: [needs r/sr Neil]

Comment 7

8 years ago
Comment on attachment 391196 [details] [diff] [review]
turn on new operators for offline mail

I agree, it looks as if it should Just Work.
Attachment #391196 - Flags: superreview?(neil)
Attachment #391196 - Flags: superreview+
Attachment #391196 - Flags: review?(neil)
Attachment #391196 - Flags: review+
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
Whiteboard: [needs r/sr Neil] → [needs checkin]
Checked in: http://hg.mozilla.org/comm-central/rev/18cec05d4843
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [needs checkin]
(Assignee)

Updated

8 years ago
Duplicate of this bug: 466295
You need to log in before you can comment on or make changes to this bug.