Support Command-. (Command-Period) keyboard shortcut for Stop on OS X

RESOLVED FIXED in Firefox1.5

Status

()

Firefox
Keyboard Navigation
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: Darkside, Assigned: mano)

Tracking

({access})

unspecified
Firefox1.5
PowerPC
Mac OS X
access
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Command-Period is a stardard keyboard shortcut to Stop loading a page.  Internet
Explorer, Safari, and even Mozilla use it in addition to Escape (which is a
"hidden" shortcut, not listed in the menu).

Even though Mozilla doesn't list Command-Period as a keyboard shortcut in View >
Stop, it still works.  IE and Safari correctly list the shortcut in their menus.

Reproducible: Always
Steps to Reproduce:
1. Begin loading any webpage.
2. Press the Command and Period (.) keys.

Actual Results:  
The page continues to load.

Expected Results:  
The page should Stop loading, as if the Stop button was clicked or the View >
Stop menu item was selected.

Updated

14 years ago
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Stop menu needs Command-. (Command-Period) keyboard shortcut → Support Command-. (Command-Period) keyboard shortcut for Stop on OS X

Updated

14 years ago
Assignee: firefox → bugs
Component: Menus → OS Integration
Flags: blocking1.0mac+
QA Contact: bugzilla → firefox.os-integration

Comment 1

14 years ago
*** Bug 250702 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
Confirmed; this bug still exists on Firefox 0.9.1 on OS X 10.3.4.  Escape stops
the load but neither Cmd-. and Cntl-. do anything at all.
Assignee: bugs → bugs.mano
no 1.0mac, wont-be-fixed for 1.0 (l10n freeze).
Severity: enhancement → normal
Status: NEW → ASSIGNED
Flags: blocking-aviary1.0mac+
Target Milestone: --- → Firefox1.1

Updated

13 years ago
Blocks: 237584

Updated

13 years ago
Flags: blocking-aviary1.1?
Created attachment 171440 [details] [diff] [review]
v1

We should still support ESC on mac (but expose Accel+. in the UI).
Attachment #171440 - Flags: review?(mconnor)
mconnor, this one is pretty simple ; )
Component: OS Integration → Keyboard Navigation
Keywords: access
Comment on attachment 171440 [details] [diff] [review]
v1

needs update.
Attachment #171440 - Attachment is obsolete: true
Attachment #171440 - Flags: review?(vladimir)

Updated

13 years ago
Attachment #175853 - Flags: review?(mconnor) → review+
Checking in locales/en-US/chrome/browser/browser.dtd;
/cvsroot/mozilla/browser/locales/en-US/chrome/browser/browser.dtd,v  <-- 
browser.dtd
new revision: 1.12; previous revision: 1.11
done
Checking in base/content/browser-menubar.inc;
/cvsroot/mozilla/browser/base/content/browser-menubar.inc,v  <-- 
browser-menubar.inc
new revision: 1.45; previous revision: 1.44
done
Checking in base/content/browser-sets.inc;
/cvsroot/mozilla/browser/base/content/browser-sets.inc,v  <--  browser-sets.inc
new revision: 1.40; previous revision: 1.39
done
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Flags: blocking-aviary1.1?
Resolution: --- → FIXED

Updated

13 years ago
Blocks: 284405
You need to log in before you can comment on or make changes to this bug.