No new mail popup when new mail is marked as junk

RESOLVED DUPLICATE of bug 233929

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 233929
14 years ago
13 years ago

People

(Reporter: Frederik De Caster, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Please do not display (or provide an option to disable) the new mail popup when
the new mail has been marked as junk. The new mail pop up should only appear
when Thunderbird thinks the mail is not junk.

Reproducible: Always
Steps to Reproduce:
1. Receive new mail
2. Mail marked as junk
3. New mail pop up appears

Actual Results:  
Well, I have been annoyed several times allready because the new mail was spam,
which Thunderbird correctly had marked as junk. As a user I do not want to be
informed about junk mail arriving...

Expected Results:  
I believe there should be an option, where the user can specify whether there
should be a new mail pop up or not when a new mail arrives that is marked as junk.

Comment 1

14 years ago
What version of Thunderbird do you use?
This issue was fixed, at least in Mozilla MailNews. See bug 189289.
(Reporter)

Comment 2

14 years ago
I have version 0.7 (20040616).

I checked it by sending an e-mail to my account handled by thunderbird and
making sure it would be marked as junk. When I received the mail the new mail
message popped up even though the mail was marked as junk.

Is there perhaps an option allready to turn this on/off and I just looked passed it?

Comment 3

14 years ago
(In reply to comment #2)

> I checked it by sending an e-mail to my account handled by thunderbird and
> making sure it would be marked as junk. 
Is the message automatically marked as junk or by a filter? Perhaps something
like bug 228131 comment 2.
Same as Bug 248758?
(Reporter)

Comment 5

14 years ago
I have paid special attention to this matter the entire day, and I have noticed
on several occasions that Thunderbird displayed the new mail message and placed
the new mail icon in the notification area when only junk mail had arrived.

Furthermore a collegue of mine at work has also experienced the same problem.

I am not using any special filters, just regular Thunderbird functionality.
(Reporter)

Comment 6

14 years ago
Ok, I think I know what the problem is...

There is an option in Tools/Junk Mail Control which enables mail marked as junk
to be sent to a "Junk" folder. I didn't have this option on as I still wanted
the junk mail to appear in my inbox folder as sometimes things get marked as
junk which aren't junk at all and I didn't want to miss any mails.

So if the mail marked as junk is sent to the inbox the new mail message pops up.
I just tried it with sending mail to the "Junk" folder, and I didn't get a
message then.

But as said I don't want the junk mail to appear in a seperate folder, as I
cannot afford to overlook mails because of professional reasons. But then again
I do not want to be warned about every junk mail that comes through.

Would it be possible to include an option "Never warn about junk mail" in a
future version of Thunderbird?

Comment 7

13 years ago

*** This bug has been marked as a duplicate of 233929 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.