Closed Bug 252412 Opened 16 years ago Closed 15 years ago

livemark in bookmarks folder causes the folder to collapse the 1st time it's opened

Categories

(Firefox :: Bookmarks & History, defect)

1.0 Branch
x86
Windows 2000
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: Peter6, Assigned: vlad)

References

Details

1.Add a livemark to your bookmarks
2.Close FF
3.Open FF
4.Press on Bookmarks
The folder will expand for a moment and collapse right away
The second time Bookmarks is pressed it works as normal.

(this only happens if a livemark is present in the bookmarks folder)

I assume the collapse is a result of the livemarks being updated

expected: Bookmark Folder not to collapse when pressed the first time
Confirming this bug on Windows Xp Home.
I can confirm this using: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.7) Gecko/20040805 Firefox/0.9.1+.
Seems to me it's fixed now (Aug. 12 2004)despite of now mention in the recent
nightlies (20040810, 20040811) release notes nor here. At least on XP. Anybody
having the same experience? I'm asking becouse the bug is tied to Win2k only,
although more platforms have been confirmed.
Bug not fixed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2)
Gecko/20040812 Firefox/0.9.1+ on Win Xp Home
This bug (probably) won't be fixed until the Live Bookmark refresh process will
executed if the user is not selecting Bookmarks.
Flags: blocking-aviary1.0PR?
From an engineering viewpoint having livemarks which collapse the Bookmarks may
seem not critical, but a 1.0 release with this defect will not be a very smart
marketing strategy. If the bug cannot be resolved for 1.0, I would suggest
suppressing livemarks and delivering a Bookmarks feature which works normally. 

Many users ignore livemarks anyway and will not miss them.
Somehow I'm not seeing this bug anymore.
At least not in any of the nighly aviary builds of the past week or so.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040817
Firefox/0.9.1+
It was still present in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.7.2) Gecko/20040816 Firefox/0.9.1+
and is still present in my Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.7.2) Gecko/20040817 Firefox/0.9.1+. With this version, once Livemlark
folder is deleted the collapse disappears. Collapse comes back when a new
Livemark folder is created. It seems that collapse may be deferred until the
mouse is moved after the first click on Bookmarks.
Mabye related to all the
document-refresh-stealing-focus issues? See for example bug 254894, bug 137015
and bug 164339.
vlad have you had a chance to look at this?
(In reply to comment #10)
> vlad have you had a chance to look at this?

I'm having a hard time reproducing it on linux, and was going to get a windows
build going -- for those who can see the bug, can you describe exactly what
steps you take to see it?  I see the steps in the first comment, but I'm not
sure which Bookmarks we're talking about here; does "press on Bookmarks" refer
to the Bookmarks menu, the Bookmarks toolbar item (that toggles the toolbar off
and on), or something else?

Status: NEW → ASSIGNED
Bookmark Menu Vlad (5th button from top-left).

This seems to be similar to the late livemark in bookmarks crash bug, it only
happens with certain livemarks. Like in the crash bug, the livemark from
mozilla.org doesn't cause the collapse but the livemark from mozillazine.org
collapses the menu (http://mozillazine.org/contents.rdf). Hope this helps in
reproducing the bug.
This problem is still very present, I have one single folder in my Bookmarks
Toolbar Folder containing all my live bookmarks, and it keeps collapsing a _lot_
the first few times I try to open it. Not just once, more like three to five
times in a short span. For the record, I've got eleven feeds in there.

I don't see this bug as being critical for 0.10, but it definitely should be
handled before the 1.0 release, as it's fairly blatant and annoying (which kind
of ruins the Find Stuff Faster philosophy, that live bookmarks shine a new light
at).

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040820
Firefox/0.9.1+
Flags: blocking-aviary1.0?
Live bookmark collapses when updating the live bookmark.
1. Open a live bookmark (which needs to be updated)
2. An Upating message is displayed as only item in the live bookmark.
3. After the update the folder just collapses instead of showing the items.
(In reply to comment #15)

Do you mean when clicking "Refresh Live Bookmark"?  This seems like the expected
behavior to me, clicking on any menu item will collapse the menu.
This happens following the automatic update of Live Bookmarks by FF, which is
triggered by the first opening of the Bookmarks (on the main menu - File Edit,
etc.) after FF is launched. Not when clicking on "Refresh Live Bookmarks". 
To help reproduce this bug:

When my bookmarks contain the feeder
http://www.squarefree.com/burningedge/index.rdf 
the menu DOES NOT collapse.

After adding the feeder
http://www.extensionsmirror.nl/peter6/firefoxfeed.xml
the menu collapses first time it is opened in a FF Session. Also, when this
feeder is the only Live Bookmarks present the menu collapses.

Hope this helps.
(In reply to comment #16)
> (In reply to comment #15)
> 
> Do you mean when clicking "Refresh Live Bookmark"?  This seems like the expected
> behavior to me, clicking on any menu item will collapse the menu.

Sometimes (after not opening FF a day or so) FF will display one item inside the
Live Bookmark saying it is updating.
After the by FF triggered update the Live Bookmark collapses (it should stay open).
minus for PR, lets try and get this for final.  vlad or someone renominate if a
patch becomes available next week.
Flags: blocking-aviary1.0PR? → blocking-aviary1.0PR-
Yep happen here as well :)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040920
Firefox/0.10
The same problems here. It happens as described with the livemarks "Latest
Headlines" of BBC news on Windows XP. It makes no difference where this
livemarks are stored. The bookmarks menu closes on first opening after a browser
restart.
I've been running into this on WinXP Pro SP2, too. (Mozilla/5.0 (Windows; U;
Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10)

Steps to reproduce:
1) Put your Live Bookmarks in a folder (e.g., "Feeds").
2) Put that folder in your Bookmarks Toolbar folder.
3) Close and re-open Ff.
4) Click on the "Feeds" folder in your Toolbar and watch it collapse immediately
(for me, usually 2-3 times, once or twice even crashing Ff).

A suggestion:
Perhaps the Live Bookmarks should not be accessible in the first X seconds of
starting Ff, so the feeds can be updated. Then, when all the Live Bookmarks are
done loading, unlock them.
As far as I can see, this isn't a live bookmark bug, but something deep in the
menu code.  As such, it's very scary code and I don't really want to touch it
this close to 1.0.  If I get motivated, I'll try to figure it out this weekend,
but it sohuldn't block 1.0.
Flags: blocking-aviary1.0? → blocking-aviary1.0-
*** Bug 261320 has been marked as a duplicate of this bug. ***
WFM after patch bug 259682 was checked in
(In reply to comment #26)
> WFM after patch bug 259682 was checked in

Bug still present in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3)
Gecko/20041004 Firefox/0.10 (MOOX M2)

as well as in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3)
Gecko/20041003 Firefox/0.10 
Doesn't work for me unfortunately.
It came back after a reboot.
Yeah, seems like I was a bit too hasty saying wfm after landing 259682 patch.
However, it did have an effect on this too. Ever since introducing the livemarks
my bookmarks menu has collapsed three times after every browser launch, now it
collapses only once ~75% of the time and not at all for the remaining time.
Not sure if this effect is related, but weird:

I have a folder in my Bookmarks. It contains 3 Livemarks, then one regular
bookmark, then 3 more Livemarks. Opening the folder from the Bookmarks menu, I
MUST highlight and expand one of the top 3 Livemarks BEFORE expanding one of the
bottom 3, or the whole menu closes.
*** Bug 260956 has been marked as a duplicate of this bug. ***
*** Bug 271714 has been marked as a duplicate of this bug. ***
Having confirmed this bug earlier (2004-09-24 ), it is also existing now in
trunk nightlies since branch and trunk merged together.
It has become even worse; when I open no-matter-what menu or context-menu after
a browser-restart, the menu closes. It happens with the default set of
livemarks: http://news.bbc.co.uk/
Flags: blocking-aviary1.1?
also,
if you are going through a proxy and have to enter credentials first, the live
bookmarks entry says 'live updates not available' and never updates itself
unless you right-click and select 'refresh'. 

maybe it could do a retry every few minutes or something to save having to do this?
why is this closed? it still exists on windows xp: Mozilla/5.0 (Windows; U;
Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

In fact it seems worse because even when i have entered my proxy details to
visit a url (when mozilla is not previously loaded) the live bookmarks is
populated correctly but the bookmarks menu closes itself the first time.

Previously I'm sure it only did this when your proxy had not been authenticated
and the live bookmarks had no entries.

Neil.
My sister (who knows nothing about computers) made me notice something.
I don't know if it's already been discussed.

- Close Firefox
- Open Firefox
- Click on the arrow on the right of the address bar (the one that is supposed
to show HISTORY)
- It WILL ONLY WORK the second time you try.
The first time, it only appear in a blink of eye and disapear. Then on, it works
every time.

(tried on 3 diferent computers)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050630
Firefox/1.0+ ID:2005063011
This is now WORKSFORME in the 2005-06-29 build, I can see the bug in the
2005-06-28 build.
I think this bug could be fixed by bug 254894.
I bookmarked two livemarks which caused heavy problems before, but the problem
doesn't occur anymore.
Bokkmarks menu now stays open on first click with several RSS feeds.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050630
Firefox/1.0+ ID:2005063006
Ok, marking fixed then. Fixed by the fix for bug 254894.
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Depends on: 254894
Resolution: --- → FIXED
Flags: blocking-aviary1.1?
*** Bug 311871 has been marked as a duplicate of this bug. ***
Windows 2000 SP4/firefox 1.0.7 still ocurrs
*** Bug 311871 has been marked as a duplicate of this bug. ***
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.