Last Comment Bug 2564 - [DOGFOOD] [PP] Scrolling a long document yields text overwriting itself
: [DOGFOOD] [PP] Scrolling a long document yields text overwriting itself
Status: VERIFIED FIXED
[PDT+] fix attached
:
Product: Core
Classification: Components
Component: Layout: Form Controls (show other bugs)
: Trunk
: Other Linux
P1 critical (vote)
: M11
Assigned To: Stuart Parmenter
: Chris Petersen
: Jet Villegas (:jet)
Mentors:
: 12298 13389 13657 13690 14212 16045 16174 16809 17238 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-22 14:00 PST by Simon Fraser
Modified: 1999-11-12 16:05 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
sample long doc (911.41 KB, text/html)
1999-09-01 23:45 PDT, Ramiro Estrugo
no flags Details
patch to fix bug (2.67 KB, patch)
1999-10-31 16:38 PST, David Baron :dbaron: ⌚️UTC-8
no flags Details | Diff | Splinter Review

Description User image Simon Fraser 1999-01-22 14:00:36 PST
Load the above URL in viewer, and wait for it to finish loading. Then scroll
down. Notice that there are large areas which are completely blank (I see
two of them), as if some big chunks of the document have been rendered at
the wrong offset. There is nothing in the HTML that should cause these blank
areas.

This does not occur on Windows, where the entire file has no gaps.

An additional test would be to scroll the document up and down while it is
rendering, and see if that causes any positioning problems.
Comment 1 User image Pierre Saslawsky 1999-01-22 16:33:59 PST
Bug #2385 also refers to big blank sections on the Mac.
Comment 2 User image Pierre Saslawsky 1999-01-25 21:43:59 PST
Bug #2385 has been closed as dup of #2615. Apparently this problem and the one in
#2385/#2615 are different.
Comment 3 User image leger 1999-02-03 07:15:59 PST
Inserting Milestone info.
Comment 4 User image leger 1999-02-03 08:08:59 PST
Setting all current Open/Normal to M4.
Comment 5 User image Paul MacQuiddy 1999-03-05 22:38:59 PST
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser
Comment 6 User image Pierre Saslawsky 1999-04-07 00:44:59 PDT
Changed target to M5
Comment 7 User image Pierre Saslawsky 1999-04-28 16:40:59 PDT
I tried with a recent build on Windows and I got a very similar problem except
that instead of "big blank sections", we have big "black" sections. The "black"
sections contain text that is overlayed over and over.

Reassigned to kipp.
Comment 8 User image Pierre Saslawsky 1999-04-28 17:14:59 PDT
Bug #1117 might be related to this one.
Comment 9 User image Patrick C. Beard 1999-04-29 13:27:59 PDT
I've fixed this on the Mac, still puzzled on Win95.
Comment 10 User image kipp 1999-04-30 14:24:59 PDT
On linux we get smearing - it seems that the drawing of the background fails in
these situations. I suspect that the coordinate math isn't handling the large
coordinates that this results in (3,465,066 twips or 231,004 pixels!)
Comment 11 User image Kevin McCluskey (gone) 1999-06-02 14:45:59 PDT
This is probably a coordinate overflow problem. On Win95
nsRenderingContext::SetClipRect and nsRenderingContext::FillRect need to have
the rectangles that they pass to the native rountines conditioned to prevent the
top and bottom of the RECT to be within WIN95's acceptable range. This is
probably what GTK needs as well.
Comment 12 User image leger 1999-06-21 17:47:59 PDT
Moving all Widget Set bugs, past and present, to new HTML Form Controls
component per request from karnaze.  Widget Set component will be retired
shortly.
Comment 13 User image ramiro 1999-08-11 09:11:59 PDT
m10
Comment 14 User image ramiro 1999-09-01 23:45:59 PDT
Created attachment 1504 [details]
sample long doc
Comment 16 User image ramiro 1999-09-01 23:52:59 PDT
Changed URL, marking assigned, m11.

I see the bug, the problem is that the arguments to XFillRectangle()
(gdk_draw_rectangle() actually) are overflowing at -(2^15) and +(2^16) cause of
the 'unsigned int' limit of x windows.

So, im going to add some code to clamp all arugments to X lib functions.
Comment 17 User image ramiro 1999-09-01 23:53:59 PDT
*** Bug 12298 has been marked as a duplicate of this bug. ***
Comment 18 User image David Baron :dbaron: ⌚️UTC-8 1999-09-06 15:48:59 PDT
This causes problems with http://www.w3.org/TR/REC-CSS1 once you've scrolled
about 2/3 of the way down.  I think it's the same problem as bug 1177 (not
1117!), which covered the fixes for Mac and Win95.
Comment 19 User image David Baron :dbaron: ⌚️UTC-8 1999-09-06 15:56:59 PDT
There are some comments relating to this bug on bug 6048.
Comment 20 User image kipp 1999-09-13 07:29:59 PDT
*** Bug 13389 has been marked as a duplicate of this bug. ***
Comment 21 User image leger 1999-09-13 21:09:59 PDT
*** Bug 13657 has been marked as a duplicate of this bug. ***
Comment 22 User image Mats Palmgren (:mats) 1999-09-17 16:51:59 PDT
*** Bug 14212 has been marked as a duplicate of this bug. ***
Comment 23 User image David Baron :dbaron: ⌚️UTC-8 1999-09-19 20:06:59 PDT
*** Bug 13690 has been marked as a duplicate of this bug. ***
Comment 24 User image ramiro 1999-10-08 09:41:59 PDT
I see the bug, the problem is that the arguments to XFillRectangle()
(gdk_draw_rectangle() actually) are overflowing at -(2^15) and +(2^16) cause of
the 'unsigned int' limit of x windows.

So, im going to add some code to clamp all arugments to X lib functions.
Comment 25 User image Eli Goldberg 1999-10-11 14:22:59 PDT
*** Bug 16045 has been marked as a duplicate of this bug. ***
Comment 26 User image Mats Palmgren (:mats) 1999-10-12 09:33:59 PDT
*** Bug 16174 has been marked as a duplicate of this bug. ***
Comment 27 User image Eli Goldberg 1999-10-12 09:35:59 PDT
As a courtesy, I've changed the bug description to reflect the behavior reported

by the many people who are still reporting this bug, in the hopes that it may be

easier for them to find. (Both here, and on the Most Frequent Bugs page.)
Comment 28 User image Simon Fraser 1999-10-20 23:25:59 PDT
Reassign to pavvy pav pav
Comment 29 User image kipp 1999-10-27 18:47:59 PDT
*** Bug 17238 has been marked as a duplicate of this bug. ***
Comment 30 User image Stuart Parmenter 1999-10-29 01:29:59 PDT
*** Bug 16809 has been marked as a duplicate of this bug. ***
Comment 31 User image David Baron :dbaron: ⌚️UTC-8 1999-10-31 16:38:59 PST
Created attachment 2519 [details] [diff] [review]
patch to fix bug
Comment 32 User image David Baron :dbaron: ⌚️UTC-8 1999-10-31 16:40:59 PST
The above patch fixes the problem for me.  You might want to fiddle with the
numbers a little (perhaps even see how gdk_draw_rectangle works and give it more
margin for error if you think it's necessary).  Also, I'm not sure if it's
needed on InvertRect.  It probably is for DrawRect, though, since someone might
put a border around the CSS1 spec someday...
Comment 33 User image leger 1999-11-01 17:07:59 PST
Putting on PDT+ radar.
Comment 34 User image Stuart Parmenter 1999-11-01 19:38:59 PST
looks good.  checked in fix.
Comment 35 User image Chris Petersen 1999-11-12 16:05:59 PST
Fixed in the Nov 12 Linux build.

Note You need to log in before you can comment on or make changes to this bug.