bookmarks repeatedly erased

RESOLVED DUPLICATE of bug 249150

Status

()

Firefox
Bookmarks & History
--
critical
RESOLVED DUPLICATE of bug 249150
14 years ago
12 years ago

People

(Reporter: Kent Eschenberg, Unassigned)

Tracking

({dataloss})

Trunk
x86
Linux
dataloss
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Firefox/1.0

Every few weeks Firefox just erases my bookmarks. This has been going on for at
least the past year, in multiple versions of Firefox. It seems to be random.

There might be a correlation between running Mozilla and the bookmarks. On
occasion, something else will run Mozilla. I didn't even know I had Mozilla; I
can't find it and erase it. I've erased anything that says Netscape. After I
delete the Mozilla program, and start Firefox, the bookmarks are gone.

This has to be made an urgent problem or I will have to stop recommending
Firefox. I waste hours recovering lost bookmarks each time Firefox erases them.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
WFM:

Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Mozilla 1.7b Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040316

I don't observe any such behaviour and haven't lost bookmarks for years.

Comment 2

14 years ago
Please have a look with a file manager where your Firefox Profile is located.
I do have multiple Mozillas and two Firefoxes on Windows, sometimes installed
from exe, mostly just an unpacked zip-build.
My default Firefox profile is located in 
ApplicationData\Firefox\Profiles\default\xxxxxxxx.slt
My named Firefox Profile is located in
ApplicationData\Mozilla\Firefox\Profiles\default\yyyyyyyy.name
My default Mozilla Profile is located in
ApplicationData\Mozilla\Profiles\default\zzzzzzzz.slt
xxx.. yyy.. zzz... stands for the randomized profile names.

Normally, if you deinstall Mozilla, at least on Windows, your profile data is
left on disk, so when you install the next one, your profile data like
passwords, cookies, bookmarks, history, cache etc. can be used by the new
browser. If however you manually delete everything, that data, including your
bookmarks, will also get lost.
Using about:config, with string browser.bookmarks.file you also can specify a
different location for your bookmarks file. Don´t know if that is working also
in Firefox. That pref is the result of the 'Open Bookmarks File' in Mozillas
Bookmark Manager, a function not available in Firefox.
To get it working, you must have a valid bookmarks file in the directory you
want to specify, so I just copy an empty bookmarks file from a fresh created
profile to my bookmarks folder, make some copies, and give them different names,
so I can open and use different bookmarks files, one at a time.
Assignee: general → vladimir
Component: Browser-General → Bookmarks
Product: Browser → Firefox
QA Contact: general → mconnor
Flags: blocking-aviary1.0?
Keywords: dataloss
are you deleting the ~/.mozilla folder in your profile? If so, you're probably
nuking your entire Firefox profile.

It might be a good plan to make a backup, then keep track of what you're
deleting before this happens.  Under Bookmarks Manager, do File-Export

Comment 4

14 years ago
The new safe-save file writer should have fixed this anyway, but
non-reproducable bugs can't block this release.
Flags: blocking-aviary1.0? → blocking-aviary1.0-

Comment 5

14 years ago
This has happened to people on Windows 2000 and Windows XP as well.

A quick search of bugzilla has found a bunch of possible dupes:
Bug 264677, Bug 260243, Bug 263488, and Bug 249602.

Assignee: vladimir → vladimir+bm

Comment 6

13 years ago
This has happened to me twice now, once after starting my computer following New
Years holiday, once today (February 1).  I would guess a relation to new month,
however bookmarks were working this morning, then my computer locked-up, and
following manual shut-down and restart the bookmarks were gone.  Using  release
version: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Comment 7

13 years ago
This is gonna be a dupe of bug 249150.  Similar occurences under similar
circumstances in a similar time frame.

*** This bug has been marked as a duplicate of 249150 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Assignee: vladimir+bm → nobody
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.