Bug 249150 (lostbookmarks)

Bookmarks file is overwritten (deleted) randomly in Firefox versions without places

RESOLVED INVALID

Status

()

defect
--
critical
RESOLVED INVALID
15 years ago
11 years ago

People

(Reporter: b2mhg, Unassigned)

Tracking

({dataloss})

unspecified
x86
All
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8b2 -
blocking1.8b3 -
blocking1.8b5 -
blocking-aviary1.5 -
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: read comment #44 first)

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

Searched through all directories for the bookmarks and could only find a
bookmark file with the correct information from about 1 month ago.  However,
could not find the information in any files for bookmarks saved to same
directory since the upgrade to 0.9

Reproducible: Always
Steps to Reproduce:
1.Bookmarks
2.
3.

Actual Results:  
see Details,  also, it does not import the IE favorites; however, 0.8 did import
them.

Expected Results:  
not deleted or overwritten existing files in a user folder

AMD Athlon 1100
Quatum 20 Gig ATA
Linksys network
ATI 9200 Radeo, 256MB
256MB memory
Abit KA-7 motherboard
1.44 fd
lg 52X cdr
samsung cdrw
viewsonic ve175
logitech cordless trackball
ms natural kb
creative 128 sc

Comment 1

15 years ago
Unable to reproduce with 0.8 profile and the latest 0.9 branch build on windows. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Summary: Bookmarks from 0.8 are missing in 0.9 and cannot be found on system. → Bookmarks from 0.8 are missing in 0.9 and cannot be found on system.
Reporter

Comment 2

15 years ago
Well, it happened again.  Everything was working fine in 0.9.2. This morning
everything was great.  Tonight I open the browser and the bookmarks are gone. 
Also, all extensions and themes I installed are gone.  I installed the bookmark
backup extension, but cannot find a backup of the bookmarks.  To my knowledge, I
do not have any viruses.  Computer is running just fine, except for this weird
thing.  This is not happening on my work computer.  
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Reporter

Comment 3

15 years ago
OK, I did a file search for bookmark.html and found the bookmark backup file
created by the bookmark backup extensions (Thanks!).  I now have my bookmarks
back from when my wife had to try and find all of her other sites from the last
loss.  I have since reloaded all extensions and themes I use and will now see if
it does it again.  I thought maybe someone went into safemode and it would not
revert back , but after I tried that, there was not a difference between my
modified version and the safemode version.  Maybe that is another bug. 
Shouldn't safe mode be the base program?? oh well, I will do that later.

Comment 4

15 years ago
I'm having a similar problem. In Firefox 0.8. This morning I restarted my
computer (after a Norton Antivirus Live Update session) and upon restart,
Mozilla told me that there was an "Important Security Update for Firefox." My
usual homepage did not load.

Then, I downloaded 1.0, but I have not installed it. After downloading, I went
to my bookmarks to load my sites, and my bookmarks were gone! All of the folders
are there, including my imported IE favorites, but none of my bookmarks. 

I'm certain that the bookmarks were missing when I restarted. Obviously just
downloading the new version to my hard drive had nothing to do with it, I'm not
assuming that.

As far as bookmark.html and all of that goes, I've searched for it. I found a
file (actually 2) named bookmark in my Firefox folder,  but they're both default
 Firefox bookmarks, not my bookmarks. What a headache. Some of my bookmarks took
hours to research! Any help would be appreciated.

Comment 5

15 years ago
Scott: firefox should store a backup in your profile (bookmarks.bak).

Bruce: judging from comment 2 this bug is not about bookmarks migration, but
about unreproducable bookmarks-loss. Changing summary (0.8->0.9 transition is
irrelevant now, anyway). Can you still reproduce it on a newer build?
Summary: Bookmarks from 0.8 are missing in 0.9 and cannot be found on system. → Bookmarks file is overwritten (deleted) randomly

Comment 6

15 years ago
*** Bug 254291 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
Another instance.
Installed Firefox RC0 on Linux FC2.  Had previously had the preview release.
Appeared to work without problems the day I installed with bookmarks intact.
First time of use today, all my bookmarks had gone.  Being a fool I didn't have
a recent backup.

Would be nice if when Firefox encounters a bookmarks file it doesn't like it
backed it up before writing a shiny new bookmarks file.

A similar thing happened to me about 3 releases ago, except that that time it
happened the first time I ran Firefox. 

Comment 8

15 years ago
Installed Firefox on 11/11/2004. There had been about 10,000 old bookmarks which
I imported from a Netscape 4.79 file size = ~2.2 MB, and perhaps just over 100
new bookmarks I added since getting Firefox 1.0 installed. No problems for
several weeks since 1.0 was downloaded and installed. 

The only thing I recall that I did or changed was to install new anti-virus
software (AVG 7.0 Free) and do a complete scan of my computer and hard drives. I
do not know if this software install, or the virus scan had anything to do with
the loss of the bookmarks. 

But, next thing I knew, next time I opened Firefox 1.0 bookmarks were all gone,
reset = 0. I was able to get most of my new 100 bookmarks back using the History
function and resaving each page, a process that took over 3 hours. The adding 
and saving bookmark function is slow, slow, slow on your Firefox software! 

Intel Chipset, Pentium 1 system board, Intel Pentium 200 MMX CPU. 192MB Main
Memory, OS is Windows 98 Second Edition 4.10.2222A

1.44 fd, Western Digital 10 Gig IDE (X2), HP 9300 cdr (X2), Exabyte 8505 TBU,
Hitachi Superscan 17", Microsoft USB Intellimouse, Visioneer USB 9100 Scanner,
IBM 84 Key KB, Berkins USB wireless network adapter

well, > 10000 bookmarks on a machine that's slightly below the minimum
requirements, and well below recommended minimums, that'll be slow, yeah. 
You're talking two extremes, essentially, and that's going to cause some degree
of slowdown.

If your AV scan decided the bookmarks file was infected, that could easily be
it, as well.

Comment 10

15 years ago
I've experienced the same bug with the official 1.0 release a while ago.
And now it just happened today !
I've backuped my profile information (I hope it's not yet corrupted).
Weird enough, this time I still have my cookies exceptions and other things like
themes, etc. .
The bookmarks-file is empty !!!!
I've been (un-)installing some software today (Deamon tools and the new Acrobat 7)
Maybe worth telling -> I did an export of my bookmarks earlier today.
(a habit I regularly do because of my loss the previous time ...)

Let's suppose the worst case : Firefox code resets/erases all bookmarks.
There's only one way possible to do this through the interface :
 delete them at the top level
Maybe all calls to this delete-code should be located (or other portions).
A "safety-device" would be to add a check + warningdialog whenever _ALL_
bookmarks are deleted.
If one day, this dialog would be triggered 'out of the blue', we might come a
step closer to this mystery.
I suggest this to be added to all next testbuilds until this matter is resolved.
This dialog wouldn't really bother in any official release either... .

Comment 11

15 years ago
(In reply to comment #8)

OK Folks, it happened again today 1/28/2005. Same Firefox 1.0, same computer.
First time Firefox crashed on me, possibly for the first time in weeks. When I
opened it up again, the bookmarks were reset, but not to empty... I seem to
recall making a copy of bookmark.htm to bookmark.bak possibly on 1/16/05, and
now both files reverted back to 1/16/05 and I lost about 12 days of bookmarks,
lost about 50 bookmarks total not as bad as the first time.  This time, I only
had about 500 bookmarks total, the file size was about 123kB. I never did
re-import the old Netscape file over again.  Never did locate the profile backup
program...


> Installed Firefox on 11/11/2004. There had been about 10,000 old bookmarks which
> I imported from a Netscape 4.79 file size = ~2.2 MB, and perhaps just over 100
> new bookmarks I added since getting Firefox 1.0 installed. No problems for
> several weeks since 1.0 was downloaded and installed. 
> 
> The only thing I recall that I did or changed was to install new anti-virus
> software (AVG 7.0 Free) and do a complete scan of my computer and hard drives. I
> do not know if this software install, or the virus scan had anything to do with
> the loss of the bookmarks. 
> 
> But, next thing I knew, next time I opened Firefox 1.0 bookmarks were all gone,
> reset = 0. I was able to get most of my new 100 bookmarks back using the History
> function and resaving each page, a process that took over 3 hours. The adding 
> and saving bookmark function is slow, slow, slow on your Firefox software! 
> 
> Intel Chipset, Pentium 1 system board, Intel Pentium 200 MMX CPU. 192MB Main
> Memory, OS is Windows 98 Second Edition 4.10.2222A
> 
> 1.44 fd, Western Digital 10 Gig IDE (X2), HP 9300 cdr (X2), Exabyte 8505 TBU,
> Hitachi Superscan 17", Microsoft USB Intellimouse, Visioneer USB 9100 Scanner,
> IBM 84 Key KB, Berkins USB wireless network adapter

Comment 12

15 years ago
*** Bug 263520 has been marked as a duplicate of this bug. ***

Comment 13

14 years ago
Any ideas what's triggering this? This just happend to my girlfriend today using
1.0 release. There were no crashes before this happend. She started up firefox
and bookmarks are gone except for an empty bookmark toolbar folder. The profile
has a bookmarks.html and bookmarks.bak both with only a BTF.  It looks like some
of the "dupes" of this bug are going in circles and most say that this is
resolved, but here this bug is, still open. Kind of annoying to have all your
bookmarks gone with no chance of getting them back so the sooner this is fixed
the better.

Comment 14

14 years ago
Something interesting. She says the "Add bookmark" dialog was acting up earlier
(she keeps a firefox window open most of the day). She went to bookmark a page,
and clicked the "Show all folders" button as usual, but only half the list
showed up. She hit "OK" because the folder she wanted was visible and just
figured it was a ui problem (sizing or drawing etc). That's the only thing out
of the ordinary.

What I'm thinking maybe is the bookmarks.html somehow had a bad character or was
corrupt in some way. Is that possible? And is anyone else who's having this
problem also using the bookmark folder tree?

Comment 15

14 years ago
I use Windows XP.  My wife and my bookmarks have been deleted twice each. 
Actually, the second time it happen to my wife, the bookmarks were only half
deleted.  I could not find "bookmark.html" or "bookmarks.bak".

What can I do to recover the bookmarks, and how to prevent this from occuring again.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225
Firefox/1.0.1



(In reply to comment #3)
> OK, I did a file search for bookmark.html and found the bookmark backup file
> created by the bookmark backup extensions (Thanks!).  I now have my bookmarks
> back from when my wife had to try and find all of her other sites from the last
> loss.  I have since reloaded all extensions and themes I use and will now see if
> it does it again.  I thought maybe someone went into safemode and it would not
> revert back , but after I tried that, there was not a difference between my
> modified version and the safemode version.  Maybe that is another bug. 
> Shouldn't safe mode be the base program?? oh well, I will do that later.

Comment 16

14 years ago
It happened to me the once, about a year ago.

I thought they had disappeared.. but luckily, the file was still on the drive.

Something must've gone awry, some shut down hiccup, and it had been picked up by
Scandisk as a free-file on restart, and dumped in the FOUND folder on C: where I
have Firefox installed.

There were a few files in the folder - I opened each one with notepad, and one
had matching web addresses as my bookmarks (yippee!).

I copied the FOUND.chk file to the Desktop, and renamed it bookmarks.html then
opened Firefox, went to Bookmarks/Manage Bookmarks, then Import.. From File.

I chose the bookmarks.html file on the desktop to import from and they were back.

I tell you what - once you've experienced losing your bookmarks, previously just
taking them for granted, you really appreciate them.
*** Bug 286340 has been marked as a duplicate of this bug. ***
*** Bug 289329 has been marked as a duplicate of this bug. ***
*** Bug 285281 has been marked as a duplicate of this bug. ***
*** Bug 287227 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Keywords: dataloss

Comment 21

14 years ago
(In reply to comment #15)
> I use Windows XP.  My wife and my bookmarks have been deleted twice each. 


How did you get her back? ;-)

Anyhow, since this is a dataloss issue, I wanted to recommend this extension
until this gets fixed: 

http://www.pikey.me.uk/mozilla/
Flags: blocking1.8b3?
Flags: blocking1.8b2?
Flags: blocking-aviary1.1?

Updated

14 years ago
Flags: blocking1.8b2? → blocking1.8b2-
*** Bug 295003 has been marked as a duplicate of this bug. ***
*** Bug 295143 has been marked as a duplicate of this bug. ***
Assignee: p_ch → nobody
QA Contact: mconnor → bookmarks
*** Bug 292047 has been marked as a duplicate of this bug. ***
*** Bug 296454 has been marked as a duplicate of this bug. ***
*** Bug 296674 has been marked as a duplicate of this bug. ***
*** Bug 297564 has been marked as a duplicate of this bug. ***

Comment 28

14 years ago
besides everyone that is having this problem, is firefox working on this? a
tech? so we can stop having the problem.
so, what in general seems to happen is the following:
1.Windows crashes (or FF is closed improperly by windows) causing FF to loose
bookmarks.html in profile.
2.The next time we startup Firefox notices bookmarks .html is awol and create a
new copy from program files\mozilla firefox\defaults\profile\bookmarks.html
3.Because the new bookmarks.html is created in profile Firefox is triggered to
create bookmarks.bak there aswell.

ergo, bookmarks.bak (in profile), which most probably survived the crash intact,
is immediately overwritten at startup.

This is offcourse fundamentally wrong.

We must also check if bookmarks.bak is awol.

suggestion:
at startup:
1.check if bookmarks.html and/or bookmarks.bak is/are missing from profile (this
is currently only done for bookmarks.html).
2.if bookmarks.html is not missing, just startup Firefox.
3.if bookmarks.html and bookmarks.bak are both missing -> let Firefox create a
new bookmarks.html from bookmarks.html (in program files) and finish startup.
4.if bookmarks.html is missing and bookmark.bak is not -> let Firefox copy
bookmarks.bak to bookmarks.html (both in profile) and finish startup.

or alternativly show a dialog like:
 ----------------------------------------------------
|              Firefox Bookmark recovery             |
 ----------------------------------------------------
| Firefox has discovered your bookmarks are missing. |
|     Do you wish to restore your bookmarks ?        |
|     (Cancel will delete your old bookmarks)        |
|                                                    |
|                                       [OK][Cancel] |
 ----------------------------------------------------
5. if the user presses [cancel] -> let Firefox create a new bookmarks.html from
bookmarks.html (in program files) and finish startup.
6. if the user presses [OK] -> let Firefox copy bookmarks.bak to bookmarks.html
(both in profile) and finish startup.





Comment 30

14 years ago
(In reply to comment #29)

Your idea is excellent, but why should the user be asked whether he wants to
restore the bookmarks or not? I think it should just restore then and show a
dialog with an OK button that says: "Firefox has detected corrupt or invalid
bookmarks and restored them from the last backup".
Depends on: 298943

Updated

14 years ago
Flags: blocking1.8b3? → blocking1.8b3-
*** Bug 300291 has been marked as a duplicate of this bug. ***

Comment 32

14 years ago
(In reply to comment #29)
> so, what in general seems to happen is the following:
> 1.Windows crashes (or FF is closed improperly by windows) causing FF to loose
> bookmarks.html in profile.
> 2.The next time we startup Firefox notices bookmarks .html is awol and create a
> new copy from program files\mozilla firefox\defaults\profile\bookmarks.html
> 3.Because the new bookmarks.html is created in profile Firefox is triggered to
> create bookmarks.bak there aswell.
> 
> ergo, bookmarks.bak (in profile), which most probably survived the crash intact,
> is immediately overwritten at startup.
> 
> This is offcourse fundamentally wrong.
> 
> We must also check if bookmarks.bak is awol.
> 
> suggestion:
> at startup:
> 1.check if bookmarks.html and/or bookmarks.bak is/are missing from profile (this
> is currently only done for bookmarks.html).
> 2.if bookmarks.html is not missing, just startup Firefox.
> 3.if bookmarks.html and bookmarks.bak are both missing -> let Firefox create a
> new bookmarks.html from bookmarks.html (in program files) and finish startup.
> 4.if bookmarks.html is missing and bookmark.bak is not -> let Firefox copy
> bookmarks.bak to bookmarks.html (both in profile) and finish startup.
> 
> or alternativly show a dialog like:
>  ----------------------------------------------------
> |              Firefox Bookmark recovery             |
>  ----------------------------------------------------
> | Firefox has discovered your bookmarks are missing. |
> |     Do you wish to restore your bookmarks ?        |
> |     (Cancel will delete your old bookmarks)        |
> |                                                    |
> |                                       [OK][Cancel] |
>  ----------------------------------------------------
> 5. if the user presses [cancel] -> let Firefox create a new bookmarks.html from
> bookmarks.html (in program files) and finish startup.
> 6. if the user presses [OK] -> let Firefox copy bookmarks.bak to bookmarks.html
> (both in profile) and finish startup.

please implement this... the current way is horrible. 
my gf just lost her bookmarks again. i think about have her switch to opera. 

note: its no fundamental data error happening that causes the bookmark loss,
rather due to a bug inside the software that deletes the corrupt file AND the
backup. 

plain ****, until this is fixed i wont recommend firefox to anyone and make
people aware that at any time they may loose all their bookmarks under firefox.

Comment 33

14 years ago
I have had this occur 3 times now. 
Flags: blocking-aviary1.1? → blocking1.8b4?
*** Bug 300966 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Flags: blocking1.8b4? → blocking1.8b4-

Comment 35

14 years ago
AHA! I have new information! This just happened to me.

I had firefox open during a power failure, and when the power came back on, and
I wen't into firefox, my bookmarks were gone! And now, for some reason, Firefox
keeps turning the (now empty) bookmarks toolbar back on everytime I restart
Firefox, even if I turn it off. This is serious stuff.

Updated

14 years ago
Flags: blocking-aviary1.5?
*** Bug 303616 has been marked as a duplicate of this bug. ***
*** Bug 303732 has been marked as a duplicate of this bug. ***
*** Bug 303686 has been marked as a duplicate of this bug. ***
Flags: blocking-aviary1.5? → blocking-aviary1.5-
if anyone manages to reproduce the problem with a nightly build after 2005-08-09
please make sure to comment.
The fix for bug 298943 may have fixed this one aswell
*** Bug 304950 has been marked as a duplicate of this bug. ***

Comment 41

14 years ago
(In reply to comment #40)
> *** Bug 304950 has been marked as a duplicate of this bug. ***

this happened to me last night.  Firefox stopped responding... I closed out, and
reopened. Upon reopening it asked if I wanted to create a new profile, or delete
the existing profile.  I created a new one, and now cant find my old one with
all my bookmarks. also, my homepage was reverted to firefox home.  pretty lame,
and still not sure how to recover the bookmarks.  all searches for
bookmark.html, or .bak have come up empty.

please help

Comment 42

14 years ago
Lost all of my bookmarks. Where should I look for them.
My OS is Windows XP Professional. I've been using foxfire for six months with no
problems. 

Comment 43

14 years ago
(In reply to comment #42)
> Lost all of my bookmarks. Where should I look for them.
> My OS is Windows XP Professional. I've been using foxfire for six months with no
> problems. 

We need useful comments, not useless ones. And we don't need any more "stories".

Comment 40 asked for occurrences for builds after 2005-08-09.
In case bug 298943 didn't fix this , bug 305004 should provide a usefull backup
to reduce dataloss to an absolute minimum.
Whiteboard: read comment #44 first
*** Bug 308097 has been marked as a duplicate of this bug. ***

Comment 46

14 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1
> 
> Searched through all directories for the bookmarks and could only find a
> bookmark file with the correct information from about 1 month ago.  However,
> could not find the information in any files for bookmarks saved to same
> directory since the upgrade to 0.9
> 
> Reproducible: Always
> Steps to Reproduce:
> 1.Bookmarks
> 2.
> 3.
> 
> Actual Results:  
> see Details,  also, it does not import the IE favorites; however, 0.8 did import
> them.
> 
> Expected Results:  
> not deleted or overwritten existing files in a user folder
> 
> AMD Athlon 1100
> Quatum 20 Gig ATA
> Linksys network
> ATI 9200 Radeo, 256MB
> 256MB memory
> Abit KA-7 motherboard
> 1.44 fd
> lg 52X cdr
> samsung cdrw
> viewsonic ve175
> logitech cordless trackball
> ms natural kb
> creative 128 sc

(In reply to comment #39)
> if anyone manages to reproduce the problem with a nightly build after 2005-08-09
> please make sure to comment.
> The fix for bug 298943 may have fixed this one aswell

Updated Firefox this morning. Laptop running XP overheated and crashed this
afternoon. Booted up again and the bookmarks have been truncated. This is the
third time this has happened. 
*** Bug 312079 has been marked as a duplicate of this bug. ***

Comment 48

14 years ago
I think this problem happens when the computer shuts down inappropiately. It's as if information that's loaded in memory is wiped out and not restored, thus eliminating all bookmarks.

This has happenend to me at least 3 times already.

Comment 49

14 years ago
*** Bug 317168 has been marked as a duplicate of this bug. ***

Comment 50

14 years ago
*** Bug 317807 has been marked as a duplicate of this bug. ***

Comment 51

14 years ago
I managed to fix the problem afre a version update. Went back and found the backup bookmarks file, brought it into the new Firefox version, and voilà!

Comment 52

14 years ago
I fired up my Mozilla Firefox > a message appeared something to the effect of 'do you want the google add-in for page ranking to appear on the toolbar'. There were 2 options Enable & Disable.  I selected Enable & clicked OK.  When the Firefox start page appeared I went to use my favourite bookmarks.  And they all disappeared - gone - deleted.  Ive read the comments on this post & have done a search for bookmarks.bak & bookmark.html, but no search was found.

There must be a backup somewhere on my pc for my favourite books. Do you have any suggestions?  

Many thanks
Diana
ps. why is this window so small to type in. i feel a little bit claustrophobic(is that how you spell it :o) )

Comment 53

14 years ago
I started Firefox this morning and was told the "default user" profile is in use and I will have to create a new one.
I created a new one and all my bookmarks disappeared.
The Bookmarks.html file only has the firefox default bookmarks.

In an effort to force it to revert / search for orignial files, I upgraded to version 1.7.  No good - I have lost all my files.

Is there a back up file I can revert to for my "profile" or my original bookmarks ?
(In reply to comment #53)
> I started Firefox this morning and was told the "default user" profile is in
> use and I will have to create a new one.
> I created a new one and all my bookmarks disappeared.
> The Bookmarks.html file only has the firefox default bookmarks.
> 
> In an effort to force it to revert / search for orignial files, I upgraded to
> version 1.7.  No good - I have lost all my files.
> 
> Is there a back up file I can revert to for my "profile" or my original
> bookmarks ?
> 

You should have first checked in task manager's process list if there had been a firefox.exe process running after that message poped up since there could have been chance that the profile wasn't faulty or damaged, just being in use by a not properly closed firefox instance.

Comment 55

14 years ago
*** Bug 312557 has been marked as a duplicate of this bug. ***

Comment 56

14 years ago
This is scary.  This critical bug is still in Firefox after over a year!

I installed Firefox 1.5 on our Windows XP Pro machine at home, and one of my family's entire bookmarks listing got deleted once.  I didn't think much of it, but it happened again a week later.  It's never happened to me or anyone else I know, or any other machines, but it proves the problem is still there.

I agree with the idea that it must be to do with a corrupted file, since this machine is slow and does occasionally get reset.  I vote for Comment #29 as a good solution.

Someone needs to fix this problem!  How can we get a developer to take this bug on?

Updated

14 years ago
Flags: blocking-firefox2?
Bookmarks is moving to mozStorage, which should prevent this bug in Fx2 and beyond.
Flags: blocking-firefox2? → blocking-firefox2-
*** Bug 324952 has been marked as a duplicate of this bug. ***
*** Bug 325461 has been marked as a duplicate of this bug. ***
*** Bug 325886 has been marked as a duplicate of this bug. ***

Comment 61

13 years ago
I have just experance a simular problem to this if not the same one.  My computer froze (don't understand why, may be related) and after I restarted my bookmarks were all gone.  I looked for them using the surch you gave in this folder (bug 249150) and found nothing.  there is only add, manage, and bookmark toolbar, all empty.  Also the quick links that were on a seporate tool bar (such as quick link to monzilla, image, and last website (or something of the like) is missing.  I was wondering how to fix this problem so it doesn't happen again, Im not to worried about the bookmarks, I can get them all again just I don't want them to be deleted again.  Im using XP, on a Gatway laptop.  If you need any other information or can help please email me at Dragon_Orca@yahoo.com.  Thanks for the help

your friend,

Eric

Comment 62

13 years ago
(In reply to comment #57)
> Bookmarks is moving to mozStorage, which should prevent this bug in Fx2 and
> beyond.
> 
Is this what is now known as "places"?
Re comment 62: yes. (moz)Storage is the name of technology behind places.

Comment 64

13 years ago
Then I guess this bug will just be marked invalid.

Comment 65

13 years ago
> Then I guess this bug will just be marked invalid.

...So we can mark this bug as invalid, and let Firefox delete our bookmarks when it feels like it - but no-one will care because their bookmarks are stored on Mozilla and we can restore them each time it happens...?  I think that is a little less than satisfactory.

Comment 66

13 years ago
(In reply to comment #65)
> ...So we can mark this bug as invalid, and let Firefox delete our bookmarks
> when it feels like it - but no-one will care because their bookmarks are stored
> on Mozilla and we can restore them each time it happens...?  I think that is a
> little less than satisfactory.

The upcoming Firefox 2 release will use a different system for storing bookmarks (a sort of a database), so this bug is INVALID.
I will instead change the bug summary and branch to note that this bug is about pre-places dataloss issues. It is unlikely that this bug will fixed in a 1.5.0.x release, because no-one knows what causes it.

Hopefully the places system in 2.0 will not suffer from this problem. If it happens to have a similar bug, please file it separately, because the reasons for the bug are very likely to be different (and because this bug is quite long already with little useful information).

Summarizing: this bug should be fixed in 2.0. It can not be fixed earlier because of lack of developer resources and unknown cause of the bug.
Summary: Bookmarks file is overwritten (deleted) randomly → Bookmarks file is overwritten (deleted) randomly in Firefox versions before 2.0a
Version: unspecified → 1.5.0.x Branch
*** Bug 331354 has been marked as a duplicate of this bug. ***
*** Bug 330800 has been marked as a duplicate of this bug. ***
*** Bug 271366 has been marked as a duplicate of this bug. ***
Alias: lostbookmarks

Comment 71

13 years ago
(In reply to comment #67)
> I will instead change the bug summary and branch to note that this bug is about
> pre-places dataloss issues. It is unlikely that this bug will fixed in a
> 1.5.0.x release, because no-one knows what causes it.

...
> Summarizing: this bug should be fixed in 2.0. It can not be fixed earlier
> because of lack of developer resources and unknown cause of the bug.

Cause is unknown, but it should be fixed? How can one make that jump? And, if it won't be fixed, shouldn't it then be marked WONTFIX?

Comment 72

13 years ago
The bookmarks were lost and now I can't add new ones. using win xp on delld600
(In reply to comment #67)
> I will instead change the bug summary and branch to note that this bug is about
> pre-places dataloss issues. It is unlikely that this bug will fixed in a
> 1.5.0.x release, because no-one knows what causes it.
> 
> Hopefully the places system in 2.0 will not suffer from this problem. If it
> happens to have a similar bug, please file it separately, because the reasons
> for the bug are very likely to be different (and because this bug is quite long
> already with little useful information).
> 
> Summarizing: this bug should be fixed in 2.0. It can not be fixed earlier
> because of lack of developer resources and unknown cause of the bug.
> 

This bug will be fixed in fx 2.0.  If you get the alpha (Bon Echo Alpha 1, version 2.0a1), you will actually see what the mozStorage (places) looks like.  Same with the trunk (Minefield 1.6a1 or 3.0a1).  Also, if you want, try upgrading to these versions.

(In reply to comment #32)
>
> 
> please implement this... the current way is horrible. 
> my gf just lost her bookmarks again. i think about have her switch to opera. 
> 
> note: its no fundamental data error happening that causes the bookmark loss,
> rather due to a bug inside the software that deletes the corrupt file AND the
> backup. 
> 
> plain bullsh**, until this is fixed i wont recommend firefox to anyone and make
> people aware that at any time they may loose all their bookmarks under firefox.

This maybe an extension problem or something like that.  Restart fx in safe mode:

Windows: Start Menu, then Run...
         Type: %ProgramFiles%\Mozilla Firefox\firefox.exe -safe-mode
Mac OS X: open Terminal or X11
          cd applicatons/firefox/contents
          ./firefox-bin -safe-mode

then check to see if the problem persists.  If it does, upgrade to 2.0a1, not 3.0a1.  I am saying this because if you lose all your bookmarks, you might have a better chance using fx normally.  Also, I told you to upgrade to 2.0a1 because 3.0 (anything of 3.0) will not support Windows 98 (98 and 98SE) and Windows ME.  If you are using Windows 2000 (any edition), Windows XP (any edition), or Windows Server 2003, then you will have no problem upgrading to 3.0a1 or 2.0a1 (if you like).

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
> Gecko/20040626 Firefox/0.9.1
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
> Gecko/20040626 Firefox/0.9.1
> 
> AMD Athlon 1100
> Quatum 20 Gig ATA
> Linksys network
> ATI 9200 Radeo, 256MB
> 256MB memory
> Abit KA-7 motherboard
> 1.44 fd
> lg 52X cdr
> samsung cdrw
> viewsonic ve175
> logitech cordless trackball
> ms natural kb
> creative 128 sc
> 

My config might be a little different than yours:
Pentium 266
Westell VersaLink network
ATI video card and driver
Intel Motherboard
CD drive
Imagic Monitor
Micro Innovations wireless k/b and mouse
Yamaha PCI Audio (DS1x Native)

Comment 74

13 years ago
ARGH!  Just had this happen to me...suspect it had something to do with a MSN conflict (I was reading some of the articles and Firefox just froze on me...tried closing tabs to see if maybe I just had too many open at once...didn't work, program sent an error report).  So I shut the program down and restarted it...came up like a new install, asking to set up a profile.  Wouldn't let me use the default (something about it already being used), so I created another...yadda, yadda, connected to the 'Net and came up on the Mozilla home page.

Thought I lost all my bookmarks (was panicked and rather ****...I have several years worth, totalling a whopping 778kb); came here, read what was going on and went into the Application Data\Mozilla\Firefox\Profiles\default...and there's the .html of bookmarks time stamped sometime today (I hadn't added anything today, so I knew it was current).  Ended up copying the file elsewhere.

I'm going to try inserting the bookmark .html doc into the stupid second profile I made...hopefully, it'll work out.  Will also upgrade to the 1.5.0.2...hope this problem gets fixed...I really, REALLY like Firefox.

Running on Windows XP Pro, SP2 on the 1.0.7...didn't realize there was a new version of Firefox...rather used to having everything update automatically or notifying me.
(In reply to comment #73)
> (In reply to comment #67)
> > I will instead change the bug summary and branch to note that this bug is about
> > pre-places dataloss issues. It is unlikely that this bug will fixed in a
> > 1.5.0.x release, because no-one knows what causes it.
> > 
> > Hopefully the places system in 2.0 will not suffer from this problem. If it
> > happens to have a similar bug, please file it separately, because the reasons
> > for the bug are very likely to be different (and because this bug is quite long
> > already with little useful information).
> > 
> > Summarizing: this bug should be fixed in 2.0. It can not be fixed earlier
> > because of lack of developer resources and unknown cause of the bug.
> > 
> 
> This bug will be fixed in fx 2.0.  If you get the alpha (Bon Echo Alpha 1,
> version 2.0a1), you will actually see what the mozStorage (places) looks like. 
> Same with the trunk (Minefield 1.6a1 or 3.0a1).  Also, if you want, try
> upgrading to these versions.
> 

Recently, Mozilla just announced that they are going to shut off places for the 2.0a1 builds and are going to implement it in 3.0.
*** Bug 336806 has been marked as a duplicate of this bug. ***
elevating this bug to blocker, this bug is not being taken very seriously even though it is at critical and lots of people are CC'ed on this bug. Mozilla might be rolling out 1.5.0.4 and pre-1.5.0.5 updates...
Severity: critical → blocker
Charli, if you read https://bugzilla.mozilla.org/page.cgi?id=fields.html#bug_severity you'll see that a blocker is a bug that "Blocks development and/or testing work". This is not such a bug. Messing with bug's fields is not going to get this bug "noticed". Figuring out the reason why most CC'd people lose bookmarks and suggesting fixes will.
Severity: blocker → critical
Summary: Bookmarks file is overwritten (deleted) randomly in Firefox versions before 2.0a → Bookmarks file is overwritten (deleted) randomly in Firefox versions without places
(In reply to comment #75)
> Recently, Mozilla just announced that they are going to shut off places for the
> 2.0a1 builds and are going to implement it in 3.0.
> 

So does this mean that there might just be a problem with the non-places bookmarks manager in 2.0?
(In reply to comment #79)
> (In reply to comment #75)
> > Recently, Mozilla just announced that they are going to shut off places for the
> > 2.0a1 builds and are going to implement it in 3.0.
> > 
> 
> So does this mean that there might just be a problem with the non-places
> bookmarks manager in 2.0?
> 

Maybe copying part of the non-places bookmarks feature in 2.0a1 to the 1.5.0.x codebase would help???

Updated

13 years ago
Flags: blocking-firefox2- → blocking-firefox2?
*** Bug 337280 has been marked as a duplicate of this bug. ***
There are non-places trunk builds available, according to tinderbox.mozilla.org
*** Bug 321516 has been marked as a duplicate of this bug. ***
*** Bug 325806 has been marked as a duplicate of this bug. ***
This bug is confirmed that it is a cross-platform bug.
---
Bug 260928 proves it.
OS: Windows 2000 → All
Version: 1.5.0.x Branch → unspecified

Comment 86

13 years ago
*** Bug 337642 has been marked as a duplicate of this bug. ***
*** Bug 325634 has been marked as a duplicate of this bug. ***
*** Bug 335597 has been marked as a duplicate of this bug. ***
(In reply to comment #85)
> This bug is confirmed that it is a cross-platform bug.
> ---
> Bug 260928 proves it.
> 

So should I mark that as a dupe of this???
*** Bug 333399 has been marked as a duplicate of this bug. ***
*** Bug 337869 has been marked as a duplicate of this bug. ***
This can't be completely fixed, due to underlying issues on certain filesystems, until we ship Places, but there is a bookmarksbackup folder in the profile which contains daily backups from the last five days.
Flags: blocking-firefox2? → blocking-firefox2-
*** Bug 314052 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Blocks: 260928
Nobody takin' this?  I'm on it.
Status: NEW → ASSIGNED
(In reply to comment #94)
> Nobody takin' this?  I'm on it.

I would point out that chances are you are too late to get any major change implemented for Firefox 2.0, and the problem goes away with Firefox 3.
(In reply to comment #95)
> (In reply to comment #94)
> > Nobody takin' this?  I'm on it.
> 
> I would point out that chances are you are too late to get any major change
> implemented for Firefox 2.0, and the problem goes away with Firefox 3.
> 

So what?  Have you thought about 1.5.0.4 and the future Mozilla1.8.0 releases?

Updated

13 years ago
Flags: blocking1.8.0.5?
Flags: blocking1.8.0.4?
Flags: blocking-aviary1.0.9?
Flags: blocking1.8.0.4?
Flags: blocking-aviary1.0.9?
Flags: blocking1.8.0.5?
(In reply to comment #96)
> (In reply to comment #95)
> > (In reply to comment #94)
> > > Nobody takin' this?  I'm on it.
> > 
> > I would point out that chances are you are too late to get any major change
> > implemented for Firefox 2.0, and the problem goes away with Firefox 3.
> > 
> 
> So what?  Have you thought about 1.5.0.4 and the future Mozilla1.8.0 releases?
> 
You're seemingly uninformed of the fact that 1.5.x will only be upgraded with security and stability fixes.
*** Bug 339407 has been marked as a duplicate of this bug. ***

Comment 99

13 years ago
(In reply to comment #97)
> (In reply to comment #96)
> > (In reply to comment #95)
> > > (In reply to comment #94)
> > > > Nobody takin' this?  I'm on it.
> > > 
> > > I would point out that chances are you are too late to get any major change
> > > implemented for Firefox 2.0, and the problem goes away with Firefox 3.
> > > 
> > 
> > So what?  Have you thought about 1.5.0.4 and the future Mozilla1.8.0 releases?
> > 
> You're seemingly uninformed of the fact that 1.5.x will only be upgraded with
> security and stability fixes.

Not deleting bookmarks IS a stability fix!
*** Bug 341186 has been marked as a duplicate of this bug. ***

Comment 101

13 years ago
my verson of fire fox will not save any bookmarks after I close the window. do I need a new download? help.
*** Bug 343415 has been marked as a duplicate of this bug. ***
*** Bug 343501 has been marked as a duplicate of this bug. ***

Comment 104

13 years ago
Now I know why...and what is common.  I installed AVG.  I think any installation of virus protection and/or firewalls causes this problem.
Are the genei at FIREFOX/THUNDERBIRD solving this problem with their recently touted update that will be out by the end of this year???

Comment 105

13 years ago
I used firefox bookmarks heavily to store all kind of links, my bookmark file was over 1MB and so I took some time to notice that the bookmarks starting getting shorter and shorter[1], I have lost a lot of links just for relying on firefox bookmarks, now I'm using del.icio.us... please fix this data loss before Firefox 2.0!

[1] My windows XP has problems that when I close big apps (like firefox) they are still in memory (I have to kill them from ctrl+alt+supr menu) and now I see that this was causing my bookmarks getting shorter :(...

Comment 106

13 years ago
I'm having the same problem too, and I'm trying to figure out why and how this whole thing is gonna get corrected.(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
> Gecko/20040626 Firefox/0.9.1
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
> Gecko/20040626 Firefox/0.9.1
> 
> Searched through all directories for the bookmarks and could only find a
> bookmark file with the correct information from about 1 month ago.  However,
> could not find the information in any files for bookmarks saved to same
> directory since the upgrade to 0.9
> 
> Reproducible: Always
> Steps to Reproduce:
> 1.Bookmarks
> 2.
> 3.
> 
> Actual Results:  
> see Details,  also, it does not import the IE favorites; however, 0.8 did
> import
> them.
> 
> Expected Results:  
> not deleted or overwritten existing files in a user folder
> 
> AMD Athlon 1100
> Quatum 20 Gig ATA
> Linksys network
> ATI 9200 Radeo, 256MB
> 256MB memory
> Abit KA-7 motherboard
> 1.44 fd
> lg 52X cdr
> samsung cdrw
> viewsonic ve175
> logitech cordless trackball
> ms natural kb
> creative 128 sc
> 
Status: ASSIGNED → NEW

Comment 107

12 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
> Gecko/20040626 Firefox/0.9.1
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
> Gecko/20040626 Firefox/0.9.1
> 
> Searched through all directories for the bookmarks and could only find a
> bookmark file with the correct information from about 1 month ago.  However,
> could not find the information in any files for bookmarks saved to same
> directory since the upgrade to 0.9
> 
> Reproducible: Always
> Steps to Reproduce:
> 1.Bookmarks
> 2.
> 3.
> 
> Actual Results:  
> see Details,  also, it does not import the IE favorites; however, 0.8 did
> import
> them.
> 
> Expected Results:  
> not deleted or overwritten existing files in a user folder
> 
> AMD Athlon 1100
> Quatum 20 Gig ATA
> Linksys network
> ATI 9200 Radeo, 256MB
> 256MB memory
> Abit KA-7 motherboard
> 1.44 fd
> lg 52X cdr
> samsung cdrw
> viewsonic ve175
> logitech cordless trackball
> ms natural kb
> creative 128 sc
> 

I just had my entire bookmarks list wiped and I didn't have any crash to cause it. Simply logged back on and they were all gone. I have them in my "history" but unable to readd them to the bookmarks list without having to spend the next 3-4 hours visiting sites, rebookmarking them and reorganizing back the way I had them. From my reading, this bug has been an issue for a few years without any repairs. Something needs to be done about this bug. I can't even import from IE browzer and I had been able to once before. 

Comment 108

12 years ago
Bob on a plain jane e-machines system (wally world special).
I have firefox 2.0 and have lost my bookmarks as of 7-2-07.  I had them on 6-29-07 and had no unexpected shutdowns between 6-29 and 7-2 because no one was here to use the system.

I can see the list of bookmarks by pretending to add a new one, canceling the add, and going back to bookmarks but I cannot use any of them.  This is a problem that occurs always and so is the failed "workaround" that I described above.

I have searched for (and found) both bookmarks.html and bookmarks.bak, is there a way to "fix" this?
Thanks in advance for any help.

Bob 

Comment 109

12 years ago
When I upgraded from Firefox 2.0.0.5 to 2.0.0.6, all my bookmarks were lost. I know where they are, but Firefox Bookmarks Manager does not let me import them. I think Mozilla / Firefox gets advertising revenue, so why am I redueced to text messaging other users, rather than getting an answer from Mozilla / Firefox. Something's wrong with their business model, wouldn't you agree? (whomever 'you'are).

Thanks to somebody,
Anton Vesely

Comment 111

12 years ago
I have had the same problem, anytime there's a new update and I update firefox all my bookmarks get erased.  I don't seem to find the bookmarks.html file.  I search my whole machine and no luck.  
This has been a recurring issue for me since firefox v. 1.5..and on..
I just updgraded to the lastest 2.0.0.8, bookmarks gone again.

i'm on windows xp pro...

Comment 112

12 years ago
With me it is really random. I'll start up firefox and all of my bookmarks will be gone. It is happening once or twice a month. What can I do to stop it from happening again?

Comment 113

11 years ago
I am using 2.0.0.12, and ONCE AGAIN all my bookmarks have been deleted through no action of my own.  

This has happened so many times (with various previous versions) that I have lost count.  Why is this a continuing problem with Firefox (especially when I have never had it happen in Netscape)?

As much as I love almost everything about Firefox, this bookmark bug has finally become intolerable.  Using Firefox is simply not a viable option for me anymore.  Why the hell can no one fix this bug?  

Comment 114

11 years ago
...and I am running XP Pro with all current updates.

Comment 115

11 years ago
For me the problem went away around the time the version incremented to 2.*. I use Linux, either Fedora Core or CentOS. I see it creates a directory named bookmarkbackups in which there are currently 5 files. Each has the date when I last used firefox (last Friday, Mon, Tues, Weds and today). Are you saying this directory and all of its files are gone?

Comment 116

11 years ago
"Are you saying this directory and all of its files are gone?"

No such directory or files are on my hard drive.  And I don't know if such directory ever existed in the first place.

Comment 117

11 years ago
 a few years ago I had this problem when I downloaded Safari.  I got rid of Safari and everything came back.  From then on, I do not download stuff I really don't need, and just because Firefox tells me about new extensions - if I don't need them or will use them I do not download them.  So far so good.   Right now I am hesitating on downloading the "fix for XP from Microsoft!b  Hope you all get your stuff back and soon!

Comment 118

11 years ago
In Windows XP, the backup for bookmarks is located in :
C:\Documents and Settings\USERNAME\ApplicationData\Mozilla\Firefox\Profiles\nnnnnnn.default\bookmarkbackups

where USERNAME is your login name and nnnnnnnn is an 8 character string.

You have to "show hidden files" as the ApplicationData folder is hidden by default.
If you have that folder/file, you can recover your bookmarks.  

Comment 119

11 years ago
all bookmarks and history lost, downloads seems to be still in the window, however firefox shows license agreement on every start-up and version 3.03 which is in question, did change a look

Comment 120

11 years ago
this was recently found in error console:


Error: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]" nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)" location: "JS frame :: file:///usr/lib/firefox-3.0.3/components/nsBrowserGlue.js :: bg__initPlaces :: line 389" data: no]
Source File: file:///usr/lib/firefox-3.0.3/components/nsBrowserGlue.js
Line: 389

Error: uncaught exception: [Exception... "Component returned failure code: 0x8007000e (NS_ERROR_OUT_OF_MEMORY) [nsIDocShellHistory.useGlobalHistory]" nsresult: "0x8007000e (NS_ERROR_OUT_OF_MEMORY)" location: "JS frame :: chrome://browser/content/browser.js :: prepareForStartup :: line 763" data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]" nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)" location: "JS frame :: file:///usr/lib/xulrunner-1.9/modules/utils.js :: anonymous :: line 105" data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]" nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)" location: "JS frame :: file:///usr/lib/xulrunner-1.9/modules/utils.js :: anonymous :: line 123" data: no]
This bug is now INVALID since Firefox 3.0.x is using places which isn't going to have the same issue, and Firefox 2.0.0.x is no longer supported.
Status: NEW → RESOLVED
Last Resolved: 15 years ago11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.