Open Bug 269228 Opened 15 years ago Updated 3 months ago

Ctrl+Shift+[0-9a-f] Shortcuts on text fields aren't accepted in GTK (shift+ctrl keys don't work) [Edit->Select->Thread]

Categories

(Thunderbird :: Mail Window Front End, defect, minor)

x86
Linux
defect
Not set
minor

Tracking

(Not tracked)

REOPENED

People

(Reporter: bill.sheppard, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041109 Firefox/1.0
Build Identifier: version 0.9 (20041103)

This it the Thunderbird duplicate of Mozilla bug #186789".

Reproducible: Always
Steps to Reproduce:
1. Select threaded view in message pane.
2. Click on a message which is part of a thread.
3. Type "Ctrl-Shift-A".

Actual Results:  
Nothing happens.

Expected Results:  
It should select the thread. Same results for other Ctrl-Shift [0-9a-f] key combos.

Short-term, all shortcuts should be mapped to combos other than Ctrl-Shift
[0-9a-f].  Long term, customization of shortcuts would be ideal.
*** Bug 273799 has been marked as a duplicate of this bug. ***
Confirmed on a Thunderbird+gtk2 build pulled from the AVIARY_1_0 branch on
2004/11/25.  (Note that this appears to be a problem only with gtk2 builds; it's
gtk2 that's swallowing these keypresses for ISO 14755 processing.)

As noted, this is the Thunderbird analogue of bug 186789 where a fix for Mozilla
on this issue was checked in around 2004/06/09.  Several shortcuts in Mozilla's
mailnews component were changed there---the only remaining problem in
Thunderbird that I can see is the Ctrl+Shift+A sequence for selectThread.

Downgrading severity to minor, since workarounds (clicking the little
thread-head mini-icon or doing Edit->Select->Thread through the menu) are available.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Ctrl+Shift+[0-9a-f] Shortcuts in Mozilla conflict with ISO 14755 Input methods (shift+ctrl keys don't work) → Ctrl+Shift+[0-9a-f] Shortcuts in Mozilla conflict with ISO 14755 Input methods (shift+ctrl keys don't work) [Edit->Select->Thread]
Okay, a little history.  As far as I can see, the three problematic
mail-related keyboard shortcuts are Ctrl+Shift+F for Search Messages,
Ctrl+Shift+C for Mark All Read, and Ctrl+Shift+A for Select Thread.  They are
still there in the nightly (non-GTK2) Mozilla 1.7 branch builds, and I don't
see any code to change them for GTK2 builds.

The solution currently checked in on the Mozilla trunk (see the patches under
bug 186789 and bug 250005) is to use Ctrl+Shift+S for Search Messages on all
platforms, to use Ctrl+Shift+M on Unix but keep Ctrl+Shift+C on other platforms
for Mark All Read, and to use Alt+Shift+A on Unix but keep Ctrl+Shift+A on
other platforms for Select Thread.  What a disaster!

Anyway, the Thunderbird approach (i.e., what's checked in on the AVIARY_1_0_1
branch) has been a GTK2-only fix.  On GTK2 builds, Search Mail and Mark All
Read have been changed from Ctrl+Shift+F and Ctrl+Shift+C respectively to
Shift+F and Shift+C respectively.  Somehow, Select Thread was missed.

The enclosed patch for the AVIARY_1_0_1 branch changes Select Thread from
Ctrl+Shift+A to Shift+A on GTK2 builds only.

As far as I know, Shift+A isn't used for anything else on Thunderbird.	Could
some one correct me if I'm wrong?
Oh, for reference:  see bug 239483 for Mark All Read (Ctrl+Shift+C to Shift+C)
and bug 242947 for Search Messages (Ctrl+Shift+F to Shift+F).
*** Bug 324362 has been marked as a duplicate of this bug. ***
I thought that this bug was linux only but I just checked and it also affects Windows, CTRL+SHIFT+A doesn't select the thread, but CTRL+SHIFT+C works

Should I file a different bug ?
Interesting; I can no longer reproduce this problem: Linux/x86 20060419. GTK2 (Debian, 2.8.18). Ctrl-Shift-A selects just the thread.
(In reply to comment #7)
> Interesting; I can no longer reproduce this problem: Linux/x86 20060419. GTK2
> (Debian, 2.8.18). Ctrl-Shift-A selects just the thread.

I can reproduce this, Ubuntu Linux 6.06, x86, in Xfce 4.4 Beta. Ctrl-Shift-A does nothing.
Oddly enough, Ctrl+Shift+A works fine for me on todays trunk. On todays branch build it does nothing. 
QA Contact: front-end
Anybody still see this on trunk (3.0a1pre)? Tried it again and it seems to work fine, strangely enough. 
Assignee: mscott → nobody
I'm pretty sure shift-ctrl-a has been working for quite a while on recent debian and ubuntu, tbird2 and trunk. The unicode hex entry is triggered only by ctrl-shift-u now. I can't find offhand a bug on bugzilla.gnome to date that change exactly...
->WFM since per previous comments this shouldn't be an issue anymore
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
Reopening this, since I still see it (and so does mconley). I'm not sure what's going on here, but here's the bug for where the behavior changed in GTK: <https://bugzilla.gnome.org/show_bug.cgi?id=82011>.

It'd be really nice to get this fixed, since keyboard shortcuts are always at a premium in Thunderbird. I'm not sure who would know anything about how this stuff works, though. Presumably someone who works on Toolkit?
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Gavin, :bwinton mentioned you might have an idea of who would know how to fix this (specifically, that Ctrl+Shift+[0-9A-F] is being swallowed up in text fields in GTK). Any ideas?
Stranger and stranger: ctrl+shift+b (address book) and ctrl+shift+f (search for messages) both work from text fields. Ctrl+shift+a doesn't, however.
I have no idea, offhand. karlt knows GTK things in general, you might try asking him.
(In reply to Jim Porter (:squib) from comment #14)
> Gavin, :bwinton mentioned you might have an idea of who would know how to
> fix this (specifically, that Ctrl+Shift+[0-9A-F] is being swallowed up in
> text fields in GTK). Any ideas?

According to the description of this bug, we should not try to get these keys work on GTK2, we should use some other shortcuts instead.
(In reply to Ginn Chen from comment #17)
> (In reply to Jim Porter (:squib) from comment #14)
> > Gavin, :bwinton mentioned you might have an idea of who would know how to
> > fix this (specifically, that Ctrl+Shift+[0-9A-F] is being swallowed up in
> > text fields in GTK). Any ideas?
> 
> According to the description of this bug, we should not try to get these
> keys work on GTK2, we should use some other shortcuts instead.

The description is inaccurate. See https://bugzilla.gnome.org/show_bug.cgi?id=82011:

"Here is a [committed] patch which changes the hex input to only be initiated by C-S-u,
followed by C-S-<hexdigit>. Releasing Control or Shift, or pressing C-S-space
commit the character. The preedit display includes the initial 'u'."
Summary: Ctrl+Shift+[0-9a-f] Shortcuts in Mozilla conflict with ISO 14755 Input methods (shift+ctrl keys don't work) [Edit->Select->Thread] → Ctrl+Shift+[0-9a-f] Shortcuts on text fields aren't accepted in GTK (shift+ctrl keys don't work) [Edit->Select->Thread]
FWIW, i don't think that is the relevant gnome bug - that looks like an older bug, that got reverted or something. See bug 311756 comment 35 - at that point it definitely worked (again).
(In reply to Magnus Melin from comment #19)
> FWIW, i don't think that is the relevant gnome bug - that looks like an
> older bug, that got reverted or something. See bug 311756 comment 35 - at
> that point it definitely worked (again).

On this machine (Ubuntu 10.04), Ctrl+Shift+A while in a text field in Evolution opens up the "new appointment" dialog, but Ctrl+Shift+A while in a text field in Thunderbird does nothing.
(In reply to Jim Porter (:squib) from comment #18)

> "Here is a [committed] patch which changes the hex input to only be
> initiated by C-S-u,
> followed by C-S-<hexdigit>. Releasing Control or Shift, or pressing C-S-space
> commit the character. The preedit display includes the initial 'u'."

OK, if it is the case, we should get some shortcuts back on Linux e.g. C-S-D for "Bookmark All Tabs...".
(In reply to Jim Porter (:squib) from comment #20)
> On this machine (Ubuntu 10.04), Ctrl+Shift+A while in a text field in
> Evolution opens up the "new appointment" dialog, but Ctrl+Shift+A while in a
> text field in Thunderbird does nothing.

For what it's worth, the same behavior happens in Ubuntu 11.04 (though I tried it on this machine with GIMP instead).
Duplicate of this bug: 1108220
Duplicate of this bug: 1043987
Duplicate of this bug: 1157365
What can or should I do for this bug to be eliminated?
Where should I report it?
Perhaps on bugzilla.gnome.org ?
In what subsection?
AFAIK, it's not clear where the bug is. 
See the previous comments in this bug. At some point it did work, for some time. If you're able, it could be useful to figure out in what version (if any) it works using current gtk. That way we could at least know if there at some point was a fix in mozilla, or if there was a fix in gtk that got reverted for some reason.
Duplicate of this bug: 1519348
You need to log in before you can comment on or make changes to this bug.