[aviary] News filter dialog pointing to wrong account for adding / listing rules.

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: fredbezies, Assigned: Bienvenu)

Tracking

({fixed-aviary1.0})

unspecified
x86
Linux
fixed-aviary1.0
Bug Flags:
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7.5) Gecko/20041116 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7.5) Gecko/20041116 Firefox/1.0

I tried to be as complete as possible with the summary.

I noticed a strange bug (for some days, maybe a week) on news filter dialog.

I have seen this bug on the latest official nightly and as well on a 90 minutes
old CVS aviary homemade build.

Reproducible: Always
Steps to Reproduce:
1.Go to newsgroup list
2.Select one
3.Go to to tools / message filter

Actual Results:  
Instead of showing me list of rules for selected newsgroup, message filter
dialog shows me the rules I've set for my first account, a mail one :(

Expected Results:  
Showing rules list for the selected newsgroup ?

This is a recent regression, and I can't find anything like this when I do a
query, using "filter" word.

Sorry if it is a known bug.
(Reporter)

Comment 1

14 years ago
Requesting 1.0 blocker flag because I have to display my account list in filter
message dialog box to get the right list of rules.
Flags: blocking-aviary1.0?
(Reporter)

Comment 2

14 years ago
Sorry to spam this bug :(

Regression seems to appear on 20 november 2004 build.

I tested a 19 november (downloaded from
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2004-11-19-06-0.9/) 
"official" nightly of thunderbird, and it works the "right way" :)

Looking at directory name, regression was added between 6:00 am on 19 november
and 5:00 am on 20 november.

The only one related to filter is bug 210614. Is this one guilty here ?
(Assignee)

Comment 3

14 years ago
 bug 210614 changes an aspect of applying pop3 filters - it wouldn't have
anything to do with editing news filters.
(Assignee)

Comment 4

14 years ago
no, it was the fix for bug 270601 - I'll fix this...
Assignee: mscott → bienvenu
Flags: blocking-aviary1.0? → blocking-aviary1.0+
(Reporter)

Comment 5

14 years ago
I was looking for bugfix added on 19 november (after 5:00 am) which could be
guilty :(

Right time, wrong patch :)

Anyway, sorry to bother you ;)
(Assignee)

Comment 6

14 years ago
Created attachment 167148 [details] [diff] [review]
proposed fix

fix the news case. Also fix the case of bringing up the message filters in the
global inbox.
(Assignee)

Updated

14 years ago
Attachment #167148 - Flags: superreview?(mscott)

Updated

14 years ago
Attachment #167148 - Flags: superreview?(mscott) → superreview+
(Assignee)

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED
(Reporter)

Comment 7

14 years ago
I build a thunderbird with this fix, and it works :)

Thanks for "killing" it :)
David: When did this get checked into trunk? I think it may have caused bug
276812, as there is a small part of the patch missing for mailnews.
Sorry, I got that wrong, the patch for this bug caused the regression that is
reported in bug 276812.
You need to log in before you can comment on or make changes to this bug.