If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Advanced Address Book Search: Can not search on notes in address book

RESOLVED DUPLICATE of bug 184483

Status

Thunderbird
Address Book
--
enhancement
RESOLVED DUPLICATE of bug 184483
13 years ago
4 years ago

People

(Reporter: David Keeley, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/Thunderbird version 1.0RC1 (20041201)

Possibly classed as an enhancement, but I think it is just a missing item in a
pick box so raised it as a bug:

I have imported my huge previously palm based address book and there is a lot of
information in the notes that I routinely find by seatching in the palm.  The
drop down of fields to search on in Thunderbirds address book does not let you
pick notes.  Even better for me would be the open search, anywhere in any field.
 That is the use case that works best for me most often.  You typically only get
a few hits and can pick off the right one.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
Confirming
os -> all
hardware -> ALL

analogous moz suite Bug 136309
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 2

13 years ago
I see that this problem is classified as an "enhancement" but I think that it is
really a "bug" because, as it is now, the Advanced Address Book Search from
Thunderbird/Mozilla Suite is pretty crippled.

The Advanced Search can not be performed not only on "notes", but also on
"country", "web page", the "custom fields" and maybe other fields too.
I was extremely disappointed to see that, after I heavily updated my Address
Book, I tried to search for all my contacts from Japan just to discover that it
*cannot* be done.
The same happens for the custom fields - which I am forced to use a lot because
of the stupid limitation of having only *two* fields for email!

The ability to search on "any field" is also a must have.

Problem confirmed on:
- Thunderbird 1.0.2 (20050317)
- Thunderbird 1.0+ (20050529)

Comment 3

13 years ago
The note field is also very important for me as I uses as sort of a "label" or
"keyword".  It depends on the ability to search the note field to display
different groups of contacts I have.  For example, I can search for everyone in
my contact who works for CompanyX and who also went to the same college I went to.

Comment 4

13 years ago
This bug is also present in Mozilla suite 1.78 
Also, I'd find the fix really useful too. 
bug 136309 has now been moved to core address book - duping to that one.

*** This bug has been marked as a duplicate of 136309 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Summary: Can not search on notes in address book → Advanced Address Book Search: Can not search on notes in address book

Updated

4 years ago
Duplicate of bug: 184483

Comment 7

4 years ago
(In reply to David Keeley from comment #0)

> Even better for me would be the open search, anywhere in any
> field.

FTR: That's bug 328199.
You need to log in before you can comment on or make changes to this bug.