preference for sending unsent messages disregarded on startup: always asks

VERIFIED FIXED in Thunderbird2.0

Status

Thunderbird
Preferences
--
minor
VERIFIED FIXED
14 years ago
11 years ago

People

(Reporter: Thomas Hettenhausen, Assigned: Magnus Melin)

Tracking

({fixed1.8.1, regression})

unspecified
Thunderbird2.0
fixed1.8.1, regression
Bug Flags:
blocking-aviary1.5 -
blocking-thunderbird2 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Thunderbird does not have that kind of line, it is version 1.0 (20041206) - from said dialog

Whenever I start Thunderbird 1.0, it asks me whether I want to send the messages
which are in my Unsent Messages folder as soon as I am online.
Via Tools - Options - Advanced, I checked that I do NOT want to sent them,
instead of "Ask me", so I clearly do not want to be asked. I also always start
the application in online mode, since I have 24/7 internet access, so the
question is superflous and annoying.
Changing the line user_pref("offline.send.unsent_messages", x); with x either 0,
1 or 2 manually in prefs.js does not change the behaviour either.

Reproducible: Always
Steps to Reproduce:
1. set up IMAP email account
2. set preferences so that you do not want to send unsent messages when going
from offline to online
3. restart Thunderbird

Actual Results:  
get asked if you want to sent unsent messages

Expected Results:  
should not have shown the dialog box

This started happening with the 1.0 version, was not in 0.9.
No extensions installed, standard theme.
Pretty annoying though. Might go back to last version before 1.0 because of this.
(Reporter)

Comment 1

14 years ago
Bug 224671 might be related, since it is the exact opposite of this bug.

Comment 2

14 years ago
Reproduced with TB 1.0 and TB 1.0+0222, Win2K.  

On program startup online, prompt appears regardless of setting of the 
preference.

On program already running, and going online, if you haven't already been asked 
once about this behavior, you will be prompted if the Preference is No *or* Ask 
Me.  And, this prompt features an Always Ask Me checkbox which is checked, 
regardless of the state of the preference.  But: Once you have selected either 
Send or Don't Send, the preference will be followed on subsequent online actions 
(and the preference will be set according to the state of the Always Ask 
checkbox on the prompt).

However, answering the prompt from the Going Online action does not affect the 
behavior of the Starting Up action.

Maybe this is by design, but it seems needlessly complex, even obscure.


(In reply to comment #1)
> Bug 224671 might be related, since it is the exact opposite of this bug.

That bug is a dupe of bug 232452, which has been fixed; but that fix didn't 
cause this problem, assuming you're correct in your observation that this 
started after 0.9.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → Windows 2000
Summary: preferences for sending unsent messages on app start disregarded, always asks → preference for sending unsent messages disregarded on startup: always asks

Updated

14 years ago
Flags: blocking-aviary1.1?

Updated

14 years ago
Flags: blocking-aviary1.1? → blocking-aviary1.1-

Comment 3

13 years ago
*** Bug 287735 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
*** Bug 326905 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
*** Bug 323994 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

12 years ago
Taking.
Status: NEW → ASSIGNED
OS: Windows 2000 → All
QA Contact: mscott
Hardware: PC → All
(Assignee)

Updated

12 years ago
Assignee: mscott → mkmelin+mozilla
Status: ASSIGNED → NEW
(Assignee)

Comment 7

12 years ago
Created attachment 231291 [details] [diff] [review]
proposed fix (tb + sm)

This checks the pref before asking.
Attachment #231291 - Flags: superreview?(bienvenu)
Attachment #231291 - Flags: review?(bienvenu)
(Assignee)

Updated

12 years ago
Status: NEW → ASSIGNED

Comment 8

12 years ago
Comment on attachment 231291 [details] [diff] [review]
proposed fix (tb + sm)

thanks for the patch, Magnus.  I don't agree with this bug 100% since starting up isn't necessarily the same as going online, but since the user has chosen not to be reminded, which is not the default behaviour, it's better to err on the side of not bothering the user.
Attachment #231291 - Flags: superreview?(bienvenu)
Attachment #231291 - Flags: superreview+
Attachment #231291 - Flags: review?(bienvenu)
Attachment #231291 - Flags: review+
(Assignee)

Updated

12 years ago
Whiteboard: [checkin needed]
mozilla/mailnews/base/resources/content/msgMail3PaneWindow.js 	1.293
mozilla/mail/base/content/msgMail3PaneWindow.js 	1.92
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → Thunderbird 3
(Assignee)

Updated

12 years ago
Attachment #231291 - Flags: approval-thunderbird2?

Comment 10

12 years ago
Verified fixed with TB 3a1-0826.  Is this worth getting into TB 2.0/SM 1.5?
Flags: blocking-thunderbird2?

Comment 11

12 years ago
not a blocker, but am interested in patch approval
Flags: blocking-thunderbird2? → blocking-thunderbird2-

Updated

12 years ago
Attachment #231291 - Flags: approval-thunderbird2? → approval-thunderbird2+
(Assignee)

Updated

12 years ago
Whiteboard: [checkin needed (1.8 branch)]
mozilla/mail/base/content/msgMail3PaneWindow.js 	1.70.2.28
mozilla/mailnews/base/resources/content/msgMail3PaneWindow.js 	1.282.2.10
Keywords: fixed1.8.1
Whiteboard: [checkin needed (1.8 branch)]
Target Milestone: Thunderbird 3 → Thunderbird2.0

Comment 13

12 years ago
V fixed on 2b1-1018, thank you!
Status: RESOLVED → VERIFIED

Updated

12 years ago
Duplicate of this bug: 235406
(Assignee)

Updated

11 years ago
Duplicate of this bug: 374318
You need to log in before you can comment on or make changes to this bug.