random crashes after clicking link or bookmark

RESOLVED DUPLICATE of bug 279205

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 279205
14 years ago
13 years ago

People

(Reporter: Peter6, Assigned: Blake Ross)

Tracking

({crash, regression})

Trunk
x86
Windows 2000
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050121 Firefox/1.0+

Firefox seemingly randomly crashes when a link or bookmark is clicked and is
closed by windows.

situation:
Multiple tabs are open
Happens often when opening a new tab from link or bookmark
Duplicating the problem after restart doesn't work.

This has been starting a few days back.

No Talkback.

Comment 1

14 years ago
can you try with a new profile and report back if problem persists so we can try
to narrow this down a bit?

Also, does this happen solely when lots of tabs are open?

finally, is there a Windows popup?  If so, can you give us the error message?
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> can you try with a new profile and report back if problem persists so we can try
> to narrow this down a bit?
> 
> Also, does this happen solely when lots of tabs are open?
> 
> finally, is there a Windows popup?  If so, can you give us the error message?

->Firefox.exe has generated erros and is closed by windows

I'm switching builds and see when it starts.
(Reporter)

Comment 3

14 years ago
up till the 18th the builds are ok.
Continuing testing newer ones untill the crashing starts
(Reporter)

Comment 4

14 years ago
2005-01-19-13
2005-01-19-16

are both ok

Updated

14 years ago
Keywords: crash
(Reporter)

Comment 5

14 years ago
regressed between 2005-01-19-16 and 2005-01-20-11

talkback -> TB3197069H

Updated

14 years ago
Keywords: regression
(Reporter)

Comment 6

14 years ago
Checkins for that period:

bug 142771 [Core]-Underlined text doesn't stop [Win]
bug 244366 [Core]-[FIXr]Invalidate event processing should flush reflows [Lin]
bug 257177 [Core]-xforms-binding-exception thrown incorrectly [All]
bug 97580  [Core]-joystick.fr always reload on tab switch in gtknotebook [Lin]
bug 278257 [Core]-Need a way to get the bound type of an instance node [All]
bug 276588 [Toolkit]-Rework toolkit command-line handling [All]
bug 277950 [Core]-[FIXr]Crash if <property> has no name attribute [@
nsXBLProtoImplProperty::nsXBLProtoImplProperty()] [All]
bug 274309 [Core]-[FIXr]default submit button sends no real value to cgi script,
even if name="xxx" is specified in the form field [All]
bug 275139 [Core]-[FIXr]Dynamic changes of border-style don't cause reflow [Lin]
bug 277224 [Core]-[FIXr]location.replace("#foo") stops document loads [All]
bug 146066 [Core]-[FIXr]should label element retarget events? [All]
bug 252011 [Core]-Remove extra param in comments section for cancel() in
nsIWebBrowserPrint.idl [Win]
bug 270377 [Core]-nullplugin dialog should only show on left mouse button click
[Lin]
bug 273337 [Core]-memory from gtk widgets should be allocated using gmalloc [Lin]

Comment 7

14 years ago
I'm also seeing this, but didn't with the 20050119 nightly.  Talkback IDs:
TB3209619E, TB3207867X.

Comment 8

14 years ago
To narrow it down some more, I haven't seen any crashes yet, after changing to
2005-01-20-11 nightly.  This is on WinXP.

Updated

14 years ago
Flags: blocking-aviary1.1?
Marking duplicate of bug 279205, but please reopen if this is still present in
tomorrow's builds.

*** This bug has been marked as a duplicate of 279205 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 10

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050127 Firefox/1.0+

WFM (not a single crash after that patch)

Updated

14 years ago
Flags: blocking-aviary1.1?
You need to log in before you can comment on or make changes to this bug.