flash game stops close tab from functioning

RESOLVED FIXED

Status

()

Firefox
Tabbed Browser
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: mossop, Assigned: mconnor)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [eta 7/26], URL)

Attachments

(1 attachment)

fix
1.12 KB, patch
Benjamin Smedberg
: review+
Benjamin Smedberg
: approval1.8b4+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050323 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050323 Firefox/1.0+

After playing the flash game in the URL and then closing the tab it is in, the
close tab button stops working.
This happens the majority of the time but occasionally everything seems fine. I
imagine this is an issue with flash, and I have only seen it with this specific
flash movie.

Reproducible: Sometimes

Steps to Reproduce:
1. Have firefox open with at least one page loaded.
2. Load the URL (http://www.officinepixel.com/online/games/lab.htm) into a new tab.
3. Enter the game (click a few times till the animation sequence starts)
4. Close the tab with the game on it.
5. Try to close the tab that is now selected.

Actual Results:  
Nothing happens. The close tab button does nothing and the clost tab in the
context menu also does nothing.
Changing to a different tab and back again makes seems to fix the problem.


Expected Results:  
The close tab button should close the tab.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050323
Firefox/1.0+

Confirmed

->NEW
->?1.1
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-aviary1.1?

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 78414 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 3

13 years ago
sorry, I didn't see it was about the button
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 4

13 years ago
WFM i have no problems to close tabs(new profile on ....Mozilla/5.0 (Windows; U;
Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
the flash plugin dosn't load for me on the trunk builds
based on last comment
unspecified->trunk
Version: unspecified → Trunk
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050402
Firefox/1.0+

WFM now too

is anyone still able to reproduce with the latest build ?
(Reporter)

Comment 7

13 years ago
Still seeing on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050402 Firefox/1.0+, though not sure what the time of this build was.

Some additional notes.

After you close the tab with the flash on it, the next tab displays but the
status bar and url remain as they were with the flash tab. Opening a new tab at
this point leaves the url and status bar the same still. Trying to open a page
on this new tab at this point will not work, neither from the url bar or
bookmarks. Changing tabs fixes everything though.

Mossop
I can close any tab, forgot to look at the other issues

1.Indeed the locationbar has the url of the closed tab and doesn't change when
you switch to any ! other tab.

2.A bookmark won't load

3.Get MiniT extension (drag&indicator) and notice the indicator jumping around
if you get near the "dead" tab

somehow a weird number of things happen around this tab

I don't know if we should not file a string of bugs, 1 for each issue ?

CC-ing mconnor to let him give a verdict on how we should proceed.



(Reporter)

Comment 9

13 years ago
The more I look at this the stranger it gets. When you try to close a tab but
fail, the js console gives:
Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIDOMXULElement.boxObject]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://global/content/bindings/browser.xml :: get_docShell :: line 0"  data: no]

When you have opened the new tab and try to browse to a bookmark with it, you
get the same error.

Now for more fun. If instead of closing the flash game you switch to the tab to
the left of it, then close that tab, the flash game is displayed again but the
tab's title is that of the tab you just closed. Now trying to close the flash
tab gives:
Error: uncaught exception: [Exception... "Node was not found"  code: "8"
nsresult: "0x80530008 (NS_ERROR_DOM_NOT_FOUND_ERR)"  location:
"chrome://global/content/bindings/tabbrowser.xml Line: 1192"]
Trying to close it a second time gives:
Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIWebProgress.removeProgressListener]" 
nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://global/content/bindings/tabbrowser.xml :: removeTab :: line 1151" 
data: no]
You can then browse away from the flash game happily, but the browser and tab
title remain stuck.

Oh and all this testing was with a totally clean profile so no extensions to
worry about.

Mossop
Do you have any idea when this ever regressed ?
If we have a date we should be able to find the cause
(Reporter)

Comment 11

13 years ago
Ok I managed to narrow it down to between builds from 8th and 9th March. The
checkins are shown here:
http://tinderbox.mozilla.org/bonsai/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1110289140&maxdate=1110379740

Hopefully that should help pinpoint the problem.
keyword regression

patches for period 20050308-07 until 20050309-7 Win32 builds
Fixes: OS in []

   1. bug 212123 [Core]-Fix temp file creation in nsFileSpec.[All]
   2. bug 230281 [Core]-Contextmenu blocking doesn't work. Right Click always
opens the standard Context menu. [Mac]
   3. bug 256104 [Firefox]-Need element IDs in viewSource.xul [All]
   4. bug 251751 [Firefox]-Firefox Help window should not be alwaysRaised [Win]
   5. bug 254056 [Firefox]-focus lost when closing tab [All]
   6. bug 277657 [Core]-textbox.maxLength doesn't work [All]
   7. bug 282141 [Core]-Use system colors pref uses the wrong color for default
background [Lin]
   8. bug 283147 [Core]-Crash [@ TableBackgroundPainter::TableBackgroundPainter]
using vbox:hover{display:table;} with inside iframe in it [Win]
   9. bug 284098 [Firefox]-Error: aSubject is not defined when removing cookie [All]
  10. bug 284351 [Core]-nsSchemaLoader doesn't handle xsd:complexType correctly.
[All]
  11. bug 284993 [Core]-https:// selects tabs opened from links, ignoring my
preference [All]
  12. bug 285219 [Core]-RangeError: reserved slot index out of range [Win]
  13. bug 285244 [Core]-open in tabs crashes [@ js_Interpret ] [All](bug bug
285219,causing this, was backed out)


Patched but not completely fixed:

   1. bug 260068 [Firefox]-Dropping extension/theme files to manager didn't
install it [All]
   2. bug 279768 [Firefox:Build Config]-Bring build system to work with
--enable-ui-locale [All]
   3. bug 282183 [Core]-sync xpfe listbox.xml with toolkit listbox.xml [All]
   4. bug 282189 [Core]-sync xpfe toolbarbutton.xml with toolkit
toolbarbutton.xml [All]

Keywords: regression
(Reporter)

Comment 13

13 years ago
I just found this bug again with another flash game:

http://www.sonypictures.com/movies/triplex2/site/game/game_mission.html
(Reporter)

Comment 14

13 years ago
This bug appears to be a little more diverse. It also happens with this url,
where there isn't a flash game, but a java applet.

http://www.houseof3d.com/pete/applets/wireframe/fractal/

Comment 15

13 years ago
I also often see similar behavior when viewing PDFs. I don't know whether it's
the same issue, because in my case usually other tabs can be closed normally,
and it's just one tab that won't go away.
(Assignee)

Comment 16

13 years ago
testing here, the closebutton is broken, but not middle-click and contextmenu close.
Assignee: bugs → mconnor
Status: REOPENED → NEW
Flags: blocking-aviary1.1? → blocking1.8b4+

Updated

13 years ago
Whiteboard: [eta 7/26]
(Assignee)

Comment 17

13 years ago
Created attachment 190610 [details] [diff] [review]
fix

simple one-liner, zero risk, fixes the bug.
Attachment #190610 - Flags: review?(benjamin)
Attachment #190610 - Flags: approval1.8b4?

Updated

13 years ago
Attachment #190610 - Flags: review?(benjamin)
Attachment #190610 - Flags: review+
Attachment #190610 - Flags: approval1.8b4?
Attachment #190610 - Flags: approval1.8b4+
(Assignee)

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.