The default bug view has changed. See this FAQ.

Using keyboard to navigate through context menus of menu items (e.g. bookmarks) skips every other item

VERIFIED FIXED

Status

()

Core
XUL
VERIFIED FIXED
12 years ago
9 years ago

People

(Reporter: rstrong, Assigned: neil@parkwaycc.co.uk)

Tracking

({fixed1.8, regression, testcase})

Trunk
x86
Windows XP
fixed1.8, regression, testcase
Points:
---
Bug Flags:
blocking1.8b3 -
blocking1.8b5 -
blocking1.8rc1 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [no l10n impact])

Attachments

(3 attachments)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050418 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050418 Firefox/1.0+

When using the keyboard to select bookmark context menu menuitems some menuitems
are often skipped. The closest bug to this I could find is bug 266076 but that
deals with accesskeys.

Reproducible: Always

Steps to Reproduce:
1. Click Bookmarks and context menu click a bookmark
2. Use the arrow keys to select menuitems

Actual Results:  
Some enabled menuitems are skipped

Expected Results:  
Each enabled menuitem is selected in turn

This bug appears for all bookmarks and bookmark folder in the Bookmarks menu. It
appears that if the context menu is brought up from the top of the Bookmarks
Toolbar for a bookmark or bookmark folder that it is possible to select each
enabled menuitem in turn using the arrow keys on the keyboard. If the bookmark
or bookmark folder is inside of another bookmark folder in the Bookmarks Toolbar
that this bug is exhibited.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050419
Firefox/1.0+

Confirmed.

the Items are picked seemingly at random
very much depends on where the mousepointer is located
Looks to have regressed somewhere between 20050117 and 20050127. And at least
what I'm seeing isn't random, it's just every other menu item gets skipped.
Keywords: regression
I noticed it wasn't random as well just after filing. It seems as if the
keypress event is running twice for popups that are a contentmenu of a popup.
Created attachment 181370 [details]
testcase
This does not appear to be bookmarks specific though it does affect bookmarks.
Changing the summary, product, and component accordingly though I suspect the
category may still be incorrect.
Component: Bookmarks → Toolbars and Toolbar Customization
Product: Firefox → Toolkit
Summary: Bookmarks context menu menuitems are inconsistently selected using keyboard → context menu menuitems are inconsistently selected using keyboard for menupopup context menu
Component: Toolbars and Toolbar Customization → Keyboard: Navigation
Product: Toolkit → Core
Version: unspecified → Trunk
Keywords: testcase
Reassigning to nobody@mozilla.org since this is not bookmarks specific to get it
off of Vladimir's plate.
Assignee: vladimir+bm → nobody
Aaron, could this be a regression from your bug 282438? The window is
2005-02-17-07 to 2005-02-18-07, and even though I don't know what I'm talking
about, yours looks the most likely.
Component: Keyboard: Navigation → XP Toolkit/Widgets: Menus
The regression range in comment 7 is off by a month (compare comment 2).  I see
the bug in a 2005-01-19-08 build but not a 2005-01-18-07 build.

So bug 282438 is definitely not it.

Bug 167145, on the other hand, is quite a likely culprit, since it messed around
with key events...
Assignee: nobody → aaronleventhal
Flags: blocking1.8b3?
Blocks: 167145
Flags: blocking1.8b4+
Flags: blocking1.8b3?
Flags: blocking1.8b3-
Whiteboard: [no l10n impact]

Comment 9

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050802
Firefox/1.0+ ID:2005080207

For me, the navigation moves in the opposite direction of the key i'm pressing.
i.e. I press up and it moves down.
Aaron - it appears that way visually because it is skipping an item.

Comment 11

12 years ago
Created attachment 191588 [details] [diff] [review]
Ignore key presses that have already been dealt with. There can be more than one listener on the same node.
Attachment #191588 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #191588 - Flags: review?(neil.parkwaycc.co.uk)

Comment 12

12 years ago
Spin off bug 303404 is a crash I found while debugging this.
(Assignee)

Comment 13

12 years ago
Created attachment 191845 [details] [diff] [review]
Don't attach multiple listeners

Comment 14

12 years ago
*** Bug 304603 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Attachment #191588 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #191588 - Flags: superreview?(bzbarsky)
Attachment #191588 - Flags: review?(neil.parkwaycc.co.uk)
Attachment #191588 - Flags: review?(bzbarsky)

Comment 15

12 years ago
Neil's got a patch
Assignee: aaronleventhal → neil.parkwaycc.co.uk

Updated

12 years ago
Attachment #191845 - Flags: superreview?(dbaron)
Attachment #191845 - Flags: review+

Updated

12 years ago
Attachment #191588 - Flags: superreview?(bzbarsky)
Attachment #191588 - Flags: review?(bzbarsky)

Updated

12 years ago
Whiteboard: [no l10n impact] → [no l10n impact][need SR dbaron]

Updated

12 years ago
Flags: blocking1.8b5+ → blocking1.8b5-
Attachment #191845 - Flags: superreview?(dbaron) → superreview+
(Assignee)

Comment 16

12 years ago
Fix checked in to the trunk.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 17

12 years ago
*** Bug 311259 has been marked as a duplicate of this bug. ***
Flags: blocking1.8rc1?

Updated

12 years ago
Summary: context menu menuitems are inconsistently selected using keyboard for menupopup context menu → Using keyboard to navigate through context menus of menu items (e.g. bookmarks) skips every other item

Updated

12 years ago
Attachment #191845 - Flags: approval1.8rc1?

Comment 18

12 years ago
Comment on attachment 191845 [details] [diff] [review]
Don't attach multiple listeners

I'm nervous about this change. We can't afford any regressions this late in the
game. What kind of testing has been done here and what kind of risk does this
patch pose?

Comment 19

12 years ago
neil, aaron, qa, have we verified that this doesn't break anything?
Keywords: qawanted
I will check this on Windows XP, but using today's Mac trunk build (Mozilla/5.0
(Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051011
Firefox/1.6a1), the test case doesn't work. Using today's Mac Branch build, the
test case does work.
Just to clarify, when I mean the test case works, you can use the arrow keys to
move up and down without skipping.

(In reply to comment #20)
> I will check this on Windows XP, but using today's Mac trunk build (Mozilla/5.0
> (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051011
> Firefox/1.6a1), the test case doesn't work. Using today's Mac Branch build, the
> test case does work.
This looks ok using today's Windows Trunk build (Mozilla/5.0 (Windows; U;
Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051011 Firefox/1.6a1). If I run the
test case, I can arrow through the choices with no problem. I also did some
context clicking on bookmarks and didn't see any problems.

Updated

12 years ago
Attachment #191845 - Flags: approval1.8rc1? → approval1.8rc1+

Comment 23

12 years ago
plussing since we decide to take this patch.
Flags: blocking1.8rc1? → blocking1.8rc1+

Updated

12 years ago
Status: RESOLVED → VERIFIED
Keywords: qawanted
Whiteboard: [no l10n impact][need SR dbaron] → [no l10n impact]

Comment 24

12 years ago
Neil, can you get this checked into the branch soon? If not, let us know and we
can find someone who can land it (maybe me :)).

(Assignee)

Comment 25

12 years ago
Sorry, I overlooked the a=asa.
Keywords: fixed1.8

Updated

9 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: mconnor → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.