Reply all does not show the to, cc, sent and original subject in the mail body

RESOLVED DUPLICATE of bug 67089

Status

--
enhancement
RESOLVED DUPLICATE of bug 67089
14 years ago
13 years ago

People

(Reporter: patrick.schmitt, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Build Identifier: version 1.0.2 (20050317)

I want to replace Outlook / Outlook Express with Mozilla Thunderbird.
Most of our User use the Outlook feature Reply all, where the Mail client adds 
the following information in the Mail body.
Example:
----- Original Message ----- 
From: Das Team von Microsoft Outlook Express 
To: Neuer Outlook Express-Benutzer 
Sent: Wednesday, April 28, 2004 9:53 AM
Subject: Willkommen

In Thunderbird there is only the option to insert something like this:
"author" wrote the following on "date":

By using the following configuration in user.js:
user_pref("mailnews.reply_header_type", 3); 

// If you set 3 for the pref above then you may set the following prefs. 
user_pref("mailnews.reply_header_authorwrote", "%s wrote the following"); 
user_pref("mailnews.reply_header_ondate", "on %s"); 
user_pref("mailnews.reply_header_separator", " "); 
user_pref("mailnews.reply_header_colon", ":"); 
// The end result will be [authorwrote][separator][ondate][colon]

In order to replace Outlook we need the extra informations in the Mail Body, 
because in long Mail-Threads user replace and add Receipient without qouting it 
into the messages.



Reproducible: Always

Steps to Reproduce:
1. Open a email
2. Klick reply all


Actual Results:  
The reply looked the following:

AfterJobParty wrote the following on 15.11.2004 20:34:

> Der Inhalt dieser Mail in der Übersicht:
>
> 1. AfterJobParty präsentiert: Die Party der Nachtschwärmer am Freitag,
> 19. November  in den Rheinterrassen, Köln-Deutz 



Expected Results:  


-----Ursprüngliche Nachricht-----
Von: AfterJobParty [mailto:mail@afterjobparty.de] 
Gesendet: Montag, 15. November 2004 20:35
An: mail@afterjobparty.de
Betreff: Save the date: Donnerstag, 09. Dezember - Die AfterJobParty "X-Mas 
Special" in der Flora, präsentiert von Radio Köln 107,1

Der Inhalt dieser Mail in der Übersicht:

1. AfterJobParty präsentiert: Die Party der Nachtschwärmer am Freitag,
19. November  in den Rheinterrassen, Köln-Deutz

2. Die AfterJobParty "Christmas Special" am Donnerstag, 09. Dezember in
der Flora, präsentiert von Radio Köln 107,1


As I see in the Thunderbird source code there are 4 ways to build the 
Information in the mail body :

      switch (replyHeaderType)
      {
        case 0: // No reply header at all
          header=PR_FALSE;
          headerDate=PR_FALSE;
          break;

        case 2: // Insert both the original author and date in the reply header 
(date followed by author)
        case 3: // Insert both the original author and date in the reply header 
(author followed by date)
          header=PR_TRUE;
          headerDate=PR_TRUE;
          break;

        case 4: // XXX implement user specified header
        case 1: // Default is to only view the author. We will reconsider this 
decision when bug 75377 is fixed.
        default:
          header=PR_TRUE;
          headerDate=PR_FALSE;
          break;
      }
I think Case 4 might be the place to implement this issue, but this might be a 
feature which improves the ability to replace Outlook and might be done as case 
5.
Duplicate of bug 67089.
Summary: Reply all does not show the to, cc, sent and original subject in the mail body → Reply all does not show the to, cc, sent and original subject in the mail body

*** This bug has been marked as a duplicate of 67089 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.