File res/hiddenWindow.html missing in installer build

RESOLVED FIXED

Status

()

Firefox
Installer
--
blocker
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Michael Taeuber, Assigned: Benjamin Smedberg)

Tracking

({fixed-aviary1.0.5, regression, smoketest})

unspecified
fixed-aviary1.0.5, regression, smoketest
Points:
---
Dependency tree / graph
Bug Flags:
blocking-aviary1.0.5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.9) Gecko/20050702 Firefox/1.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.9) Gecko/20050702 Firefox/1.0.5

When using the installer build (exe-file) of the nightly
2005-07-02-04-aviary1.0.1 , Firefox doesn't start up. There is an error message
that the file res/hiddenWindow.html is missing.
After creating an empty file with this name, Firefox starts.
The missing file is included in the zip build.

Reproducible: Always

Steps to Reproduce:
1. Install Firefox 2005-07-02 using the installer build
2. Try to start Firefox
3.

Actual Results:  
Firefox doesn't start. Error message about missing file res/hiddenWindow.html
shows up.

Expected Results:  
Firefox should start :-)
(Assignee)

Comment 2

13 years ago
Fixed on trunk by my own authority, thanks for the quick and accurate bugreport!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Updated

13 years ago
Blocks: 297543
(Assignee)

Comment 3

13 years ago
This needs to be fixed on the branches, and it doesn't have a 1.7.x blocking
flag, bah.
Flags: blocking-aviary1.0.5+

Comment 4

13 years ago
*** Bug 299451 has been marked as a duplicate of this bug. ***
This bug is also in the Mozilla nightly for 2005070205 but, it seems to be
running fine after clicking OK.
(Reporter)

Comment 7

13 years ago
Problem exists also in Thunderbird nightly 2005-07-02-07-aviary1.0.1, but T-Bird
doesn't show a error message.
Is this problem also solved by the fix of Benjamin Smedberg?

Comment 8

13 years ago
*** Bug 299477 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

13 years ago
*** Bug 299503 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

13 years ago
*** Bug 299523 has been marked as a duplicate of this bug. ***
OS: Windows XP → All
Hardware: PC → All
Whiteboard: 1.0.1 branch checkin needed

Comment 11

13 years ago
(In reply to comment #3)
> This needs to be fixed on the branches, and it doesn't have a 1.7.x blocking
> flag, bah.

The suite trunk and 1.7 branch have been covered by bug 299463.

Comment 12

13 years ago
CC'ing jst, this looks like a regression from his recent checkin for bug 297543.

Benjamin: Please get this fix on the Aviary 1.0.1 branch asap!  a=jay

Comment 13

13 years ago
On linux trunk this still isn't fixed; in the fix Benjamin landed by comment #2
hiddenWindow.css is added instead of hiddenWindow.html.
http://lxr.mozilla.org/mozilla/source/browser/installer/unix/packages-static#230

Can somebody reopen this bug?

Comment 14

13 years ago
Created attachment 188261 [details] [diff] [review]
patch to correct things on linux
Status: UNCONFIRMED → NEW
Ever confirmed: true
fyi: 'tis a smoketest blocker Win 2005-07-05-04-aviary1.0.1
Severity: normal → blocker
Keywords: regression, smoketest
(Assignee)

Comment 17

13 years ago
Committed unix s/css/html/ and committed on AVIARY_1_0_1_20050124_BRANCH.
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Keywords: fixed-aviary1.0.5
Resolution: --- → FIXED
*** Bug 299772 has been marked as a duplicate of this bug. ***
The Linux fix doesn't seem to be checked in on the trunk, and I'm seeing the
problem even on non-installer builds. (i.e., latest nightly needs me to touch
res/hiddenWindow.html.)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 20

13 years ago
Joe, is your build GRE based? If so, it may be the same problem as in Windows
(see bug 299463) where the hiddenWindow.html was missing in GRE creating the
very same problem. The reason is the patch from the secret bug patch from the
secret bug 297543 changed mozilla/xpfe/appshell/src/nsAppShellService.cpp replacing
"about:blank" with "resource://gre/res/hiddenWindow.html". Take note there is a
"gre" in the URI.
Jacek, it looks like my build is gre-based. I'm not positive - all I did was
download the nightly build - but my firefox directory contains the subdirectory
"greprefs," and the resource URL you quoted works, while without "gre" it
doesn't work at all.
verified fixed on Fx branch with Windows and Linux builds from 0706

Comment 23

13 years ago
Still broken on Seamonkey Win32 build 2005070605 on WinXP. 
This is also on Windows Thunderbird 1.0.5 2005-07-06-07-aviary1.0.1
as a workaround I cut and pasted hiddenWindow.html from Fx 1.0.5 to /res
ignore my last comment #24, I had inadvertently installed yesterdays build. 
this is fixed in Windows Tbird build 2005-07-06-07-aviary1.0.1
*** Bug 299714 has been marked as a duplicate of this bug. ***

Comment 27

13 years ago
*** Bug 299584 has been marked as a duplicate of this bug. ***

Comment 28

13 years ago
isn't this fixed?
Assignee: nobody → benjamin
Status: REOPENED → NEW

Comment 29

13 years ago
I don't know the version of Bugzilla on this site, but maybe someone changed the
flag with this Bugzilla bug:
http://www.bugzilla.org/security/2.18.1/

Comment 30

13 years ago
Shouldn't this bug be marked fixed? -- trying to clean up the "regression" list
(Assignee)

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
Whiteboard: 1.0.1 branch checkin needed
You need to log in before you can comment on or make changes to this bug.