Closed Bug 299463 Opened 19 years ago Closed 19 years ago

File res/hiddenWindow.html missing in installer build

Categories

(SeaMonkey :: Installer, defect)

x86
All
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
seamonkey1.0alpha

People

(Reporter: ajschult784, Assigned: jst)

References

Details

(Keywords: fixed1.7.9)

Attachments

(3 files, 1 obsolete file)

it'd be nice to let people know when you're going to break the world
Attached patch patchSplinter Review
Attachment #188038 - Flags: review?(benjamin)
Attachment #188038 - Flags: approval1.8b3?
Duplicate of Bug 299449
Sorry, that's the Firefox bug for the same thing.
Comment on attachment 188038 [details] [diff] [review]
patch

Please land this on the 1.7 branch as well as the trunk.
Attachment #188038 - Flags: review?(benjamin)
Attachment #188038 - Flags: review+
Attachment #188038 - Flags: approval1.8b3?
Attachment #188038 - Flags: approval1.8b3+
Attachment #188038 - Flags: approval1.7.9+
checked into trunk and MOZILLA_1_7_BRANCH.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
*** Bug 299474 has been marked as a duplicate of this bug. ***
*** Bug 299648 has been marked as a duplicate of this bug. ***
Reopening. Branch (1.7) has still the problem in the latest nightly build
2005070408.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/2005-07-04-08-1.7/windows-xpi/browser.xpi
includes hiddenWindow.html, so I don't know what else is needed.
> so I don't know what else is needed.

I already know. hiddenWindow.html is missing in GRE. When I copied the file into
C:\Program Files\Common Files\mozilla.org\GRE\1.7.9_2005070406\res, the problem
was solved (well, worked around).
... and no wonder. The patch from the secret bug (damn such stupid secrets!),
changed mozilla/ xpfe/ appshell/ src/ nsAppShellService.cpp replacing
"about:blank" with "resource://gre/res/hiddenWindow.html".

That's how I guessed I need to copy the file to .../gre/res directory.
CC'ing jst, this looks like a regression from his recent checkin for bug 297543. 

Setting blocking1.7.9+ flag, please get this fix on the 1.7 branch asap!  a=jay
Flags: blocking1.7.9+
(In reply to comment #10)
> > so I don't know what else is needed.
> 
> I already know. hiddenWindow.html is missing in GRE.

Looks like it goes in mozilla/embedding/config/basebrowser-installer-win.pkg to
get into the GRE.

Flags: blocking-seamonkey1.0a+
Assignee: ajschult → jst
Status: REOPENED → NEW
Whiteboard: eta 7/5 need patch
Attached patch Same thing for aviary (obsolete) — Splinter Review
Attachment #188373 - Flags: superreview?(benjamin)
Attachment #188373 - Flags: review?(benjamin)
Comment on attachment 188373 [details] [diff] [review]
Same thing for aviary

Um, that belongs in a different bug, and it's a different patch too, me thinks.
Attachment #188373 - Attachment is obsolete: true
Attachment #188373 - Flags: superreview?(benjamin)
Attachment #188373 - Flags: review?(benjamin)
Fix landed on the 1.7 branch by kairo@kairo.at.
Status: NEW → RESOLVED
Closed: 19 years ago19 years ago
Keywords: fixed1.7.9
Resolution: --- → FIXED
Whiteboard: eta 7/5 need patch
Reopening again since kairo's patch went in on 7/2 and comment #8 says the 7/4
builds were still broken.  Jst is investigating.
Status: RESOLVED → REOPENED
Keywords: fixed1.7.9
Resolution: FIXED → ---
GRE-based installer builds, such as
http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-trunk/seamonkey-1.0a.en-US.win32.stub-installer.exe,
are still displaying the alert dialog for the missing hiddenWindow.html.

comment 10, comment 11, and comment 13 have all restated this issue so this bug
isn't really fixed.
I've landed the first attachment for trunk and 1.7 branch on 2005-07-02, when
this bug fixed. The reopen happened because it was still seen on the branch, and
dveditz seems to be right that it needs to be patched in the file for GRE as
well, which wasn't included in the patch here (as this has been ported from
aviary, which does not have seperate GRE packages AFAIK).
Attachment #188385 - Flags: superreview?(dveditz)
Attachment #188385 - Flags: review?(dveditz)
Comment on attachment 188385 [details] [diff] [review]
Add hiddenWindow.html to GRE's res dir.

r/sr=dveditz
Attachment #188385 - Flags: superreview?(dveditz)
Attachment #188385 - Flags: superreview+
Attachment #188385 - Flags: review?(dveditz)
Attachment #188385 - Flags: review+
Comment on attachment 188385 [details] [diff] [review]
Add hiddenWindow.html to GRE's res dir.

a=jay for the 1.7 branch.  Let's get this in asap.
Attachment #188385 - Flags: approval1.7.9+
shouldn't the file also be removed from the other windows packaging files, so
that it doesn't get shipped twice?
Fix landed on the 1.7 branch.
Keywords: fixed1.7.9
Comment on attachment 188385 [details] [diff] [review]
Add hiddenWindow.html to GRE's res dir.

We want this in SeaMonkey trunk as well.

biesi:
I'd rather deal with removing duplicate versions of it once the bigger problem
of getting warning dialogs etc. is fixed. Non-GRE-based builds will need the
file in the other files. I guess we can look to remove it where ua.css also
isn't listed...
Attachment #188385 - Flags: approval1.8b3?
> once the bigger problem of getting warning dialogs etc. is fixed

FWIW: This bug resulted in a bigger problem for me on two different home
profiles, and my work profile, than just a warning dialog.  In all cases, 3/4
times I'd start SeaMonkey (previously also seen with Mozilla) I'd be left with
only a splash screen and nothing else.  I'd have to kill the process.  As soon
as I copied the missing hiddenWindow.html file over, this stopped happening, and
the browser would load every time.

I can only think that the warning dialog was somehow being called, but just not
being shown - so the browser was waiting for an event (my clicking on OK) that
never actually happened. (?)  Although, this doesn't explain why it worked
sometimes.  However, fixing this bug should also fix the problem I was seeing.
Attachment #188385 - Flags: approval1.8b3? → approval1.8b3+
checked in the GRE fix for trunk.

OK, I hope this is really fixed now.
Status: REOPENED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → FIXED
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b3) Gecko/20050708 SeaMonkey/1.0a]
(nightly) (W98SE)

V.F.
Status: RESOLVED → VERIFIED
Target Milestone: --- → Seamonkey1.0alpha
*** Bug 300228 has been marked as a duplicate of this bug. ***
*** Bug 300503 has been marked as a duplicate of this bug. ***
*** Bug 300512 has been marked as a duplicate of this bug. ***
I think this need to be reopened, I've been getting this error with 1.8b2
Could you check your build ID and make sure it is more recent than the one
mentioned in comment 29 (20050708).
*** Bug 301331 has been marked as a duplicate of this bug. ***
*** Bug 302268 has been marked as a duplicate of this bug. ***
*** Bug 303877 has been marked as a duplicate of this bug. ***
If you have a fix, it would be nice to make a new build available. However, even
though I haven't downloaded a more recent build (7/2/05 is still the most recent
build), it has stopped doing it in the past few days.
(In reply to comment #38)
> If you have a fix, it would be nice to make a new build available. However, even
> though I haven't downloaded a more recent build (7/2/05 is still the most recent
> build), it has stopped doing it in the past few days.

We have plenty newer SeaMonkey builds available, I don't know what you mean...
I'm using Mozilla Suite for Windows, not Seamonkey. I'm hearing different things
about what Seamonkey is.
When I click on "latest builds" under QA, I get
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest/ where the latest
mozilla-win32-installer.exe is July 2 (and the latest Seamonkey is July 3).
Eileen, Mozilla suite is not existent on any 1.8 or higher version any more
(1.7.x are the latest and last version supported by Mozilla Foundation), and its
new builds were stopped back then because of that.
SeaMonkey is the new project emerged out of that and continuing the suite code,
and its new builds are up in the seamonkey directory on ftp.mozilla.org - see
http://www.mozilla.org/projects/seamonkey/ for more info about that project.
*** Bug 325538 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: