Restarting after an application update should restore the session

RESOLVED FIXED in mozilla1.8.1beta1

Status

()

enhancement
RESOLVED FIXED
14 years ago
11 years ago

People

(Reporter: mrbkap, Assigned: zeniko)

Tracking

({fixed1.8.1})

1.8 Branch
mozilla1.8.1beta1
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

After downloading an update (especially if it's downloaded automatically in the
background) I'm asked if I want to restart Firefox to apply the update. It would
be very cool if we could restore the browing session to where it was (windows
and tabs) before the update.

I suppose there might be questions about if there was post data in one of the
tabs or something, but those should be solvable.
This would depend on having an easy way to save sessions, which has historically
been bug 159357 (see also bug 307637), but that bug is an old dupe bucket with
no progress made towards a solution so I don't think this should be marked as a
dupe of that.
OS: Windows XP → All
Hardware: PC → All
i thought this was in the planning for 2.0
http://wiki.mozilla.org/Firefox:Options_Window
(see top layout, section start)
If we want true sessionsaving capabilities it's probably best to get it for
restart after update, normal restart and after crash.

A quick hack (for just at restart), which probably isn't that much work. is
likely to be just a bug/dupe generator.

http://kb.mozillazine.org/SessionSaver
*** Bug 312086 has been marked as a duplicate of this bug. ***
This is covered by the requirements of Session Restore as tracked in meta bug 328154. (Also, the request to remove the Update Now/Update Later dialog should reduce the annoyance factor of forced updates not saving state - see bug 334767)
Blocks: 328154

Comment 6

13 years ago
Looks like the software update dialog needs to set browser.sessionstore.resume_session_once to true before closing Firefox:
http://lxr.mozilla.org/seamonkey/source/browser/components/sessionstore/src/nsSessionStore.js#58
http://lxr.mozilla.org/seamonkey/source/toolkit/mozapps/update/content/updates.js#1436  (onWizardFinish)

Comment 7

13 years ago
Note discussion in bug 335864.
Flags: blocking-firefox2?
Summary: Restarting after an update could restore the session → Restarting after an update should restore the session
Version: unspecified → 2.0 Branch
hmm, this should be fixed now, no?
(In reply to comment #8)
> hmm, this should be fixed now, no?
> 

No, sessionrestore doesn't work on trunk (disabled) and this hasn't landed on branch
Flags: blocking-firefox2? → blocking-firefox2+
Assignee: nobody → dietrich
Target Milestone: --- → Firefox 2 beta1

Updated

13 years ago
Depends on: 335864

Comment 10

13 years ago
This was fixed by bug 335864. It works just fine with branch nightlies (on windows at least).

Reenabling session restore on the trunk is bug 337320.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
This certainly doesn't look fixed to me. This bug is about app update, not extension updates/installs.
Status: RESOLVED → REOPENED
Keywords: fixed1.8.1
Resolution: FIXED → ---
Summary: Restarting after an update should restore the session → Restarting after an application update should restore the session

Comment 12

13 years ago
While you're at it, can the "You are about to close x tabs" confirmation be suppressed in this scenario where you are going to restore the session after the browser is restarted?  Or should that be a separate bug?

Comment 13

13 years ago
(In reply to comment #11)
> This bug is about app update, not extension updates/installs.
Right.

> This certainly doesn't look fixed to me.
Look again ;-)
I just updated to today's windows branch nightly, and Bon Echo restored the two tabs I had open (this bug and www.mozilla.org).
Also have a look at the code in bug 335864: It changed nsAppStartup.cpp to notify about the quit-application reason (shutdown or restart), and nsSessionStore.js to set the browser.sessionstore.resume_session_once pref in the case of a restart. That's not specific to restarts from the Add-ons manager.
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 14

13 years ago
--> Simon, who fixed this by fixing bug 335864.
Assignee: dietrich → zeniko
Status: REOPENED → NEW

Comment 15

13 years ago
I just filed bug 341248 (don't show Confirm close tab dialog when restarting Firefox).
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
*** Bug 344777 has been marked as a duplicate of this bug. ***
*** Bug 352802 has been marked as a duplicate of this bug. ***
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.