Bug 159357 (sessionsaver)

Add "Last tabs visited" to Navigator startup preferences / save tab session when closing, quitting.

VERIFIED FIXED

Status

SeaMonkey
General
--
enhancement
VERIFIED FIXED
15 years ago
8 years ago

People

(Reporter: AL, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Why not save ALL tabbed sites instead(or in addition to) "Last page 
visited".This would be very interesting for people who must monitor the same 
sites every day.
AL

Comment 1

15 years ago
Reporter:  Do you mean, you'd like to see another home page option?  For example,

Preferences | Navigator | 

When Navigator starts up display
  ( )  Blank page
  ( )  Home page
  ( )  Last page visited
  ( )  Last tabs visited
(Reporter)

Comment 2

15 years ago
Yes, exactly as you describe it. When you open the browser all tabbed sites
appear restoring your last working environment.
I think that would be an IE killer!
AL

Comment 3

15 years ago
Something tells me that this is a duplicate.  However, I can't find it.

Other related bugs that are NOT duplicates deal with setting the home page to a
tab group (bug 118835), and an option to *manually* reload tab sites from a
previous session (bug 147404).

But I seem to recall seeing a bug requesting that when Mozilla is started, it
come back up with all of the windows and tabs that were in use when it was
previously closed.  I just can't find it now.

Al: What do you want Mozilla to do if there was more than one window (browser
session) open when it was closed?  Do you want ALL windows and their tabs
restored, or just the focused window with its tabs?
(Reporter)

Comment 4

15 years ago
I would prefer just the focused window for clarity.
AL

Comment 5

15 years ago
Good, that keeps it consistent with what "Last page visited" currently does.  As
such, I don't believe this is a duplicate.  (I could still be wrong.)

Confirming bug.
-> History: Global.  (Perhaps this should be Tabbed Browsing, not sure.  But we
don't currently keep a history of each tab on exit do we?)

Suggest changing Summary to something like: Add "Last tabs visited" to Navigator
startup preference.
Status: UNCONFIRMED → NEW
Component: Browser-General → History: Global
Ever confirmed: true

Comment 6

15 years ago

*** This bug has been marked as a duplicate of 147030 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 7

15 years ago
Reopening.

1. Please do not mark a bug a duplicate of another bug that has, itself, been
marked a duplicate of something else.

2. This bug is NOT a duplicate of bug 147404 (via bug 147030).  See comment 3. 
That bug wants a way of *manually* reloading tabs from the last session.  This
bug is about setting such behaviour as an option for *automatically* happening
via Edit -> Preferences -> Navigator.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 8

15 years ago
Tweaking bug Summary for clarity (AL: change this back if it's unacceptable).

From: "Edit->Preferences->  Last page visited"
To: "Add 'Last tabs visited' to Navigator startup preferences."


Summary: Edit->Preferences-> Last page visited → Add "Last tabs visited" to Navigator startup preferences.
(Reporter)

Comment 9

15 years ago
I just found that crazy browser (http://www.crazybrowser.com) spotted it 
correctly and associated this feature cleverly with the tab group concept. 
Groups allow you to have several of those environments saved.

AL

Comment 10

15 years ago
> But I seem to recall seeing a bug requesting that when Mozilla is started,
> it come back up with all of the windows and tabs that were in use when it
> was previously closed.

Might just possibly have been me in
http://bugzilla.mozilla.org/show_bug.cgi?id=134800#c14 point 6), but then again
this was more a list of 6 things that I personally felt were missing in Mozilla,
so maybe not.

Irrespective of source though, I'm definitely in favour of an option for this
open-the-tabs-that-were-previously-open-when-closing behaviour.

Re comment #9:
NetCaptor also supports this (I mostly use this and Mozilla), and it's quite
nice behaviour (e.g. I find that Win2K starts to get very flaky after 30-40 days
without a reboot, so with this I can just exit, reboot, and then resume from
where I left off). NetCaptor and CrazyBrowser avoid the whole "what to do in the
event of multiple windows" problem by only having one main window (with multiple
tabs), which is preferable IMHO.

Comment 11

15 years ago
Re: comment 10

> NetCaptor and CrazyBrowser avoid the whole "what to do in the
> event of multiple windows" problem by only having one main window (with multiple
> tabs), which is preferable IMHO.

Personally, I think that a strength of Mozilla tabs is that they can work with
multiple windows.  I can have a set of tabs open in one window concerning a
particular topic, and another window with tabs for a seperate topic.

On that note, parhaps saving all tabs _and windows_ could be an option...
Of course, that would be inconsistant with 'last page visited' behavior.

my $0.02

Comment 12

15 years ago
IMHO, I believe that this bug should be kept consistent with the other options
in Preferences -> Navigator, and that it should only refer to the window that
was active at the time that Mozilla was closed.

Another bug for reinstating the entire browser state (all windows and tabs)
could be another option - ( ) Previous windows and tabs - but should be in a
different bug.  (Particularly since the reporter has said that he wasn't
referring to that behaviour when he opened this one.)

Comment 13

15 years ago
*** Bug 150551 has been marked as a duplicate of this bug. ***

Comment 14

15 years ago
There's an XUL app, Tabbrowser Extensions, that slays a variety of tabby bugs
'n' RFEs - including this, bug 103843, bug 105547 and bug 105885.

From the Features page:

Navigator loads tabs all of last visited [ pages ], when you set the startup
page to "last visited".

http://www.cc-net.or.jp/~piro/xul/_tabextensions.en.html


.
Assignee: Matti → blaker
Status: REOPENED → NEW
QA Contact: asa → claudius

Comment 16

15 years ago
Thinking about this some more, is there any reason to not simply morph the
existing "Last page visited" into "Last page(s) visited"?  Do we really need two
separate prefs for this?

Comment 17

15 years ago
> Thinking about this some more, is there any reason to not simply morph 
> the existing "Last page visited" into "Last page(s) visited"?  Do we 
> really need two separate prefs for this?

That seems like a good idea to me.

It's also what the Tabbrowser Extensions add-on mentioned above does, and apart
from a very minor quibble due to the label being "Last page visited" when it
actually does "Last page(s) visited", it makes sense and works well and avoids
introducing another option (by making the existing option more general).

Comment 18

15 years ago
Multizilla have this (open last visited tabs) feature too

Comment 19

15 years ago
*** Bug 191115 has been marked as a duplicate of this bug. ***

Comment 20

14 years ago
*** Bug 196343 has been marked as a duplicate of this bug. ***

Comment 21

14 years ago
*** Bug 208551 has been marked as a duplicate of this bug. ***

Comment 22

14 years ago
I see a number of issues with trying to implement this:
1) How to store what is in each tab - would have to change how things are stored
for last page visited (uses mork I think)
2) Whether to implement as an extra radio button on display prefs or as a check
box on the tabbed browsing tab

One work around is just to set a home page group and use that for those people
that need to open a group of tabs at the same time.
*** Bug 211832 has been marked as a duplicate of this bug. ***

Comment 24

14 years ago
I have not seen so I will mention:
- Opera does it
- Galeon does it

If Moz had this I would change it to my default browser.  Already use Moz as 
defalut mail.
*** Bug 223015 has been marked as a duplicate of this bug. ***

Comment 26

14 years ago
 Under galeon and Opera, when you are surfing webs in different tabs and you
close the browser, when you reopen it all the tabs are reopened and loaded like
the moment you closed it. Currently mozilla does load a single tab with the last
web you were browsing, but you lose all other tabs.

 Under konqueror you can save current tabs as a "session" and then load it from
command line with "konqueror --load-profile NAME". This way you can have a
session named "weblogs" openning automatically "slashdot, linuxnews, linuxtoday,
and so", and other session save to open easily for favourite newspapers, as an
example.

 The first one (saving the state each time you close the browser) I think it's
the minimum that mozilla should implement. The second feature (saving sessions)
is more advanced, and is an step further than the first one.

 I would be happy just if mozilla would save all the tabs I was browsing when I
close it (and reopen when launching mozilla another day).

 Thanks a lot and sorry for my poor english.


Comment 27

14 years ago
> The second feature (saving sessions) is more advanced, and is an step
> further than the first one.

Your second feature has been available for quite some time now.  It's called
"tab groups"...

Comment 28

14 years ago
*** Bug 226983 has been marked as a duplicate of this bug. ***

Comment 29

13 years ago
*** Bug 247771 has been marked as a duplicate of this bug. ***
I would change the summary of this bog to something like this:

'Option for automatically remember last tab session'

I think that people usually searches for 'tab session' when looking for this.

Comment 31

13 years ago
Adapted summary following above suggestion. Please refine it if needed.
Summary: Add "Last tabs visited" to Navigator startup preferences. → Add "Last tabs visited" to Navigator startup preferences / save tab session when closing, quitting.
*** Bug 269944 has been marked as a duplicate of this bug. ***
*** Bug 272120 has been marked as a duplicate of this bug. ***
Depends on: 36810

Comment 34

13 years ago
But of course!
That's what I thought as soon as I saw it.
Look at: 63094

(In reply to comment #3)
> Something tells me that this is a duplicate.  However, I can't find it.
> 

Comment 35

13 years ago
That bug looks like it does a lot more than this one.  Adding the dependency.
Blocks: 63094

Comment 36

13 years ago
Ben wants to do session saving for fx2...He probably has a bug on this already,
but booting this over to him.
Assignee: firefox → bugs

Comment 37

13 years ago
*** Bug 174932 has been marked as a duplicate of this bug. ***
*** Bug 260088 has been marked as a duplicate of this bug. ***
*** Bug 278705 has been marked as a duplicate of this bug. ***

Comment 40

13 years ago
*** Bug 279721 has been marked as a duplicate of this bug. ***

Comment 41

13 years ago
Don't think too hard people. For starters - implement single window mode (bug
279726). Then add "last session (available in single window mode only)" as one
of the homepage options. Make it greyed out if single window mode is off.

Would be much better than nothing.

Comment 42

13 years ago
*** Bug 279857 has been marked as a duplicate of this bug. ***

Comment 43

12 years ago
*** Bug 283810 has been marked as a duplicate of this bug. ***

Updated

12 years ago
No longer blocks: 63094
*** Bug 285060 has been marked as a duplicate of this bug. ***

Comment 45

12 years ago
*** Bug 291269 has been marked as a duplicate of this bug. ***

Comment 46

12 years ago
*** Bug 292081 has been marked as a duplicate of this bug. ***

Comment 47

12 years ago
[just inserting from my duplicate bug. by the way i searched for words "tab,
restore, session" in various combinations, and obviously failed. the insert
contains some additional thought.]

The best example is probably Opera: if I open anything new, it saves a temporary
session file, so if I exit the program or it crashes (oh, I know, firefox never
does ;->) restarting it resumes *everything* there was before, including all
opened windows and tabs. This is currently the main reason I use Opera, because
I love to keep 100+ tabs open and get them reopened the next morning without
manual intervention. 

(Btw Opera does cache these pages, so startup actually doesn't refresh them
immediately but gets the cached content if possible, they solved this way the
problem of slow startup and high CPU load at start.)
*** Bug 295108 has been marked as a duplicate of this bug. ***

Comment 49

12 years ago
*** Bug 296549 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Alias: sessionsaver

Comment 50

12 years ago
Just some comments: there is a save tabs extension (can't recall the name) which
theoretically perfect but useless in reality. What it does is almost reaches the
perfection of Opera: tries to save tabs and their history every time a tab is
changed. In this case not even a crash can lose them. (Apart from the problem
that if there's a tab which crashes FF/Moz then it has to be manually removed;
this has to be kept in mind when implementing.)

It is useless probably because it's written in javascript [and possibly not very
efficient] and it is **SLOW** like a dead snail. I had to remove it because
every URL change required 5-10 seconds wait... 

If anyone plans such a thing please open 150 tabs first (see Bug 155325), and
test it that way. Under Opera the delay is not observable, so FF/Moz can do it
too. ;)

Comment 51

12 years ago
(In reply to comment #50)
> Just some comments: there is a save tabs extension (can't recall the name) 

...

Session Saver is one. There is another, which is an offshoot, which is for
crashes only, I think.

Comment 52

12 years ago
(In reply to comment #50)
> Just some comments: there is a save tabs extension (can't recall the name) 

...

Session Saver is one. There is another, which is an offshoot, which is for
crashes only, I think.

Comment 53

12 years ago
Yes, there is another one:
Crash Recovery:
http://forums.mozillazine.org/viewtopic.php?t=164513

Comment 54

12 years ago
Yes, there is another one:
Crash Recovery:
http://forums.mozillazine.org/viewtopic.php?t=164513

Comment 55

12 years ago
*** Bug 307637 has been marked as a duplicate of this bug. ***

Comment 56

12 years ago
*** Bug 295988 has been marked as a duplicate of this bug. ***
*** Bug 308720 has been marked as a duplicate of this bug. ***

Comment 58

12 years ago
Oops, I put in a bug that was a duplicate of this, but I want to add the idea
that something like this would be handy for when you install a new extension
that you want to be active, but you don't want to lose your current setup.. 

Some sort of "restart firefox and have it show up exactly like it is now" would
be nice.  I put more detail into but 308720.

Thanks :)

Comment 59

12 years ago
*** Bug 308833 has been marked as a duplicate of this bug. ***
*** Bug 310261 has been marked as a duplicate of this bug. ***

Comment 61

12 years ago
Very needed function that should be a part of Firefox rather than an extension.

Comment 62

12 years ago
*** Bug 318912 has been marked as a duplicate of this bug. ***
*** Bug 322494 has been marked as a duplicate of this bug. ***

Comment 64

12 years ago
I vote for making saving tab sessions (with crash recovery) a core
Mozilla feature.  Yes, there is the SessionSaver Firefox extension.
Unfortunately, SessionSaver is buggy (as just one example in a long
history, currently I can not install other Firefox extensions without
disabling SessionSaver first and restarting Firefox), the user
interface is highly confusing (as just one example out of many, the
preferences window's title appears to be in braille!), the
documentation is mostly non-existent, and the version numbering is
cryptic.  Although SessionSaver's maintainer is eager and seems to
work **** it, the task probably requires the involvement of
additional people who are more oriented toward quality assurance and
human interfaces rather than just being pure coders.
Blocks: 310261
No longer blocks: 310261

Comment 65

11 years ago
The CrashRecovery Firefox extension has been incorporated into Firefox 2.  (It works for me with 2.0 beta 1.)

http://sessionmanager.mozdev.org/crashrecovery/

Comment 66

11 years ago
I actually "End Process" on Firefox so that I can save the session for later.  If we add the feature to save the session and close...it sure sounds like the next logical step.

Comment 67

11 years ago
You can simply set an about:config pref: http://kb.mozillazine.org/Browser.sessionstore.resume_session to true in b1, http://kb.mozillazine.org/Browser.startup.page to 3 starting with some nightly post-b1.

Bug 342701 is about adding UI for enabling the feature.

Comment 68

11 years ago
The above still has no applicability to SeaMonkey that I'm aware of.

Comment 69

11 years ago
Yes, however as it is likely that the sessionstore-like component for seamonkey will be implemented at application level (this is how Firefox sessionstore works), I believe this bug should be either closed or moved to a seamonkey-specific component.

Comment 70

11 years ago
This bug was created before Firefox even existed.  The abstract even refers to "Navigator".  As such, it should already be SeaMonkey specific. However, I'll grant that the Product / Component might need to be changed.
Component: History: Global → General
Product: Core → Mozilla Application Suite

Updated

11 years ago
Assignee: bugs → general
QA Contact: claudius → general

Comment 71

11 years ago
(In reply to comment #67)
> You can simply set an about:config pref:
> http://kb.mozillazine.org/Browser.sessionstore.resume_session to true in b1,
> http://kb.mozillazine.org/Browser.startup.page to 3 starting with some nightly
> post-b1.
> 
> Bug 342701 is about adding UI for enabling the feature.
> 


Right, but I don't want it to do it after every close.  That is why a UI feature is so crucial.  The only way to do it for only one session, on demand, would require a "save session and close" option in the File menu.

Comment 72

11 years ago
(In reply to comment #71)
> (In reply to comment #67)
> > You can simply set an about:config pref:
> > http://kb.mozillazine.org/Browser.sessionstore.resume_session to true in b1,
> > http://kb.mozillazine.org/Browser.startup.page to 3 starting with some nightly
> > post-b1.
> > 
> > Bug 342701 is about adding UI for enabling the feature.
> > 
> 
> 
> Right, but I don't want it to do it after every close.  That is why a UI
> feature is so crucial.  The only way to do it for only one session, on demand,
> would require a "save session and close" option in the File menu.
> 

Yep, which is why I am STILL in the wrong bug.  Sorry for the bug spam.

Comment 73

11 years ago
(In reply to comment #66)
> I actually "End Process" on Firefox so that I can save the session for later. 
> If we add the feature to save the session and close...it sure sounds like the
> next logical step.

Ditto. I sometimes do this before shutting down for the day. There's gotta be a better way.

Comment 74

11 years ago
Sorry, just noticed the other comments and change away from "Core".
*** Bug 215026 has been marked as a duplicate of this bug. ***

Comment 76

10 years ago
Just wondering if the status on this will be changing now that "suiterunner" is out.

Comment 77

8 years ago
Sessionstore is implemented now. VERIFY planed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.