[meta] implement Session Restore (restore user's session on app launch)

RESOLVED FIXED in Firefox 2 beta1

Status

()

enhancement
RESOLVED FIXED
13 years ago
8 days ago

People

(Reporter: dietrich, Assigned: dietrich)

Tracking

({meta})

2.0 Branch
Firefox 2 beta1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: 181b1+)

(Assignee)

Updated

13 years ago
Depends on: 328159
(Assignee)

Updated

13 years ago
Depends on: 328162
(Assignee)

Updated

13 years ago
Depends on: 328163
Assignee: nobody → dietrich
Status: NEW → ASSIGNED
Flags: blocking-firefox2+

Updated

13 years ago
Depends on: 333907
*** Bug 334702 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

13 years ago
Depends on: 334839
Adding bug 332774 (session data API for extensions) to list of dependencies.
Depends on: 332774
(Assignee)

Comment 3

13 years ago
Added dependency on 336758 because the crash-restoration feature can't get turned on by default until it jives with the automated testing.
Depends on: 336758
(Assignee)

Updated

13 years ago
Depends on: 336902
Target Milestone: Firefox 2 alpha2 → Firefox 2 beta1
Bug 339804 is about a problem with proxy auth with session store enabled, maybe some dev can look into this.
Depends on: 339804

Updated

13 years ago
No longer blocks: 335864
Depends on: 335864

Updated

13 years ago
Keywords: meta
Summary: Restore User's Session on App Launch → implement Session Restore (restore user's session on app launch)

Updated

13 years ago
Depends on: 337320

Updated

13 years ago
Whiteboard: 181b1+
I'm going to mark this fixed.  Remaining issues will be addressed in followup bugs.

Thanks Dietrich!
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Dietrich, please nominate any of the dependency bugs that require blocking status for blocking-firefox2; we're not accepting meta-bugs as blockers.
Flags: blocking-firefox2+
Duplicate of this bug: 375311

Updated

10 years ago
Duplicate of this bug: 158258
Summary: implement Session Restore (restore user's session on app launch) → [meta] implement Session Restore (restore user's session on app launch)
You need to log in before you can comment on or make changes to this bug.