Closed Bug 343053 Opened 16 years ago Closed 15 years ago

Lightning win32 trunk build not compatible with official Thunderbird trunk build

Categories

(Calendar :: Lightning Only, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: bhalter, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

When I add a new WebDav calendar to lightning build 2006062808 with Thunderbird version 3 alpha 1 (20060627) I get to the final screen where it asks for a name for the calendar and cannot finish

Reproducible: Always

Steps to Reproduce:
1.Create a new calendar in Lightning 
2.Select Remote -> Next
3.Select WebDav with URL of http://mail.armyofpenguins.com:8080/Calendar/bhalter.ics
4.Assign the calendar a name and a color.  I used bhalter as the name
5.Click next

Actual Results:  
Step 5 above does nothing 

Expected Results:  
Should finish the wizard and add the new calendar
Version: unspecified → Trunk
Are there any errors in the javascript console (under tools) after this fails?
Yes.  When I start adding a new calendar 

Error: uncaught exception: [Exception... "Invalid ClassID or ContractID"  nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)"  location: "JS frame :: chrome://calendar/content/calendarUtils.js :: <TOP_LEVEL> :: line 89"  data: no]

is reported.  Then clicking on "Next" at the end throws these errors:

Error: [Exception... "Invalid ClassID or ContractID"  nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/bhalter/Application%20Data/Thunderbird/Profiles/cgom2ehg.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js :: initBaseComponent :: line 64"  data: no]
Source File: file:///C:/Documents%20and%20Settings/bhalter/Application%20Data/Thunderbird/Profiles/cgom2ehg.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js
Line: 64

Error: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://calendar/content/calendarUtils.js :: getCalendarManager :: line 46"  data: no]
Source File: chrome://calendar/content/calendarUtils.js
Line: 46
To be sure: Do you installed the correct version of Lightning? For Thunderbird 3.0a1 download Lightning trunk build from http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-trunk/
1)
Confirmed with official Tb 3.0a1 (2006062813) and Lt 0.1+ (2006062820-trunk)

2) 
It works with the Thunderbird build that is next to the Lightning xpi file.

3) 
The error messages look like Bug 330753, but our Lightning tinderbox uses --disable-static. The official Thunderbird tinderbox uses --enable-static. But in both build logs you will find "-DMOZ_STATIC_MAIL_BUILD=1" - does that mean --disable-static is not working? And we have a static Lightning build?

4)
Official Thunderbird tinderbox still builds with VC98 while our Lightning tinderbox builds with VC2005 now. Maybe we have a kind of binary incompatibility as known from linux builds?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Bryan, can you retest please? Using official Thunderbird 0.3a1 (20060705) and Lightning 0.1+ (20060705) on Windows 2000 this works for me now.
(In reply to comment #6)
> Bryan, can you retest please? Using official Thunderbird 0.3a1 (20060705) and
> Lightning 0.1+ (20060705) on Windows 2000 this works for me now.

Weird: Using the same builds on Windows XP I still see the errors. Updating summary as this seems to be a more general problem.
Summary: Cannot add new webdav calendar → Lightning win32 trunk build not compatible with official Thunderbird trunk build
*** Bug 343691 has been marked as a duplicate of this bug. ***
I see this bug and Bugzilla Bug 344105
Lightning don't work in Thunderbird 1.5.0.x anymore for the 1.5.0.x branch, but is there a third bug for the 2.0 branch?

(Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060709 Thunderbird/2.0a1 ID:2006070905)
(In reply to comment #9)
During my testing for Bug 344105 I saw no problems with Thunderbird 2.0a1.
Does it fail or work for you with Thunderbird 2.0a1?
After some more investigation I'm sure this is caused by the different build environments. Official Thunderbird win32 trunk tinderbox (patrocles) still builds with VC6 (VS98) while our Lightning tinderbox builds with VC8 (VS2005). Depends on Bug 323931.

Workaround for Lightning testers: Use the Thunderbird build from http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-trunk/ instead of the official one.
Depends on: 323931
Is there a bug to make Lightining a default part of the trunk Thunderbird build? This would avoid all the mismatching between versions. If this is going to compete with Outlook (and you can't deny that is the intent), then that should be happening as soon as possible. Matching up nightly builds on branch might be a different story (for now), but in the trunk, it should be fully integrated by now, eliminating this bug.
(In reply to comment #12)
> Is there a bug to make Lightining a default part of the trunk Thunderbird
> build? This would avoid all the mismatching between versions. 
This is a decision for the Thunderbird team to make, once Lightning is more mature and not until then.

> If this is going
> to compete with Outlook (and you can't deny that is the intent), 
I can and I will.

> then that
> should be happening as soon as possible. Matching up nightly builds on branch
> might be a different story (for now), but in the trunk, it should be fully
> integrated by now, eliminating this bug.
No. It's not ready yet. 

*** Bug 347526 has been marked as a duplicate of this bug. ***
(In reply to comment #13)
> (In reply to comment #12)
> > Is there a bug to make Lightining a default part of the trunk Thunderbird
> > build? This would avoid all the mismatching between versions. 
> This is a decision for the Thunderbird team to make, once Lightning is more
> mature and not until then.

I have recorded Bugzilla Bug 349870
build/run/integrate Lightning on top of Thunderbird to mark this.


> > If this is going
> > to compete with Outlook (and you can't deny that is the intent), 
> I can and I will.

Just that most everybody else in the world will.


> 
> > then that
> > should be happening as soon as possible. Matching up nightly builds on branch
> > might be a different story (for now), but in the trunk, it should be fully
> > integrated by now, eliminating this bug.
> No. It's not ready yet. 

OK, waiting.
Depends on: 349870
*** Bug 353556 has been marked as a duplicate of this bug. ***
Depends on: 324440
Is there a bug similar to this for the 2.0 Thunderbird branch? 
(In reply to comment #17)
> Is there a bug similar to this for the 2.0 Thunderbird branch? 

No. Lightning 0.3 should work fine with nightly builds of Thunderbird 2.0b1pre. If it stopped working please file a new bug and define the regression range if possible.
Build server for win32 Thunderbird trunk build was upgraded last week to use new compiler version. I retested and this is now WORKSFORME using Thunderbird/3.0a1 (20061107) with Lightning/0.4a1 (2006110707-trunk) on Windows XP system.

Reporter, could you retest on your system too?
(In reply to comment #19)
> Build server for win32 Thunderbird trunk build was upgraded last week to use
> new compiler version. I retested and this is now WORKSFORME using
> Thunderbird/3.0a1 (20061107) with Lightning/0.4a1 (2006110707-trunk) on Windows
> XP system.
> 
> Reporter, could you retest on your system too?
> 

I now have the same bug as FF, crash at startup on msvcr80.dll.  

No solution on FF since July ;-(

(In reply to comment #20)
> (In reply to comment #19)
> > Build server for win32 Thunderbird trunk build was upgraded last week to use
> > new compiler version. I retested and this is now WORKSFORME using
> > Thunderbird/3.0a1 (20061107) with Lightning/0.4a1 (2006110707-trunk) on Windows
> > XP system.
> > 
> > Reporter, could you retest on your system too?
> > 
> 
> I now have the same bug as FF, crash at startup on msvcr80.dll.  
> 
> No solution on FF since July ;-(
> 

oups, made a mistake (wrong bug).  Forget my comment !
I DID have a similar problem previously.  But just checked with latest trunk nightly for Thunderbird (3a1 (20061110)) on Win XP and it works for me now.
(In reply to comment #19) (In reply to comment #22)
-> WORKSFORME.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
It seems that nightly builds are out of sync again. Reopen?
(In reply to comment #24)
> It seems that nightly builds are out of sync again. Reopen?

Please check your Lightning version first: http://forums.mozillazine.org/viewtopic.php?t=513308

If there is still a problem I suggest to file a new bug describing your issue. 'Out of sync' is bit vague.
(In reply to comment #25)
> (In reply to comment #24)
> > It seems that nightly builds are out of sync again. Reopen?
> 
> Please check your Lightning version first:
> http://forums.mozillazine.org/viewtopic.php?t=513308
> 
> If there is still a problem I suggest to file a new bug describing your issue.
> 'Out of sync' is bit vague.

Those look like builds for installation in trunk or 1.5.x branch versions of Thunderbird, correct? I am running 2.0 nightly Thunderbird builds.

(In reply to comment #26)
If you are running Thunderbird 1.5 or pre-release 2.0, you can use the Lightning 0.3.1pre nightly builds.

If you are running Thunderbird pre-release 3.0, you can use the Lightning 0.6a1 (a.k.a. trunk) builds.

Since you're running Tb 2.0, you're not running trunk, which is what this bug was about.  If you have trouble running 0.3.1pre with Tb 2.0, please open another bug with all the details.  This bug should stay closed.
(In reply to comment #27)
> (In reply to comment #26)
> If you are running Thunderbird 1.5 or pre-release 2.0, you can use the
> Lightning 0.3.1pre nightly builds.
> 
> If you are running Thunderbird pre-release 3.0, you can use the Lightning 0.6a1
> (a.k.a. trunk) builds.
> 
> Since you're running Tb 2.0, you're not running trunk, which is what this bug
> was about.  If you have trouble running 0.3.1pre with Tb 2.0, please open
> another bug with all the details.  This bug should stay closed.
> 
Tried this, and it loses all my data. Fortunately, I kept the old .xpi file and it is still working.
What happened to the download "matrix" showing which builds went with which builds? Thanks.
(In reply to comment #29)

Please post support questions in either the calendar support newsgroup or the calendar forum.
Is this different from the current issues of Lighting not working in "Trunk" builds?
Yes. Starting with Thunderbird 61 extension like Lightning are no longer working. See Bug 1449487. I have no idea why you think that this bug from 2006 is related to current problems.
You need to log in before you can comment on or make changes to this bug.