Closed Bug 199877 Opened 17 years ago Closed 7 years ago

ability to set icon for a specific bookmark in properties

Categories

(Firefox :: Bookmarks & History, enhancement)

enhancement
Not set

Tracking

()

RESOLVED WONTFIX
Future

People

(Reporter: warenhaus, Unassigned)

References

Details

(Whiteboard: parity-ie)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030320 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030320 Phoenix/0.5

all kinds of bookmarks (bookmarklets, bookmark folders,...) should be given the
possibility to have a custom icon. it is now limited to "normal" bookmarks.
there is a userChrome.css workaround described in bug 72374
http://bugzilla.mozilla.org/show_bug.cgi?id=72374#c6
that can be used if one specifies the css-id for every single case.

i guess that in bookmarks.html the introduction of ICON=... for non-html
bookmarks would suffice.

Reproducible: Always

Steps to Reproduce:
1.have a bookmarklet in your pers.toolbar or bookmarks
2.right-click, properties
3.

Actual Results:  
there is no "extra" tab

Expected Results:  
the possibility to set an icon for everything that fits under bookmarks
Confirming for developer review.

Pierre?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: all kinds of bookmarks should have the "Extra"-tab in the properties (to set an icon) → ability to set icon for a specific bookmark in properties
This is the same as bug 121348, "[RFE] Custom Web-Site Icons for Bookmarks".
Blocks: 109669
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor
*** Bug 242289 has been marked as a duplicate of this bug. ***
Whiteboard: parity-ie
The properties windows allows you to change "name", "location" "keyword" and
description.
We just have to add a "icon URL" zone in this window. So one can erase the icon
URL, modify the icon URL or add an icon URL.
This UI change can be done without too much pain.

PS: the icon should be DISPLAYED also in the property window !!
*** Bug 248780 has been marked as a duplicate of this bug. ***
actually, the dialog box sems to work as of this date, using the "browse" button
to locate the custom icon - but firefox does NOT change the icon (it does
display in the dialog window, though); evidently, the dialog box isn't actually
telling firefox where that custom icon is..... 
*** Bug 268628 has been marked as a duplicate of this bug. ***
*** Bug 297132 has been marked as a duplicate of this bug. ***
I filed bug 310123 yesterday not detecting it was duplicate of this bug when
doing search yesterday - apologies for that.

I notice in the comments here that Rastignac suggests a dialog box to contain
icon related widgets for user modification. I think this approach should
universally work for both bookmarks and folders alike. In fact, a Favicon Picker
extension already exists to handle bookmarks. My filing of bug 310123 was to
extend the icon support to include folders. Having a JS call similar to
updateBookmarkIcon to support folders would suffice for us extension authors.
Later versions don't seem to have ANY way to change the icons in the bookmarks,
although it does seem to be doing better at finding the favicon.ico of the page
that gets bookmarked.  Problem is when the web page doesn't have a facicon.ico
to save.  How about putting the function back that allows you to change the .ico
that gets associated with the bookmark?  And making sure it works correctly, of
course... <G>

Tom
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
See also bug 264241, which is specifically about assigning icons to *folders* of bookmarks.
Assignee: p_ch → nobody
Component: Bookmarks & History → Places
QA Contact: bookmarks → places
Target Milestone: --- → Future
This doesn't sound like a candidate for a core feature, but we should also make sure it's possible for an add-on to be able to do this.
Whiteboard: parity-ie → parity-ie wontfix?
Duplicate of this bug: 326896
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
Add-ons can to this already and it's not really a core feature, a few users may find it neat, but most users won't really care to specify special icons for each bookmark.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
Whiteboard: parity-ie wontfix? → parity-ie
Duplicate of this bug: 1097678
You need to log in before you can comment on or make changes to this bug.