quick searching for sender in "sent mail" and drafts folder actually searches for recipient

RESOLVED FIXED

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: Marian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Version 1.5 (20051201)

I would like to search all mails in my local "sent mail" folder for mails which I have sent with a certain sender address, say me@account1domain.com.

When using the search bar in the folder view, I select "Sender" and enter the above address.

Instead of searching the "From" field (sender) of the mails, obviously the "To" field (recipient) is searched.

Although this is minor, there seems to be no workaround for me.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5

Comment 1

12 years ago
See bug 259914 comment 14
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

12 years ago
also affects drafts folder - tested with trunk build.
workaround is use "search messages".
Severity: minor → normal
Summary: Searching for sender in "sent mail" folder actually searches for recipient → Searching for sender in "sent mail" and drafts folder actually searches for recipient
Version: 1.5 → Trunk

Comment 3

11 years ago
*** Bug 341233 has been marked as a duplicate of this bug. ***

Comment 4

11 years ago
I have this problem as well - given the presence of the "To or cc" field it is unneccessary.
I also have some folders that have "become" sent folders for a reason I cannot ascertain and don't know how to switch them back, which makes this more annoying :-)
Should this be marked as a duplicate or dependency of 259914?

Updated

11 years ago
Depends on: 259914
OS: Windows XP → All
Hardware: PC → All
Summary: Searching for sender in "sent mail" and drafts folder actually searches for recipient → quick searching for sender in "sent mail" and drafts folder actually searches for recipient

Comment 5

11 years ago
well, this is intentional - does using the advanced search window work?

Comment 6

11 years ago
(In reply to comment #5)
> well, this is intentional - does using the advanced search window work?

This behavior was a regression.  Prior to bug 256545's fix, there was only one field searched -- it searched 'From' except in Sent and Drafts folders, where it was 'To', and the field read 'Sender' or 'Recipient' depending on which folder you were in.  After that bug's fix, you could pick which fields to search, and the selector only displayed 'Sender' -- but there was no 'To' field.  But the *behavior* was the same -- when it read Sender, it would still search Recipient in a Sent folder.  (Bug 259914 was originally about this inconsistency.)

Sometime in mid-2005 another bug was fixed to add a To or CC field.  At that point, if you view a Sent folder, whether you picked Sender or To or CC, you could only search the recipient.  Given that multiple identities can share a Sent (or Drafts) folder, being able to search on Sender is not a whimsical idea.  That is the regression that spawned this bug.


I like the idea that the Quicksearch field is smart enough to know the context and understand that, for most cases, if the selected criterion is Sender for an Inbox, then it should logically switch to Recipient in the Drafts/Sent.  But the field's criterion text should be updated accordingly (bug 259914) *and* the "To or CC" should change to "From" in the same context (this bug).

Alternately, remove the smart context switching, and search on the fields that are actually shown as the criteria.


Yes, Advanced Search works, but it doesn't support the smart context switching either (no reason to).

Comment 7

11 years ago
> Given that multiple identities can share a Sent (or Drafts) folder,
> being able to search on Sender is not a whimsical idea

Here is how I ended up in this situation:

I have set up Thunderbird to act like Gmail - I have a single 'archive' folder that I use as my sent items, and once I have read and dealt with an email I move it from my inbox to my archive folder.

I sort the archive by conversation, and I can see all mails for a particular threadm both mails that I have sent and received.
QA Contact: front-end

Comment 8

11 years ago
A possible workaround: create a new Search virtual folder with Edit->Find->Search Messages and search your Sent folder (or global Archive folder if you use that) with a criteria so that every message will match (eg. Sender does not contain "@@@@@@@@@@@@@@"). Then, you are able to use the search bar in this new virtual folder.

Maybe another workaround would be creating a filter that moves your sent messages from your Sent folder to another one which can be searched normally.

However I find this bug very annoying.

Updated

10 years ago
Assignee: mscott → nobody

Comment 9

9 years ago
is this same as bug 387505? or dependent.
also bug 299109 presents same for sent mails stored in inbox.

Comment 10

9 years ago
and I see that in 2.0.0.16 and 3.0a2 (2008072418)

Comment 11

9 years ago
This is fixed as part of the patch that fixed bug #259914. Could somebody please close it?

Updated

9 years ago
Duplicate of this bug: 387505

Comment 13

9 years ago
Yep, this is no longer a problem.  (Trunk builds only, of course, until TB 3 is release.)

Bug 299109 is somewhat different, and IMO would be a misfeature to implement.

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.