user-defined keyboard shortcuts not always recognized (new shortcut for Tools:Downloads/Cmd+J works only after menu is selected. if menu is closed, Cmd+J still invokes Tools:Downloads)

RESOLVED DUPLICATE of bug 429824

Status

()

Firefox
Shell Integration
--
minor
RESOLVED DUPLICATE of bug 429824
12 years ago
a year ago

People

(Reporter: Jon Willeke, Unassigned)

Tracking

unspecified
All
Mac OS X
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3.6 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/417.9 (KHTML, like Gecko) Safari/417.8
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

On OS X, there is a system-wide facility for defining keyboard shortcuts (System Preferences > Keyboard & Mouse > Keyboard Shortcuts).  A shortcut so defined appears next to the menu item.  Firefox does not reliably recognize them.

Reproducible: Sometimes

Steps to Reproduce:
1. Redefine the shortcut for, say, Tools > Downloads from Cmd-J to, say, Cmd-Shift-7.
2. Restart Firefox.
3. Use the new shortcut.

Actual Results:  
Nothing happens.

Expected Results:  
The Downloads window should open.

If I use the default shortcut, the Downloads window opens.  This could be bad if the user remaps that shortcut to something else, although I haven't tested this.  If I select the menu item, the user-defined shortcut works thereafter.

Comment 1

12 years ago
I opened "System Preferences > Keyboard & Mouse > Keyboard Shortcuts" and didn't see anything for changing Firefox's shortcuts.  I only saw things for changing system-wide shortcuts such as "show all windows".

I'm using Firefox trunk on Mac OS X 10.4.5.
(Reporter)

Comment 2

12 years ago
Firefox does not define any shortcuts in the System Preferences.  You can define your own with the "+" button.

Comment 3

11 years ago
duplicate of bug 316459.

Comment 4

10 years ago
FF 3.02 out, very disappointing to see this issue not corrected.

Issue is Custom keyboard shortcuts in MAC OSX 10.5.x DO NOT WORK when set in system preferance keybaord settings.

I'm trying to assign a shortcut for "Home" (from the history menu)
It simply will not work.  Worked fine in FireFox 2.0  Never worked for me with Firefox 3

Please correct this issue.
- James

Comment 5

9 years ago
This is completely reproducible.

I'm a Windows user so I'm used to using Control+X or C or V for cut, copy and paste.

So in system prefs I have gone into Keyboard & Mouse, Keyboard Shortcuts and under the Application Keyboard Shortcuts/ All Applications section I have added entries for cut, copy and paste mapping those commands to Ctrl+X, Ctrl+C and Ctrl+V respectfully. Every mac application I have honors these new shortcuts except for Firefox. Firefox DOES show the new shortcuts in the Edit pull-down menu but they do not work, I have to use the default Mac key combos.

Updated

9 years ago
Flags: blocking-firefox3.6?
Confirming bug.
This doesn't block the release of Firefox 3.6.
--> Shell Integration
--> All/OSX
Status: UNCONFIRMED → NEW
Component: Keyboard Navigation → Shell Integration
Ever confirmed: true
Flags: blocking-firefox3.6? → blocking-firefox3.6-
QA Contact: keyboard.navigation → shell.integration
Hardware: PowerPC → All
Pretty sure this is a dupe of bug 429824
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429824
(In reply to rahul abrol from comment #3)
> duplicate of bug 316459.

This bug is Cmd-J version of bug 316459, or Cmd-J version of Bug 938303(and bug 457973, bug 515395, bug 624881, bug 646362).
Even if same mechanism, change in diferent part of source code is needed for resolving problem. So it's not dup.

Reopening, with setting dependency to Bug 938303 for ease of analysis and tracking.

(In reply to Jeff from comment #5)
> I'm a Windows user so I'm used to using Control+X or C or V for cut, copy and paste.

Control+X or C or V case is different, even if similar mechanism is reli\evant, because action by Control+X or C or V may depend on context(even though <key> is defined, command is not directly defined by <key>).
See bugs relevant to Control+X or C or V which were cloased as dup of bug 429824.
Status: RESOLVED → REOPENED
Depends on: 938303
Resolution: DUPLICATE → ---
Depends on: 316459
Definition of Tools:Downloads/Cmd+J
> Where string of "Tools:Downloads" is used.
>   http://mxr.mozilla.org/mozilla-central/search?string=Tools%3ADownloads
> Key binding for key_openDownloads
>   http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser-sets.inc#273
> key value for key_openDownloads
>   http://mxr.mozilla.org/mozilla-central/source/browser/locales/en-US/chrome/browser/browser.dtd#207
> menuitem for minimizeWindow, zoomWindow
>  http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser-menubar.inc#461

Same solution as bug 938303 is possible in Tools:Downloads/Cmd+J case : remove command from <key>.
Summary: user-defined keyboard shortcuts not always recognized → user-defined keyboard shortcuts not always recognized (new shortcut for Tools:Downloads/Cmd+J works only when menu is opened. if menu is closed, Cmd+J still invokes Tools:Downloads)
Summary: user-defined keyboard shortcuts not always recognized (new shortcut for Tools:Downloads/Cmd+J works only when menu is opened. if menu is closed, Cmd+J still invokes Tools:Downloads) → user-defined keyboard shortcuts not always recognized (new shortcut for Tools:Downloads/Cmd+J works only after menu is selected. if menu is closed, Cmd+J still invokes Tools:Downloads)
No longer depends on: 938303
Depends on: 827652
Status: REOPENED → RESOLVED
Last Resolved: 8 years agoa year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429824
You need to log in before you can comment on or make changes to this bug.