Closed Bug 329687 Opened 14 years ago Closed 11 years ago

Remove Ctrl+Q keyboard shortcut on Windows for File > Exit / Quit application (like Firefox)

Categories

(Thunderbird :: Mail Window Front End, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b1

People

(Reporter: benson, Assigned: philor)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Bugzilla 52821 discusses the fate of Control-Q in Firefox. While that bug is still 'new', firefox 1.5.0.1 does not quit on control Q, so I have to think that the patch actually went into force back in 2004 when it was last posted.

Thunderbird, on the other hand, is still infested with this creature.

I have several justifications for asking for its removal:

1) It is not reflected in the File pulldown as an accelerator for Exit, and is thus a surprise.
2) As documented in the above bug, lots of other commonly-used applications have control-Q for something harmless, and so many of us type it at Mozilla and then curse when our window disappears.
3) In Outlook, from which many of us come, control-Q is specifically the 'mark message read' accelerator. So many of us have fingers trained to hit it, and life gets frustrating in a hurry.


Reproducible: Always

Steps to Reproduce:
1. enter control-q by mistake
2.
3.

Actual Results:  
curse an evil fate

Expected Results:  
nothing
(In reply to comment #0)
> While that bug is
> still 'new', firefox 1.5.0.1 does not quit on control Q, so I have to think
> that the patch actually went into force back in 2004 when it was last posted.

The patches there are for the suite; and the only semi-reviewed patch simply changes the shortcut to Shift+Ctrl+Q.
Severity: normal → enhancement
OS: Windows XP → All
Hardware: PC → All
Summary: The control-q-for-quit accelerator is very frustrating → Remove control-q-for-quit accelerator (like Firefox)
Version: unspecified → Trunk
QA Contact: front-end
Assignee: mscott → nobody
!?!? "Infested with this creature" ?!?! I'd say "blessed with this feature". I wonder why this so-called RFE isn't already long WONTFIXed.

SeaMonkey, Sunbird, ksysguard, kedit, Konqueror and Kmail (among others) all use Ctrl+Q to quit the application, which explains that I'm not convinced by the argument about "lots of commonly-used applications" in comment #0. In fact, all GUI applications I've checked use Ctrl+Q to quit, except Firefox and konsole (with no keyboard shortcut AFAICT) and gvim (with :qa<Enter>).
If we keep it, 1) is just a bug to be fixed.

On the Mac, at least, most (all?) apps uses command-q to quit.  I don't recall noticing this last time I lived on Windows, but it's been a while.  If you felt like listing some of these commonly-used applications, that would be helpful.

3), however, is fairly compelling, since lots of our users on Windows are likely to have Outlook experience.  What does Outlook Express do?

I'd be interested in hearing clarkbw's thoughts here, so I've added him to the CC...
Outlook Express and Windows Mail both do the same, ctrl+q == mark as read.

The only thing I found in a fairly quick look that does something else harmless with it was Wyndfields, a rather ancient shareware database, which does quicksearch.

The aliens Safari for Windows and OpenOffice, and the not-so-alien but prone to annoying behavior Adobe Reader all quit on ctrl+q, none of the other two dozen Windows programs I tried do anything.
I think on Windows you can't use ctrl-q for quit.  In Firefox it has been removed and I'm forced to find the File -> Exit item.  But on other systems like the mac and linux ctrl-q / cmd-q has been the default for a while.

So I'd support the removal on Windows as that's more likely to have people using ctrl-q for actions other than quit.  However I can't see removing cmd-q/ctrl-q on the other systems.
Restricting Hardware/OS to PC/Windows according to comment #5 (and comment #4). If, on Windows, Ctrl-Q-to-quit is the exception rather than the rule, then we can remove that shortcut on that platform, and keep it where (according to comment #2 [Linux] and comment #3 [Mac]) it's the norm.
OS: All → Windows XP
Hardware: All → PC
Attached patch Fix v.1Splinter Review
I always feel a little dirty using XP_UNIX to mean XP_UNIX_AND_MACOSX, but it's already impossible to survive if you don't know that's true, so I guess it doesn't matter.
Assignee: nobody → philringnalda
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #343755 - Flags: review?(mkmelin+mozilla)
Attachment #343755 - Flags: review?(mkmelin+mozilla) → review+
http://hg.mozilla.org/comm-central/rev/093ef818b7b6
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Thunderbird 3.0b1
OS: All → Windows XP
Hardware: All → PC
If I read the patch correctly, Ctrl+Q has been removed for Windows only -> adjusting summary. So we still have:
Linux: Ctrl+Q
MAC OS: Command+Q
Confirmation would be appreciated.
Summary: Remove control-q-for-quit accelerator (like Firefox) → Remove Ctrl+Q keyboard shortcut on Windows for File > Exit / Quit application (like Firefox)
That's correct.
Depends on: 716101
More than 3yrs after implementation, this has also found its way into the main keyboard shortcuts documentation, major revision 5614 which I landed today:

https://support.mozillamessaging.com/en-US/kb/keyboard-shortcuts/revision/5614
You need to log in before you can comment on or make changes to this bug.