Last Comment Bug 335113 - More obvious secure site indication for SeaMonkey - yellow URL bar
: More obvious secure site indication for SeaMonkey - yellow URL bar
Status: RESOLVED FIXED
Mac classic fixed for seamonkey1.1.1 ...
: fixed-seamonkey1.1.1, fixed-seamonkey1.1a, relnote
Product: SeaMonkey
Classification: Client Software
Component: UI Design (show other bugs)
: unspecified
: All All
: -- enhancement (vote)
: ---
Assigned To: ui-design
:
Mentors:
https://bugzilla.mozilla.org/
Depends on: 367672
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-22 14:42 PDT by zug_treno
Modified: 2008-07-31 04:23 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Diff made with Patch Maker and SeaMonkey 1.5a/20060422 (1.60 KB, patch)
2006-04-22 15:07 PDT, zug_treno
db48x: review-
Details | Diff | Review
Second diff made with Patch Maker and SeaMonkey 1.5a/20060525 (2.10 KB, patch)
2006-05-26 09:08 PDT, zug_treno
db48x: review+
neil: superreview-
Details | Diff | Review
Third diff made with Patch Maker and SeaMonkey 1.5a/20060602 (2.44 KB, patch)
2006-06-03 07:41 PDT, zug_treno
no flags Details | Diff | Review
Modern screenshot (1.62 KB, image/gif)
2006-06-03 14:04 PDT, neil@parkwaycc.co.uk
no flags Details
Screenshot showing a transparent dropmarker (1.52 KB, image/gif)
2006-06-04 04:34 PDT, zug_treno
no flags Details
Modified ubhist-arrow.gif (85 bytes, image/gif)
2006-06-04 04:39 PDT, zug_treno
no flags Details
Modified ubhist-arrow-act.gif (85 bytes, image/gif)
2006-06-04 04:40 PDT, zug_treno
no flags Details
Fourth diff made with Patch Maker and SeaMonkey 1.5a/20060603 (1.78 KB, patch)
2006-06-04 09:48 PDT, zug_treno
neil: superreview-
Details | Diff | Review
Screenshot with yellow background and transparent dropmarker (Modern) (1.94 KB, image/gif)
2006-06-04 09:56 PDT, zug_treno
no flags Details
Edited 4th diff (1.77 KB, patch)
2006-06-05 10:26 PDT, zug_treno
no flags Details | Diff | Review
Fifth diff made with Patch Maker and SeaMonkey 1.5a/20060615 (1.87 KB, patch)
2006-06-17 08:25 PDT, zug_treno
jag-mozilla: review+
neil: superreview+
csthomas: approval‑seamonkey1.1a+
Details | Diff | Review
Screenshot of URL bar with (7.40 KB, image/gif)
2007-01-21 07:22 PST, Stefan [:stefanh]
no flags Details
Override style rule in navigator.css (1000 bytes, patch)
2007-01-21 10:35 PST, Stefan [:stefanh]
neil: review+
neil: superreview+
kairo: approval‑seamonkey1.1.1+
Details | Diff | Review
RE:color change for HTTPS sites in URL bar (148.00 KB, application/octet-stream)
2007-01-21 22:16 PST, Dr. Richard Close
no flags Details

Description zug_treno 2006-04-22 14:42:59 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060404 SeaMonkey/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060404 SeaMonkey/1.0.1

Firefox sets the background of the URL/location bar to yellow when you visit a secure/https site (see Firefox bug 244025). This might be nice for SeaMonkey as well.

Reproducible: Always

Steps to Reproduce:
1.Go to a secure site.
2.Look at the URL bar.
Actual Results:  
The background of the URL bar is still white.

Expected Results:  
The background of the URL bar changes to yellow.
Comment 1 zug_treno 2006-04-22 15:07:24 PDT
Created attachment 219460 [details] [diff] [review]
Diff made with Patch Maker and SeaMonkey 1.5a/20060422

This is a 'Copy and Paste'-patch made from the patches in Firefox bug 244025 and Firefox bug 249680. I just copied the relevant URL bar parts of these patches, I didn't change the statusbar/lock icon code. This patch seems to work with both Classic and Modern.
Comment 2 Daniel Brooks [:db48x] 2006-05-25 01:14:11 PDT
Comment on attachment 219460 [details] [diff] [review]
Diff made with Patch Maker and SeaMonkey 1.5a/20060422

move the css rule into the themes
Comment 3 zug_treno 2006-05-26 09:08:43 PDT
Created attachment 223445 [details] [diff] [review]
Second diff made with Patch Maker and SeaMonkey 1.5a/20060525

Improved patch, I moved the css rule into the Classic and Modern navigator.css files.
Comment 4 Daniel Brooks [:db48x] 2006-05-26 10:06:51 PDT
Comment on attachment 223445 [details] [diff] [review]
Second diff made with Patch Maker and SeaMonkey 1.5a/20060525

looks good. r=db48x
Comment 5 neil@parkwaycc.co.uk 2006-05-27 06:40:49 PDT
Comment on attachment 223445 [details] [diff] [review]
Second diff made with Patch Maker and SeaMonkey 1.5a/20060525

>--- classic\skin\classic\navigator\navigator.css.bak	2005-05-01 02:48:34.000000000 +0200
>+++ classic\skin\classic\navigator\navigator.css	2006-05-26 16:38:55.562500000 +0200
>@@ -195,6 +195,13 @@
>   -moz-border-left-colors: transparent ThreeDShadow ThreeDDarkShadow;
> }
> 
>+#urlbar[level="high"] > .autocomplete-textbox-container,
>+#urlbar[level="low"] > .autocomplete-textbox-container,
>+#urlbar[level="broken"] > .autocomplete-textbox-container {
>+  background-color: #F5F6BE; /* #F7F898; */
>+  color: #000000;
>+}
The Classic theme should use system colours where available.
I suggest the tooltip colours would be a reasonable choice.

>+#urlbar[level="high"] > .autocomplete-textbox-container,
>+#urlbar[level="low"] > .autocomplete-textbox-container,
>+#urlbar[level="broken"] > .autocomplete-textbox-container {
>+  background-color: #F5F6BE; /* #F7F898; */
>+  color: #000000;
>+}
The Modern urlbar is styled differently. In particular the dropmarker is partially transparent, so its background needs to change too. However you should not need to change the text colour. I am also not convinced of the choice of colour; by comparison the locked icon uses the colour #E8DB99.
Comment 6 zug_treno 2006-06-03 07:41:45 PDT
Created attachment 224311 [details] [diff] [review]
Third diff made with Patch Maker and SeaMonkey 1.5a/20060602

I changed the Classic colors to InfoBackground and InfoText. The Modern background-color is now #E8DB99, as is the dropmarker background.
Comment 7 Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2006-06-03 09:15:51 PDT
(In reply to comment #5)
> The Classic theme should use system colours where available.
> I suggest the tooltip colours would be a reasonable choice.

I'd suggest tooltip color or a firefox (winstripe) color.

> The Modern urlbar is styled differently. In particular the dropmarker is
> partially transparent, so its background needs to change too. However you
> should not need to change the text colour. I am also not convinced of the
> choice of colour; by comparison the locked icon uses the colour #E8DB99.

That's an ugly color on its own, bug #E8DB99 does seem like it would fit well in Modern.
Comment 8 neil@parkwaycc.co.uk 2006-06-03 14:04:38 PDT
Created attachment 224323 [details]
Modern screenshot

Classic looks fine, but Modern still looks wrong.

Note: you should be able to use #urlbar[level]
Comment 9 zug_treno 2006-06-04 04:34:27 PDT
Created attachment 224346 [details]
Screenshot showing a transparent dropmarker

Screenshot with the white parts of ubhist-arrow.gif/ubhist-arrow-act.gif made transparent, would this be better?
Comment 10 zug_treno 2006-06-04 04:39:10 PDT
Created attachment 224347 [details]
Modified ubhist-arrow.gif
Comment 11 zug_treno 2006-06-04 04:40:23 PDT
Created attachment 224348 [details]
Modified ubhist-arrow-act.gif
Comment 12 neil@parkwaycc.co.uk 2006-06-04 05:41:58 PDT
Sorry for being unclear, I should have said when attaching the screenshot that I was referring to the background which still shows as a strange-looking border.
Comment 13 zug_treno 2006-06-04 09:48:00 PDT
Created attachment 224362 [details] [diff] [review]
Fourth diff made with Patch Maker and SeaMonkey 1.5a/20060603

New patch using #urlbar[level] in both Classic and Modern, no more white background/border visible in Modern.
Comment 14 zug_treno 2006-06-04 09:56:09 PDT
Created attachment 224363 [details]
Screenshot with yellow background and transparent dropmarker (Modern)
Comment 15 jag (Peter Annema) 2006-06-04 20:52:54 PDT
Ok, maybe I'm missing something, but why are we displaying the yellow (secure) background colour for level=broken? I admit that the red from lock-broken.gif is perhaps a bit ugly to put up there, but could we then just leave it white instead?
Comment 16 neil@parkwaycc.co.uk 2006-06-05 03:10:56 PDT
Comment on attachment 224362 [details] [diff] [review]
Fourth diff made with Patch Maker and SeaMonkey 1.5a/20060603

OK, after some consideration, I agree with jag here, so we'll need to specify the two "good" levels. Sorry for messing you around like that.

(In reply to comment #15)
>why are we displaying the yellow (secure) background colour for level=broken?
To clarify, "broken" means mixed content (typically advert from insecure site, but also unfortunately for remote XUL on secure websites).
Comment 17 zug_treno 2006-06-05 10:26:20 PDT
Created attachment 224448 [details] [diff] [review]
Edited 4th diff

(In reply to comment #15)
> I admit that the red from lock-broken.gif
> is perhaps a bit ugly to put up there, but could we then just leave it white
> instead?

Just changing 'this.urlBar.setAttribute("level", "broken");' to 'this.urlBar.removeAttribute("level");' in nsBrowserStatusHandler.js gives me a broken lock icon and a white URL bar background.

(In reply to comment #16)
> OK, after some consideration, I agree with jag here, so we'll need to specify
> the two "good" levels.

Any suggestions for the Classic and Modern colors?
Comment 18 neil@parkwaycc.co.uk 2006-06-15 14:37:11 PDT
(In reply to comment #17)
>(In reply to comment #16)
>>OK, after some consideration, I agree with jag here, so we'll need to specify
>>the two "good" levels.
>Any suggestions for the Classic and Modern colors?
You misunderstood me (don't worry, you're not the first to do that).
I meant that the URLbar should not change for mixed content.

Note: the mixed content notification happens after a secure content notification, so that the URLbar will briefly flash...

Comment 19 neil@parkwaycc.co.uk 2006-06-15 14:38:45 PDT
Comment on attachment 224448 [details] [diff] [review]
Edited 4th diff

The question is, should we still add the broken attribute to the URLbar so that other themes have the chance to use their own styling?
Comment 20 zug_treno 2006-06-17 08:25:46 PDT
Created attachment 225990 [details] [diff] [review]
Fifth diff made with Patch Maker and SeaMonkey 1.5a/20060615

With this patch the URL bar background changes back to white on a broken/mixed page and I readded the 'broken' attribute for other themes to use.
Comment 21 neil@parkwaycc.co.uk 2006-06-23 08:57:14 PDT
Comment on attachment 225990 [details] [diff] [review]
Fifth diff made with Patch Maker and SeaMonkey 1.5a/20060615

Sorry for the delay, I was overwhelmed with work this week.
Comment 22 zug_treno 2006-06-28 06:56:29 PDT
Daniel, Neil and Peter thanks for the (super)reviews. Is this patch ready for checkin now, and if so who could do that?
Comment 23 neil@parkwaycc.co.uk 2006-07-02 09:19:31 PDT
Fix checked in on the trunk.
Comment 24 Stephen Donner [:stephend] - PTO; back on 5/28 2006-07-02 15:49:31 PDT
Verified FIXED using both Classic and Modern skins on SeaMonkey trunk build 2006-07-02-09, Windows XP.
Comment 25 Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2006-07-09 09:30:22 PDT
Checked in on mozilla_1_8_branch
Comment 26 Kelly Kane 2007-01-18 19:00:35 PST
Any chance of having a global "Appearance" override preference for this? One that disables the theme css change all together, either in about:config or Preferences->Appearance->Colors?
Comment 27 ChrisX 2007-01-19 06:23:26 PST
SeaMonkey 1.1 final is supposed to have this according to the release notes. I still only see the closed lock at the bottom, no color change in the address bar.  Mac OS X 10.3.9, Classic Theme.
Comment 28 Stefan [:stefanh] 2007-01-19 09:22:41 PST
(In reply to comment #27)
> SeaMonkey 1.1 final is supposed to have this according to the release notes. I
> still only see the closed lock at the bottom, no color change in the address
> bar.  Mac OS X 10.3.9, Classic Theme.
> 

Hmm, I guess I thought this was a windows-only fix. But now I see that the OS field is "All".

+  background-color: InfoBackground;

I don't think "InfoBackground" is useful on mac for this purpose, it seems to return white... In the bugs mentioned in comment #1 you'll notice that Pinstripe is treated differently, like this:

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/browser/themes/pinstripe/browser&command=DIFF_FRAMESET&file=browser.css&rev1=1.3&rev2=1.4&root=/cvsroot

You'll probably need to hard-code the bgcolor for everyone if you can't put the style rules for mac in a mac-only file.

It should probably be mentioned in the release notes that it only works for win/nix(?).
Comment 29 Stefan [:stefanh] 2007-01-19 12:56:21 PST
Just to clarify:

It works in Modern on mac, but not with Classic.
Comment 30 ChrisX 2007-01-19 18:04:06 PST
Thanks for clarifying. Confirmed working in Modern.
Comment 31 Stefan [:stefanh] 2007-01-20 05:43:34 PST
Neil, are you OK with a hard-coded background-color in navigator.css? Or shall we override the style rules in navigator.css from some mac platform-specific file in Classic?

In the long term, the native theme code should of course be corrected. But I don't see any other short-term option than hard-coding the background-color somewhere in the theme files since InfoBackground is used in Pinstripe elsewhere (and I can imagine that they don't want the color change).

Fwiw, the mac tooltip bgcolor that you get with "-moz-appearance: tooltip;" on trunk is #FFFFC7 (hardcoded in nsNativeThemeCocoa).

(In reply to comment #26)
> Any chance of having a global "Appearance" override preference for this? One
> that disables the theme css change all together, either in about:config or
> Preferences->Appearance->Colors?

You should be able to override the "secure" background-color with your own preferred color by adding those lines to your userChrome.css file:

#urlbar[level="high"] > .autocomplete-textbox-container,
#urlbar[level="low"] > .autocomplete-textbox-container {
  background-color: yourColor !important;

Comment 32 neil@parkwaycc.co.uk 2007-01-20 16:13:21 PST
(In reply to comment #31)
>Neil, are you OK with a hard-coded background-color in navigator.css?
No, but then I didn't know that Mac gets this badly wrong again (is there really no system colour set on the Mac?)

>Or shall we override the style rules in navigator.css from some mac
>platform-specific file in Classic?
I guess that's the best we can do on the branch.

>In the long term, the native theme code should of course be corrected.
I'll let you file the appropriate bug :-)

>Fwiw, the mac tooltip bgcolor that you get with "-moz-appearance: tooltip;" on
>trunk is #FFFFC7 (hardcoded in nsNativeThemeCocoa).
Is #FFFFC7 noticeably yellow? I don't think we can use -moz-appearance in this case, as it overrides the CSS padding.

>(In reply to comment #26)
>>Any chance of having a global "Appearance" override preference for this? One
>>that disables the theme css change all together, either in about:config or
>>Preferences->Appearance->Colors?
>You should be able to override the "secure" background-color with your own
>preferred color by adding those lines to your userChrome.css file:
You should also be able to override the colour used by tooltips (and thus the "secure" background) be setting the ui.infobackground preference.
Comment 33 Stefan [:stefanh] 2007-01-21 07:22:51 PST
Created attachment 252215 [details]
Screenshot of URL bar with 

> Is #FFFFC7 noticeably yellow? I don't think we can use -moz-appearance in this
> case, as it overrides the CSS padding.

If you want to use the tooltip background to indicate a secure url that is the color we'll get for mac once the native theme code is fixed ;-)
Comment 34 neil@parkwaycc.co.uk 2007-01-21 07:30:01 PST
Comment on attachment 252215 [details]
Screenshot of URL bar with 

That's nice! I'd actually overlooked that Windows defaults to the paler #FFFFE1.
Comment 35 Stefan [:stefanh] 2007-01-21 08:28:47 PST
I can only think of two files in classic/global/mac where one could put the style rule: autocomplete.css or textbox.css. It feels a bit awkward, though. You know that I want a mac navigator.css file ;-) (at least on trunk, please)

Anyway, which one do you prefer?



Comment 36 neil@parkwaycc.co.uk 2007-01-21 09:49:26 PST
autocomplete.css is slightly less inaccurate.
Comment 37 Kelly Kane 2007-01-21 09:51:57 PST
(In reply to comment #32)
> >(In reply to comment #26)
> >>Any chance of having a global "Appearance" override preference for this? One
> >>that disables the theme css change all together, either in about:config or
> >>Preferences->Appearance->Colors?
> >You should be able to override the "secure" background-color with your own
> >preferred color by adding those lines to your userChrome.css file:
> You should also be able to override the colour used by tooltips (and thus the
> "secure" background) be setting the ui.infobackground preference.

Thank you for the tips. I have already overridden it in my userChrome.css file with some help from nice people in #seamonkey.

I was thinking something a little less hackish, something that I can tell my friends? Also, I would prefer if there were a way to keep yellow-background tooltips but not have the color-changing urlbar. Perhaps an tickbox in Appearance or Security? (Ticked by default) Or something in about:config.
Comment 38 Stefan [:stefanh] 2007-01-21 10:35:53 PST
Created attachment 252227 [details] [diff] [review]
Override style rule in navigator.css
Comment 39 neil@parkwaycc.co.uk 2007-01-21 11:21:05 PST
Comment on attachment 252227 [details] [diff] [review]
Override style rule in navigator.css

Not that I can actually test this, you understand ;-)
Comment 40 Stefan [:stefanh] 2007-01-21 11:36:58 PST
Comment on attachment 252227 [details] [diff] [review]
Override style rule in navigator.css

This will make the "secure"  url bgcolor work on mac classic.
Comment 41 Robert Kaiser (not working on stability any more) 2007-01-21 13:20:19 PST
Comment on attachment 252227 [details] [diff] [review]
Override style rule in navigator.css

first-a=me for 1.1.1, one still needed to go
Comment 42 Dr. Richard Close 2007-01-21 22:16:27 PST
Created attachment 252290 [details]
RE:color change for HTTPS sites in URL bar

no change in color on an https system on my copy of 1.1

Thanks
Richard
Comment 43 Karsten Düsterloh 2007-01-21 22:47:48 PST
Comment on attachment 252290 [details]
RE:color change for HTTPS sites in URL bar

It is not appropriate to attach (Windows) binaries of unknown origin. If you have trouble with a specific build, just name its location on an official Mozilla server.
It is also not appropriate to flag such binaries as reviewed, which only gives the impression that some scam is attempted (I didn't test this binary, though)...
Comment 44 Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2007-01-23 19:19:30 PST
Comment on attachment 252227 [details] [diff] [review]
Override style rule in navigator.css

first-a=me.  Get a second approval.
Comment 45 Stefan [:stefanh] 2007-01-23 23:08:34 PST
(In reply to comment #44)
> (From update of attachment 252227 [details] [diff] [review])
> first-a=me.  Get a second approval.

Your approval is the second one. See comment #41 ;-)
Comment 46 Karsten Düsterloh 2007-01-27 07:32:37 PST
Comment on attachment 252227 [details] [diff] [review]
Override style rule in navigator.css

Landed on MOZILLA_1_8_BRANCH.
Comment 47 Stefan [:stefanh] 2007-01-27 07:40:16 PST
This is now fixed for Mac classic in 1.1.1 and trunk (bug 367672 fixed it on trunk).

Note You need to log in before you can comment on or make changes to this bug.