Last Comment Bug 335755 - Extension XUL overlay errors should not create a gray bar
: Extension XUL overlay errors should not create a gray bar
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: All All
: -- enhancement with 1 vote (vote)
: ---
Assigned To: Neil Deakin
:
: Neil Deakin
Mentors:
: 318588 356792 356841 357508 362691 386863 389576 398034 401683 418637 (view as bug list)
Depends on: 342063
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-27 16:30 PDT by Jesse Ruderman
Modified: 2009-03-24 08:09 PDT (History)
23 users (show)
jaymoz: wanted1.8.1.x+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Don't output error message for overlays that don't parse properly (5.80 KB, patch)
2006-05-05 09:15 PDT, Neil Deakin
jonas: review+
Details | Diff | Splinter Review
Address comments (6.36 KB, patch)
2006-05-05 15:20 PDT, Neil Deakin
jst: superreview+
bryner: approval‑branch‑1.8.1-
Details | Diff | Splinter Review
screenshot from Mac (29.46 KB, image/png)
2006-07-30 23:44 PDT, Alex Vincent [:WeirdAl]
no flags Details

Description User image Jesse Ruderman 2006-04-27 16:30:38 PDT
There have been at least 50 bug reports in Bugzilla about a gray bar appearing below the status bar due to broken extensions.  (I counted INVA bugs where http://kb.mozillazine.org/Gray_bar_below_status_bar was mentioned, bug 314768 and its dups, and bug 308742 and its dups).

The gray bar is an unnecessary persistent annoyance.  It should be replaced by a clear error message (in a dialog) or quiet failure (just show a message in the JavaScript Console).  The message should state which overlay is broken/missing and which extension is responsible.
Comment 1 User image Neil Deakin 2006-05-05 09:15:02 PDT
Created attachment 220937 [details] [diff] [review]
Don't output error message for overlays that don't parse properly

This patch disables printing out the error message for non-well-formed overlays. The "xul-overlay-parsererror" notification can be used by some future extension manager change to disable the corresponding extension.
Comment 2 User image Jonas Sicking (:sicking) No longer reading bugmail consistently 2006-05-05 14:00:16 PDT
Comment on attachment 220937 [details] [diff] [review]
Don't output error message for overlays that don't parse properly

Please make OnDocumentParserError return the reporterror bool rather than an nsresult.

And send a notification to the js-console as well.

with that, r=sicking
Comment 3 User image Neil Deakin 2006-05-05 15:20:54 PDT
Created attachment 220993 [details] [diff] [review]
Address comments
Comment 4 User image Johnny Stenback (:jst, jst@mozilla.com) 2006-06-05 18:34:10 PDT
Comment on attachment 220993 [details] [diff] [review]
Address comments

sr=jst
Comment 5 User image Boris Zbarsky [:bz] (still a bit busy) 2006-06-08 07:40:43 PDT
So shouldn't we report the error to the console even if OnDocumentParserError() returns true?
Comment 6 User image Neil Deakin 2006-06-08 08:12:15 PDT
(In reply to comment #5)
> So shouldn't we report the error to the console even if OnDocumentParserError()
> returns true?
> 

We could do that yes. That would cause all XUL parse errors, overlay or otherwise to be reported.
Comment 7 User image Boris Zbarsky [:bz] (still a bit busy) 2006-06-08 08:15:46 PDT
That's what we should do, imo, unless there's a really good reason not to.
Comment 8 User image Jason Barnabe (np) 2006-06-08 13:03:41 PDT
Comment on attachment 220993 [details] [diff] [review]
Address comments

Requesting approval‑branch‑1.8.1. This comes up often in the support forums and the problem occurs more often with major releases (with new versions of extensions coming out).
Comment 9 User image Brian Ryner (not reading) 2006-06-10 12:58:09 PDT
Comment on attachment 220993 [details] [diff] [review]
Address comments

This can't land on the branch as-is because it changes nsIXULDocument.
Comment 10 User image Boris Zbarsky [:bz] (still a bit busy) 2006-06-19 14:24:08 PDT
Wait.  Doesn't this double-report the well-formedness errors, since nsExpatDriver reports errors itself too?
Comment 11 User image Boris Zbarsky [:bz] (still a bit busy) 2006-06-19 14:33:46 PDT
Filed bug 342063 on the double-reporting issue.
Comment 12 User image Phil Ringnalda (:philor) 2006-07-05 00:25:31 PDT
*** Bug 318588 has been marked as a duplicate of this bug. ***
Comment 13 User image Alex Vincent [:WeirdAl] 2006-07-30 23:44:54 PDT
Created attachment 231368 [details]
screenshot from Mac

bz: This is a screenshot of the error console on 1.8 branch, with two error messages.  As I understand this bug from comment 0, you want me to prevent the second error message from appearing.  That's what my patch does.  Did I misinterpret this bug?  Do I need to change the code on 1.8 branch somewhere else?
Comment 14 User image Alex Vincent [:WeirdAl] 2006-07-30 23:46:01 PDT
ignore comment 13, I meant to attach to bug 342063 (sorry!)
Comment 15 User image William Bumgarner [:zsinj] 2006-10-16 20:13:12 PDT
*** Bug 356792 has been marked as a duplicate of this bug. ***
Comment 16 User image William Bumgarner [:zsinj] 2006-10-18 08:53:29 PDT
*** Bug 356841 has been marked as a duplicate of this bug. ***
Comment 17 User image Ria Klaassen (not reading all bugmail) 2006-10-21 14:14:10 PDT
*** Bug 357508 has been marked as a duplicate of this bug. ***
Comment 18 User image Jesse Ruderman 2006-12-03 20:33:06 PST
*** Bug 362691 has been marked as a duplicate of this bug. ***
Comment 19 User image Jay Patel [:jay] 2007-01-03 15:21:56 PST
Rather than fix individual bugs like bug 364460, we would rather take a patch for this bug on the 1.8 branch.

Neil:  Could you look into updating the patch for the 1.8 branch?
Comment 20 User image Jesse Ruderman 2007-07-05 02:32:18 PDT
*** Bug 386863 has been marked as a duplicate of this bug. ***
Comment 21 User image Jesse Ruderman 2007-07-25 17:00:50 PDT
*** Bug 389576 has been marked as a duplicate of this bug. ***
Comment 22 User image Jesse Ruderman 2007-09-29 18:33:14 PDT
*** Bug 398034 has been marked as a duplicate of this bug. ***
Comment 23 User image Jesse Ruderman 2007-10-30 10:40:56 PDT
*** Bug 401683 has been marked as a duplicate of this bug. ***
Comment 24 User image Jonathan Haas 2007-12-08 01:38:09 PST
Are you planning and is it possible to add an error dialog to inform the average user that one of his extensions is not working properly?
Comment 25 User image Nickolay_Ponomarev 2007-12-10 07:00:21 PST
Possible, yes. The question is better suited for a newsgroup or a separate bug.
Comment 26 User image Jesse Ruderman 2008-02-20 13:13:14 PST
*** Bug 418637 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.