Closed Bug 336488 Opened 14 years ago Closed 14 years ago

Search Bookmarks Broken

Categories

(Firefox :: Bookmarks & History, defect, major)

2.0 Branch
defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 2 beta1

People

(Reporter: steventheconqueror, Assigned: moco)

References

Details

(Keywords: regression, verified1.8.1, Whiteboard: [SWAG: fixed, just waiting for verification])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20060503 BonEcho/2.0a1
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20060503 BonEcho/2.0a1

Ever since Places was disabled on branch, searching bookmarks hasn't worked. Searching from the bookmarks sidebar and bookmarks manager both don't work. I compiled a new build right before submitting this bug and it is still present, even with a new profile.

Reproducible: Always

Steps to Reproduce:
1. Open bookmarks sidebar or bookmarks manager
2. Search for a known bookmark

Actual Results:  
Should find the bookmark

Expected Results:  
doesn't find bookmark
OS: Linux → All
Version: unspecified → 2.0 Branch
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060503 BonEcho/2.0a1
Yes, I see the same.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox2?
Keywords: regression
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060503 BonEcho/2.0a1 ID:2006050304

Same here.
Severity: normal → major
Steven, are you sure this was caused by Bug 336488 (Disable Places on 1.8.1 branch) ?
Are you sure this regressed between the 20060428 and 20060429 ?
Peter, no I'm not sure the exact date it regressed. In fact, I had been having trouble with places so I had made a build with --disable-places a week before it was officially turned off and it had this same problem. So it definitely didn't occur during the dates you mentioned but happened sometime before that. (btw, the bug you linked to is the same bug we're on)
Yeah, that should have been bug 335377

Hmm, so this regressed between Places enabled and Places disabled
mid march - 20060429
would the checkin for bug 325257 have anything to do with it?

that checkin also broke FireFTP.
I confirm this on Mac with BonEcho alpha 2; architecture can probably be changed to "All."
Hardware: PC → All
Target Milestone: --- → Firefox 2 beta1
Is this subject to the same "...due to underlying issues on certain
filesystems, until we ship Places,..." issue as in Bugzilla Bug 249150
Bookmarks file is overwritten (deleted) randomly in Firefox versions without places?

https://bugzilla.mozilla.org/show_bug.cgi?id=249150#c92
Bug still existing since April 29th.
http://forums.mozillazine.org/viewtopic.php?p=2235226#2235226

Should be corrected for any official release.
while working on #315690, I saw this regression.
Flags: blocking-firefox2? → blocking-firefox2+
taking, as I would really need this fixed before I can verify that a fix for #315690 did not regress bug #255255
Assignee: nobody → sspitzer
Blocks: 315690
Attachment #223342 - Flags: superreview?(mconnor)
Attachment #223342 - Flags: review?(gavin.sharp)
Comment on attachment 223342 [details] [diff] [review]
removing part of the fix from bug #317107 which caused this regression

Wow, sucks that Firefox bookmarks search depends on code in xpfe/components/search. Clearly I was wrong in bug 317107 :(.  I'd be kind of nice to remove that dependency (so that bug 332021 could be fixed on the branch), but I have a strong feeling that that would require a non-trivial amount of work.

r=me if it fixes the bustage, but I'm really not familiar with any of this code, and I don't know who is. Maybe vlad?
Attachment #223342 - Flags: review?(gavin.sharp) → review+
> Wow, sucks that Firefox bookmarks search depends on code in xpfe/components/search.

Based on ben's comments, when places is re-enabled, it should not depend on it.  

But I'm not sure, so that is just my un-educated guess.
Status: NEW → ASSIGNED
when debugging to figure out what was going on, I was unable to set a breakpoint in nsLocalSearchService.cpp, which led me to look rdf:localsearch was missing.

doing a cvs blame on mozilla/browser/components/bookmarks/content/bookmarksTree.xml led me to bug 317107: new search service.

note, mozilla/xpfe/components/bookmarks/resources/bookmarksTree.xml does not have this issue, as it still has rdf:localsearch
Whiteboard: [fix in hand, awaiting sr]
Comment on attachment 223342 [details] [diff] [review]
removing part of the fix from bug #317107 which caused this regression

robert strong tells me for mozilla/browser I only need one review (thanks gavin) and then a= for the 1.8.1 branch
Attachment #223342 - Flags: superreview?(mconnor) → approval-branch-1.8.1?(mconnor)
Whiteboard: [fix in hand, awaiting sr] → [fix in hand, awaiting 1.8.1 approval]
Comment on attachment 223342 [details] [diff] [review]
removing part of the fix from bug #317107 which caused this regression

gah, so evil.

a=me for branch after we reopen it
Attachment #223342 - Flags: approval-branch-1.8.1?(mconnor) → approval-branch-1.8.1+
I can confirm the fixes this bug. Since branch is closed, if anyone else wants the fix on their browser just modify BookmarksTree.xml inside browser.jar with the changes in the patch. Thanks Seth Spitzer. :)
the branch is open again, because alpha 3 is out.
so is this being checked in?
landed on 1.8.1 branch
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Whiteboard: [fix in hand, awaiting 1.8.1 approval]
*** Bug 339903 has been marked as a duplicate of this bug. ***
*** Bug 339984 has been marked as a duplicate of this bug. ***
Whiteboard: [SWAG: fixed, just waiting for verification]
fyi, in order to keep trunk in sync with the 1.8 branch, I've landed this change on the trunk as well.
Verified with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1b2) Gecko/20060822 BonEcho/2.0b2
Status: RESOLVED → VERIFIED
verified 1.8.1 per comment 24
You need to log in before you can comment on or make changes to this bug.