Pulldown list does not go away on mousewheel action

VERIFIED FIXED in mozilla0.9

Status

()

Core
HTML: Form Submission
P3
normal
VERIFIED FIXED
18 years ago
16 years ago

People

(Reporter: Ted Ashton, Assigned: Brian Ryner (not reading))

Tracking

({helpwanted})

Trunk
mozilla0.9
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-] [nsbeta3-] [rtm-] developer nominating no beta2, URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; N; WinNT4.0; en-US; m14)
BuildID:    2000032808

If I pulldown a selection list and then, while it is pulled down scroll using my
Genius Netmouse (non-gfx-scrollbars, so netmouse will work), the page scrolls
but over top of it, the pulled down menu floats.

Reproducible: Always
Steps to Reproduce:
1.  Go to the listed URL :-) and pull down, for instance, the menu which selects
the type of search next to the Summary box.
2.  While it is down, scroll the page using the mousewheel



Actual Results:  The box with the options remains floating over the scrolling
page and is still active (i.e., I can select an option from it)	

Expected Results:  Either the option list would go away upon scrolling or else
the list would scroll with the page.

This is almost definitely related to bug 22794

Comment 1

18 years ago
mass-move to M16
Target Milestone: --- → M16

Comment 2

18 years ago
non-essential for m16
Target Milestone: M16 → M17

Comment 3

18 years ago
nominating for nsbeta2 based on:
 - visibility
 - feature broken
Keywords: nsbeta2

Comment 4

18 years ago
Can PDT get a retest here please. Also do not think that we are supporting 
navtive scrollbars. Are we?
Whiteboard: [NEED INFO]
(Reporter)

Comment 5

18 years ago
Still broken.  I checked Opera, IE and Navigator and in those three, clicking
down a pull-down picklist makes the mousewheel affect the pull-down list instead
of the entire window.  As to whether you are supporting native scrollbars or
not, I couldn't say, but the gfx scrollbars don't work with teh Genius Netmouse
and it's pretty frustrating to have Mozilla require a different method of scrolling.

Comment 6

18 years ago
This is a hard issue to solve and it won't get fixed for beta2, plus I don't 
want to spend a lot of time on it with native scrollbars in the dropdown when we 
will be turning on Gfx scrollbars for the dropdown (hopefully) early in M17.
Status: NEW → ASSIGNED
(Reporter)

Comment 7

18 years ago
In that case, I'd advise marking it as dependant on bug 22794.  I currently
have to use native scrollbars if I want to use my netmouse "wheel" at all.

Updated

18 years ago
Whiteboard: [NEED INFO] → This isn't going to make it for beta2

Comment 8

18 years ago
Here is what is going on. Go to nsWindow.cpp on Windows and search for the 
string "33733" Turn on the ifdef. Now what happens is, when you dropdown the 
combobox and the mouse is over the dropdown the MouseWheel scrolls the dropdown. 
When the mouse is over the content window or even more importanly when it is 
over the combobox control (not the dropdown) in the content window the Window 
scrolls.

When a MouseWheel event comes into the event state manager it needs to find out 
what piece of content has focus, then it needs to find out what frame is hit, 
and it needs to find out if the frame is a Rollup listener.

It is is a Rollup listener then the following should happen:
If the frame for the focused content and the frame that the mouse is currently 
over do not match, then ask the Rollup listener to Rollup. If they do match then 
the ESM needs to ask the Rollup listener for a frame in which to send the 
MouseWheel event to.

Summary:
When the dropdown is down (it is implied that the combobox has focus) any event 
in the content page when the mouse is over the combobox proper should go to the 
dropdown. When the mouse is over any other part of the content page, the 
dropdown should be asked to be rolled up and the page should be scrolled.
Assignee: rods → joki
Status: ASSIGNED → NEW
Whiteboard: This isn't going to make it for beta2

Comment 9

18 years ago
*** Bug 34161 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
The mousewheel should only scroll a dropped list if the list is scrollable 
(i.e. its contents require it to have vertical scrollbars).  Otherwise, it 
should close the list and scroll the page as usual.  This is how IE 5.5 
behaves, at least on win32.

Comment 11

18 years ago
I disagree with the nsbeta2 nomimation.  This can wait.
Whiteboard: developer nominating for pdt-

Updated

18 years ago
Whiteboard: developer nominating for pdt- → developer nominating no beta2

Comment 12

18 years ago
Putting on [nsbeta2-] radar. Not critical to beta2.
Whiteboard: developer nominating no beta2 → [nsbeta2-] developer nominating no beta2

Comment 13

18 years ago
Updating Milestone to M18.
Target Milestone: M17 → M18
(Assignee)

Comment 14

18 years ago
I've got an idea what's going on here.
Assignee: joki → bryner
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 15

18 years ago
*** Bug 32544 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 16

18 years ago
Nominating beta3 (we really don't want to have dropdown boxes floating around
when the page scrolls).  Marking XP.
Keywords: nsbeta3
OS: Windows NT → All
Hardware: PC → All
(Assignee)

Updated

18 years ago
Target Milestone: M18 → ---
(Assignee)

Comment 17

18 years ago
*** Bug 27938 has been marked as a duplicate of this bug. ***

Comment 18

18 years ago
nsbeta3-, helpwanted, future.
Keywords: helpwanted
Whiteboard: [nsbeta2-] developer nominating no beta2 → [nsbeta2-] [nsbeta3-] developer nominating no beta2
Target Milestone: --- → Future

Comment 19

18 years ago
Updating QA contact.
QA Contact: ckritzer → vladimire

Comment 20

18 years ago
Markinv rtm. Needs to get fixed, too many people use mouse wheel for this bug to 
 be released.
Keywords: rtm

Comment 21

18 years ago
cc'ing self. FWIW, I agree with Vladimire 110% about the RTM needs for this bug
(Assignee)

Comment 22

18 years ago
I tend to disagree.  This does not impair mousewheel functionality, at all.  It
simply requires you to roll up a dropdown list before you mousewheel scroll.  I
want to fix this the Right Way as rods suggests, but we simply don't have time
for 6.0.

Comment 23

18 years ago
Brian is correct, there is no way we will fix this for N6.  rtm-
Whiteboard: [nsbeta2-] [nsbeta3-] developer nominating no beta2 → [nsbeta2-] [nsbeta3-] [rtm-] developer nominating no beta2

Comment 24

18 years ago
I would encourage a re-think of that position Peter. IMNSHO this bug falls into 
the "silly" category. A *whole* lot of people are going to hit it. We really 
don't want to be leaving this kind of impression about the product in people's 
minds, especially when they can just go back to IE and scroll the *contents* of 
a combo box with the mouse wheel.

My .02 worth.
(Assignee)

Comment 25

18 years ago
mousewheel event targetting bugs -> mozilla 0.9
Target Milestone: Future → mozilla0.9
(Assignee)

Comment 26

18 years ago
*** Bug 60580 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 27

18 years ago
a patch for this is attached to bug 57598
(Assignee)

Comment 28

18 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 29

17 years ago
Looked at 32544 and verifying that as a duplicate of this one.
Both involve scrolling and drop down boxes.
Bug 32544 is about Moz not scrolling the drop down, whereas this bug is about 
the drop down not being closed up when the scrolling scrolls the page. Seem 
different problems, but I agree that the general cause is the same (drop down 
box scrolling not handled correctly) but are seeing the bug from two different 
angles. 
Suggest summary alteration to something more generic?
'Scrolling in a drop-down box not handled correctly' ??
(Suggest that the proposed fix be verified against 32544 before marked as such)

Comment 30

17 years ago
Verifying on windows 2000 build 2001-01-26-10-MTEST
Status: RESOLVED → VERIFIED

Comment 31

16 years ago
*** Bug 116294 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.