Last Comment Bug 355248 - Drag and drop of messages to folders broken in trunk around 2006/10/01
: Drag and drop of messages to folders broken in trunk around 2006/10/01
Status: RESOLVED DUPLICATE of bug 367203
:
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: unspecified
: PowerPC Mac OS X
: -- normal with 1 vote (vote)
: ---
Assigned To: Scott MacGregor
:
:
Mentors:
Depends on: 332913
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-03 09:18 PDT by Charles Bailey
Modified: 2007-02-20 08:04 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Charles Bailey 2006-10-03 09:18:41 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20060926 Camino/1.0+
Build Identifier: Mozilla Thunderbird version 3 alpha 1 (20061003)

Moving of messages by dragging the header line from the message "catalog" pane onto a folder icon in the mailbox listing has broken between the Sep 26 nightly and the Oct 01 nightly.  The drag appears to start normally (message header line higlights, and outline deags) but the folders do not act as targets (i.e. do not highlight when dragged over).  Moving messages via main or context menu commands works fine.

Reproducible: Always

Steps to Reproduce:
1. Open mailbox
2. Select message from listing of mailbox contents
3. Attempt to drag onto another folder

Actual Results:  
As above

Expected Results:  
Target folder highlights, and releasing mouse while hovering over target folder causes message to be moved.
Comment 1 Hiro 2006-10-03 19:25:18 PDT
It might be an influence of bug326469.
The problem occurs similarly in Firefox by D&D.(bug354958)
It is likely to improve it with FIXED of bug332913. 
Comment 2 xolaware.llc 2006-10-30 20:02:08 PST
any chance it is affected by an attempt to fix https://bugzilla.mozilla.org/show_bug.cgi?id=329086
Comment 3 Gulliver 2006-11-18 11:15:39 PST
Next week we see the 2 months anniversary for this bug (Built from Sept. 27th is the last where drag&drop works).

Any news here or in any other of the 20 associated/dependant bugs?
Comment 4 Gulliver 2006-11-19 05:36:41 PST
A very arrogant message by Wayne Woods ([url=https://bugzilla.mozilla.org/show_bug.cgi?id=332913#c42]Comment #42 From Wayne Woods[/url]) states that the basic bug 332913 was solved 3 weeks ago. Anybody working on this one now?
Comment 5 Gulliver 2006-11-19 05:37:52 PST
A very arrogant message by Wayne Woods (<a href="https://bugzilla.mozilla.org/show_bug.cgi?id=332913#c42">Comment #42 From Wayne Woods</a>) states that the basic bug 332913 was solved 3 weeks ago. Anybody working on this one now?
Comment 6 Hiro 2006-11-19 05:41:21 PST
(In reply to comment #5)
> A very arrogant message by Wayne Woods (<a
> href="https://bugzilla.mozilla.org/show_bug.cgi?id=332913#c42">Comment #42 From
> Wayne Woods</a>) states that the basic bug 332913 was solved 3 weeks ago.
> Anybody working on this one now?
> 

This problem has still reproduced. 
Comment 7 Daniel Kauffman 2007-01-07 20:14:42 PST
The following environment also exhibits the behavior noted by Charles Bailey:

  Thunderbird 1.5.0.9
  FreeBSD 6.1
  i386

Any suggestions on how I might help to fix this?
Comment 8 Gulliver 2007-01-08 03:16:27 PST
It also happens in Seamonkey, so please change the "product" designator.
Comment 9 Daniel Kauffman 2007-01-08 10:52:18 PST
Behavior disappears when gtk+ is reverted from 2.10.7 to 2.8.20

Based on when the behavior first appears in Thunderbird (per Charles Bailey, this was between September 26 and October 01) and on the release schedule for gtk+ (as inferred from file dates on ftp.gtk.org), the behavior was probably introduced with gtk 2.10.3 (released around September 05), 2.10.4 (released around September 23), or 2.10.6 (released around October 04), however, I have not tested this.

One *possible* cause (out of many) for this behavior would be an API change in gtk+ such as a change in the default value for a flag on the widget used for displaying the folder tree.

Is there somebody familiar with Thunderbird and gtk+ who would like to tackle this? Scott MacGregor, perhaps? Or is there somebody who could point me to the right files?
Comment 10 Alessandro Palma 2007-01-08 18:09:56 PST
Please, read these two post in the freebsd-gnome mailing list:
http://lists.freebsd.org/pipermail/freebsd-gnome/2007-January/016547.html
http://lists.freebsd.org/pipermail/freebsd-gnome/2007-January/016537.html

They are both reporting similar problem after the upgrade from gtk-2.10.6 to gtk-2.10.7.

The first is related to thunderbird, the second to the bookmarks manager using firefox, seamonkey and mozilla.
Comment 11 Thomas Butter 2007-01-17 12:29:29 PST
this also happens in ubuntu (feisty) starting with the update to gtk-2.10.7
Comment 12 Gulliver 2007-01-17 15:00:43 PST
Any news about a fix - 4 months after the first appearance?
Comment 13 Mart Raudsepp 2007-01-17 18:17:41 PST
(In reply to comment #10)
> They are both reporting similar problem after the upgrade from gtk-2.10.6 to
> gtk-2.10.7.
> 
> The first is related to thunderbird, the second to the bookmarks manager using
> firefox, seamonkey and mozilla.

This parcicular case is reported here as bug 367203 with a working patch.
There is also http://bugzilla.gnome.org/show_bug.cgi?id=394525 for gtk+ upstream report
Comment 14 John Griffiths 2007-01-29 18:25:07 PST
This is also occurring in Fedora Core 6 with gtk2-2.10.8-1.fc6 .

Ran thunderbird from a terminal and the following error is printed several times.

(Gecko:7527): Gtk-CRITICAL **: gtk_drag_get_data: assertion `GTK_IS_WIDGET (widget)' failed

As others have requested, please change the hardware and OS.
Comment 15 Daniel Kauffman 2007-01-29 19:51:53 PST
Appears to be duplicate of http://bugzilla.mozilla.org/show_bug.cgi?id=367203

See also http://www.freebsd.org/cgi/query-pr.cgi?pr=107689
Comment 16 ernst reissner 2007-02-13 15:56:05 PST
As far i can see, i lost the whole d&d functionality in mozilla products: 
This affects mozilla, seamonkey, thunderbird and firefox. 
This affects moving mail messages, bookmarks and also address-cards. 

The root of all evil ;-) seems to be some gtk-lib. 

Daniel Kauffman wrote (2007-01-08 10:52:18 PST)
Behavior disappears when gtk+ is reverted from 2.10.7 to 2.8.20
Hm, i use gtk2-2.8.3-4
(at least that is what rpm -q gtk2 says) 
and have the same problem. 

So, i'm not sure whether to upgrade or to downgrade... 

who can help??????????
Comment 17 Magnus Melin 2007-02-14 08:03:00 PST
Marking as dupe. Do try a recent nightly that would have the fix. 

*** This bug has been marked as a duplicate of bug 367203 ***
Comment 18 Bob Majdak Jr 2007-02-19 16:15:43 PST
still having this bug in most recent thunderbird, thunderbird 2, and thunderbird 3. and firefox.

gtk 2.10.9, i686, official mozilla releases.
Comment 19 ernst reissner 2007-02-20 01:31:01 PST
Bob, you are not alone ;-) 
i also tried thunderbird, thunderbird 2, and thunderbird 3. and firefox. 
but in contrast to you with gtk2 2.8.3: 
same problem. 

Is this the same bug or another one? 

Today i try an update suse 10.0 --> 10.2  without hope that this helps. 

Comment 20 Magnus Melin 2007-02-20 08:04:42 PST
May also be bug 370295.

Note You need to log in before you can comment on or make changes to this bug.