Junk mail not always put in Junk folder (IMAP)

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
12 years ago
6 years ago

People

(Reporter: Frantone Electronics, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

x86
Windows XP
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [moveproblem])

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8

On occasion email that is identified by the junk mail filter will remain in the inbox and is not automatically put into the trash, even though the trashcan icon in present in the line.  The email must then be deleted manually, causing the email to be read.

Reproducible: Sometimes



Expected Results:  
All identified junk mail should be placed in the trash automatically.

Updated

10 years ago
Assignee: mscott → nobody

Comment 1

10 years ago
if anyone still see this problem using a current version please comment with your version number and steps to reproduce.

if you no longer see the problem, please cite your version and close the bug or comment
Whiteboard: closeme 2008-10-21

Comment 2

10 years ago
version 2.0.0.17 (20080914)
WinXP SP2+

I'm not sure how to reproduce - it just happens sometimes.  Could be related to another problem which is that TBird seems to lose the ability to write to any local files at all.  Restart always fixes it, but often only for an hour or two.
Whiteboard: closeme 2008-10-21 → qawanted

Updated

9 years ago
Whiteboard: qawanted → [moveproblem]
Version: unspecified → 2.0

Comment 3

9 years ago
Continuing to see on
version 2.0.0.21 (20090302) on WinXP SP3
> Expected Results:  
> All identified junk mail should be placed in the trash automatically.

To Frantone Electronics(bug opener) and dannyv@post.harvard.edu:   

Ordinal setting is "automatically move to Junk folder".
(Q1) How do you set "automatically move junk mail to Trash folder"?
(Q2) POP3 or "Local Mail Folder"? Or IMAP folder?
If POP3 or "Local Folders", read Bug 324777(move to Junk folder case), see Bug 324777 Comment #75, and check whether "auto-compact of Trash(or Inbox) folder" is one of culprits or not first, please.
(Q3) auto-compact is one of culprits of your case?
If IMAP case, read Bug 324777 Comment #73, please.

Comment 5

9 years ago
Q1) Account->Junk Settings->Move new junk messages to: Other (I'm actually not using 'Trash'
Q2) IMAP folder.  my timeout is 29 as in Bug 495007.  What do you recommend?  

I've turned debug on and running DebugView.  I'll let you know what I find.

Comment 6

9 years ago
I have 33MB of logs that cover an instance of the problem, but they include private email, etc.  What in particular should I look for to upload?
(In reply to comment #6)
> I have 33MB of logs that cover an instance of the problem, but they include
> private email, etc.  What in particular should I look for to upload?

Clear up private data try to figure out the area where the error occurs.

Wada care to help dany figuring out and reading his log file ?
(In reply to comment #5)
> my timeout is 29 as in Bug 495007.  What do you recommend?  

The 29 was for interval of IDLE and was "29 minutes". It's irrelevant to tcptimeout. Sorry for my confusion.

(In reply to comment #5)
> (Q2) IMAP folder.
(In reply to comment #6)
> I have 33MB of logs that cover an instance of the problem, but they include
> private email, etc.  What in particular should I look for to upload?

Mail data itself is irrelevant to problem. Replace mail data lines by line like "*** NNN lines of mail data is omitted ***".
If servername, username, folder name, mail-addr etc. is sensitive data, replace them by some strings, with keeping text length, with keeping consistency in log file, before open log data to public.
This problem occurs to me today for first time with 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1pre) Gecko/20090715 Lightning/1.0pre Shredder/3.0b3pre ID:20090715031648

I attached junk mail that produce this issue.

I click on Junk button and nothing happens: only junk button disappair from my msgHeader.

Now, if I reimport this attached mail I cannot reproduce the issue.
Created attachment 388723 [details]
junk mail
(In reply to comment #9)
> Gecko/20090715 Lightning/1.0pre Shredder/3.0b3pre ID:20090715031648
> I click on Junk button and nothing happens: only junk button disappair from mymsgHeader.
> Now, if I reimport this attached mail I cannot reproduce the issue.

This bug is for similar phenomenon to next bugs.
> Bug 310431 Junk filter sometimes doesn't move junk to junk folder (Seamonkey)
> Bug 324777 junk mail not moved to junk folder sometimes (Thunderbird, Local Junk folder)
My questions were to know whether DUP of above bugs or IMAP specific case of same external symptom.

Your case is different problem from this bug although "Junk was not moved" part is same.
Dup of 487610? If not, check error console. Is there any error?
As written in Bug 497199 and as seen in Dependency Tree for Bug 497199, many regressions exist in ltest trunk builds. 
Aureliano Buendía, open separate bug for you problem which is different from this bug's problem, please.

Updated

9 years ago
Duplicate of this bug: 509932
Summary: Junk mail not always put in trash → Junk mail not always put in Junk folder (IMAP)

Comment 13

9 years ago
My experience is that if you click the flagged junk email (to make it not junk) and then click again to flag it as junk, the filter will then kick in and removes the message to the Junk folder.
Happens also to me with today build

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090930 Lightning/1.0pre Shredder/3.0pre ID:20090930031731

using POP3 and not imap.

No valid information in error console.
(In reply to comment #13)
> My experience is that if you click the flagged junk email (to make it not junk)
> and then click again to flag it as junk, the filter will then kick in and
> removes the message to the Junk folder.

Please don't do it with Tb3.0bN. If you unmark Junk, mail is moved back to Inbox(new feature). Select mails marked as Junk, then execute Mark/"As Junk" from context menu.

(In reply to comment #14)
> using POP3 and not imap.

If auto-compact is silently running, problem like Bug 168648, Bug 497804 may happen. And, if Junk folder is relevant to phenomenon like Bug 168648, Bug 497804, phenomenon of this bug and some similar bugs can occur. Could you please rule out "auto-compact without dialog before start of auto-compact" case. See comment #4 and Bug 498274 Comment #2, please.
(In reply to comment #14)
> using POP3 and not imap.

FYI. There are open bugs for POP3 case - Bug 310431(Sm) and Bug 324777(Tb).

Comment 17

9 years ago
(In reply to comment #15)
> (In reply to comment #13)
> > My experience is that if you click the flagged junk email (to make it not junk)
> > and then click again to flag it as junk, the filter will then kick in and
> > removes the message to the Junk folder.
> 
> Please don't do it with Tb3.0bN. If you unmark Junk, mail is moved back to
> Inbox(new feature). Select mails marked as Junk, then execute Mark/"As Junk"
> from context menu.
> 
> (In reply to comment #14)
> > using POP3 and not imap.
> 
> If auto-compact is silently running, problem like Bug 168648, Bug 497804 may
> happen. And, if Junk folder is relevant to phenomenon like Bug 168648, Bug
> 497804, phenomenon of this bug and some similar bugs can occur. Could you
> please rule out "auto-compact without dialog before start of auto-compact"
> case. See comment #4 and Bug 498274 Comment #2, please.

As for Not Junk - learned that the hard way.

As for Auto-compact running silently - is there some way to make it at the very least give some sort of notification that it is running (IOW not run 'silently' but with full notification)?

I realize that this may be counter intuitive, as most folks would want compaction to occur without their intervention, but a simple notification similar to new mail notification would be helpful to folks like me, using 8 different accounts via IMAP and another 5 via POP in the same profile.

Comment 18

9 years ago
Reporter - is this still reproducible for your using current release builds (2.x) or 3.x Beta / pre-release builds?
xref Bug 310431 and Bug 324777, for ease of track.
Depends on: 310431, 324777

Comment 20

9 years ago
Still reproducible here

Comment 21

7 years ago
If you saw this problem in the past, and did not solve it by changing cached connections - please comment to say that you still see the problem. (or don't see the problem)


(In reply to comment #20)
> Still reproducible here

Danny reports via PM it used to be pretty regular.  I can't say whether it was due to changes in TB or my environment," ... but the issue is gone using v3.1.5


(In reply to comment #17)
> a simple notification
> similar to new mail notification would be helpful to folks like me, using 8
> different accounts via IMAP and another 5 via POP in the same profile.

Bug 469050 is nearing completion - Compacting operation should be shown on Activity Manager window



(In reply to comment #18)
> Reporter - is this still reproducible for your using current release builds
> (2.x) or 3.x Beta / pre-release builds?

Frantone seems to be gone

Comment 22

7 years ago
(In reply to comment #21)
> If you saw this problem in the past, and did not solve it by changing cached
> connections - please comment to say that you still see the problem. (or
> don't see the problem)
> 

It's not on the top of my mind, so I must not have seen it for a while.  Will pay attention to see if it's still happening.

Comment 23

6 years ago
I thnk we clost this based on comment 21
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.