the BDO element is not implemented

RESOLVED FIXED

Status

()

Core
Layout: Text
P3
enhancement
RESOLVED FIXED
19 years ago
4 years ago

People

(Reporter: Claudius Gayle, Assigned: smontagu)

Tracking

({pp, regression})

Trunk
PowerPC
All
pp, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
On the test page you will see three sentences.
The third sentence should be written from Right To Left.
It is not. It is displayed 'normally' or LTR
To be fair, Nova does not handle this properly, nor does IE4.
This bug is valid for all current (Mar10) builds of Seamonkey.
(Reporter)

Updated

19 years ago
QA Contact: 4144 → 4130
(Reporter)

Comment 1

19 years ago
setting QAC to myself

Updated

19 years ago
Severity: normal → enhancement
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → LATER

Comment 2

19 years ago
nglayout and 5.0 will not be supporting full BIDI layout. So I'm marking this
bug as LATER.

Comment 3

18 years ago
mine now
Assignee: kipp → buster
Status: RESOLVED → NEW

Comment 4

18 years ago
resetting later resolution accidentally removed
Status: NEW → RESOLVED
Last Resolved: 19 years ago18 years ago

Comment 5

17 years ago
reopen to reassign
Status: RESOLVED → REOPENED
Resolution: LATER → ---

Comment 6

17 years ago
I presume BDO ~ BiDi; mkaply is this yours or fixed or ...
Assignee: buster → mkaply
Status: REOPENED → NEW
OS: Mac System 8.5 → All

Comment 7

17 years ago
This will be fixed in the Bidi code coming soon....
Status: NEW → ASSIGNED

Comment 8

17 years ago
Can I get this HTML page on an external server somewhere to test with the 
IBMBIDI changes?
(Reporter)

Comment 9

17 years ago
sorry, the url link was just old; all these tests are of course available outside the firewall.

Comment 10

17 years ago
This bug will be fixed when IBMBIDI is turned on in the build.
Depends on: 75982

Comment 11

17 years ago
*** Bug 9100 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
Fixed in current build
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED

Comment 13

17 years ago
Chaning QA contact. HTML issue.
QA Contact: petersen → bsharma

Comment 14

17 years ago
BDO element is not working on the Mac July 10th branch or trunk builds (2001071005).
http://mozilla.org/quality/browser/standards/html/bdo.html

Third paragraph should flow from right to left but doesn't.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

17 years ago
Keywords: regression

Comment 15

17 years ago
cc lchiang
I think this is Mac-only (actually, it's probably Bidi-unaware-only). 
Marking pp.
Keywords: pp
Hardware: All → Macintosh

Comment 17

17 years ago
Is this element not working only when bi-directional text is turned on?

cc: montse

Updated

17 years ago
Blocks: 41368

Updated

17 years ago
Blocks: 7954
(Assignee)

Comment 18

16 years ago
Moving to Bidi component. Should QA change also?
Component: Layout → BiDi Hebrew & Arabic

Comment 19

16 years ago
any update to this bug?  With bi-di support now, can this be fixed soon?

Comment 20

16 years ago
Montse or Mike - any updates to this?

How often is this element used on web pages?

Comment 21

16 years ago
There is no work being done on Mac Bidi support right now. I don't believe the 
skills exist.

Comment 22

16 years ago
Per lchiang's request, let me add some comments.
AFAIK, BDO element is used primarily in the following types
of situations.

1. The document contains multilingual text and Bidi Algorithm
   will apply to such a text. 
2. Under some circumstances, e.g. MIME compliant mail agents might 
   have already applied RtoL formatting. If the bidi-alorithm is
   applied again, this will produce incorrect order.

The web author can retain full control of text directionality with
the BDO element. 
I am thinking that the possibility of using BDO in web pages might be
small. For e-mail agents, the situation may not be that uncommon, e.g.
English msgs with Hebrew embedded. So the question to me is that do
we handle Hebrew/English mail messages OK most of the time?

Given that this bug is for Mac only and the fact that the BDO element
is designed to handle a small percentage of cases, I am not sure if fixing this 
is of urgent nature.
QA Contact: bsharma → zach

Comment 23

16 years ago
is this really mac only? If it is how did bug 9100 get duped to this bug?

Comment 24

16 years ago
Don't know if it's Mac-only, but <bdo> is functional in Mozilla 0.9.5 for win32. 

Comment 25

16 years ago
BDO is not working for me on Mozilla 2001121303 on Windows ME.

Testcase:
http://mozilla.org/quality/browser/standards/html/bdo.html

Actual results:
The third sentence is written from left to right.

Expected results:
The third sentence should be written from right to left.  Even though Latin
characters have inherent left-to-right directionality, BDO is supposed to
override it.

http://www.w3.org/TR/html4/struct/dirlang.html#h-8.2.4

  8.2.4 Overriding the bidirectional algorithm: the BDO element

  dir = LTR | RTL [CI]
  This mandatory attribute specifies the base direction of the element's text
  content. This direction overrides the inherent directionality of characters
                          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

This may be the same as bug 9100.

Updated

16 years ago
Blocks: 115710

Comment 26

16 years ago
change platform to ALL. Looks like a regression. N6.2 is fine on WinNT4J but
trunk build is bad now. reassign to smontagu
Assignee: mkaply → smontagu
Status: REOPENED → NEW
Hardware: Macintosh → All
(Assignee)

Comment 27

16 years ago
Let's keep this one as mac-only. The all-platform regression is bug 115921,
which dbaron checked in the fix for today.
Hardware: All → Macintosh
(Assignee)

Comment 28

16 years ago
ftang or zach, can you test
http://mozilla.org/quality/browser/standards/html/bdo.html and 
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=61906 on a current Mac
build and close this bug if they appear correctly?

Comment 29

16 years ago
*** Bug 119130 has been marked as a duplicate of this bug. ***

Comment 30

16 years ago
In the Mac OSX and Mac 0S Classic Jan 30th builds , the bdo test renders
correctly now.

http://mozilla.org/quality/browser/standards/html/bdo.html

Comment 31

16 years ago
That's good.  I wonder which change fixed this.  Perhaps the bug can be marked
WFM by the owner unless we know specifically the fix which addressed this.  Thanks.
(Assignee)

Comment 32

16 years ago
This will have been fixed by the fix to bug 116976 and/or bug 116982 (depending
on Mac system).
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED

Updated

9 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.