Choosing IMAP mail folders for offline use does not allow all folders to be selected

RESOLVED DUPLICATE of bug 174934

Status

--
enhancement
RESOLVED DUPLICATE of bug 174934
11 years ago
11 years ago

People

(Reporter: ian, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: version 2.0.0.0 (20070326)

When choosing IMAP mail folders for download for offline use, there is no way to select ALL folders.  The process is torturous and requires each branch of the tree of IMAP folders to be opened and folders to be selected either by clicking them with the mouse OR by selecting multiple folders and then pressing spacebar.  Unfortunately both approaches seem to only allow ~300 folders to be selected at any one time.  A download / sync must be performed BEFORE any further folders can be selected.  So to download the 2000 to 3000 folders takes many iterations.

Then Bug 267772 and 379531 randomly de-select folders that have been previously selected and all goes to make the whole IMAP offline selection / download virtually unusable.

Reproducible: Always

Comment 1

11 years ago
For the suite there is bug 174934. Related/dupe: bug 308504.
Severity: major → enhancement
OS: Mac OS X → All
Hardware: Macintosh → All
Version: unspecified → 2.0
(Reporter)

Comment 2

11 years ago
A painful work around for selecting ALL folders is to: 
1. Select as many folders as you can (usually ~100) 
2. Quit Firefox....and exiting Firefox seems to take along time ~30sec rather than the usual 2-3 seconds
3. Restart Firefox and repeat steps 1 and 2 until ALL folders are selected.

I have not found if this eliminates the de-selection problem reported above.
(Reporter)

Comment 3

11 years ago
Actually I meant Thunderbird (and not Firefox)...sorry

Comment 4

11 years ago
Use hidden option mail.server.default.autosync_offline_stores = TRUE to automatically select everything and everywhere.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 174934
You need to log in before you can comment on or make changes to this bug.