If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

New mail notification window (alert) doesn't comply with high-contrast GNOME theme

RESOLVED FIXED

Status

Thunderbird
General
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: Tim Miao, Assigned: Patrick Wagstrom)

Tracking

({access})

Trunk
x86
Linux
access

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
New mail notification popup window is not compliant with gnome desktop theme settings.

Steps to reproduce:
1. Change gnome desktop theme to high contrast large print inverse.
2. Start thunderbird and compose a new message to yourself.
3. Send and receive mail.

Expected result:
After step 3, new mail notification window will be popup, it should be compliant with selected theme settings.

Actual result:
This notification window is not compliant with selected theme settings.

Updated

11 years ago
Component: Message Compose Window → General
QA Contact: message-compose → general
Summary: Notification window is not compliant with gnome desktop theme settings. → New mail notification window (alert) doesn't comply with high-contrast GNOME theme

Comment 1

11 years ago
Can you provide a screenshot of the alert?
(Reporter)

Comment 2

11 years ago
Created attachment 266583 [details]
screenshot

Updated

11 years ago
Duplicate of this bug: 382450
(Assignee)

Comment 4

11 years ago
Created attachment 266639 [details] [diff] [review]
patch to fix color issues

this is the updated patch against CVS from today
(Assignee)

Updated

11 years ago
Attachment #266639 - Flags: review+

Comment 5

11 years ago
Comment on attachment 266639 [details] [diff] [review]
patch to fix color issues

I don't think anyone has reviewed this patch yet so removing the plus. 

Asking Magnus and myself.
Attachment #266639 - Flags: superreview?(mscott)
Attachment #266639 - Flags: review?(mkmelin+mozilla)
Attachment #266639 - Flags: review+

Comment 6

11 years ago
Can we use 
 background-color: -moz-Dialog;
 color: -moz-DialogText;
?

I think we should not hardcoded bg/fg color to white/black.

Comment 7

10 years ago
Comment on attachment 266639 [details] [diff] [review]
patch to fix color issues

I think Ginn is on the right track with his suggestion. Can you incorporate it into your patch?
Attachment #266639 - Flags: superreview?(mscott)
Attachment #266639 - Flags: superreview-
Attachment #266639 - Flags: review?(mkmelin+mozilla)
Attachment #266639 - Flags: review-

Comment 8

10 years ago
While you're at it, it turned out that the min-height and background-color rules on #newMailAlertNotification in the newMailAlertUnix.css file aren't needed - so we can get rid of them like on the branch. http://lxr.mozilla.org/mozilla1.8/source/mail/themes/qute/mail/newMailAlertUnix.css#9
(Assignee)

Comment 9

10 years ago
Created attachment 266916 [details] [diff] [review]
updated version of patch to utilize mozilla symbolic names
Attachment #266916 - Flags: review?(mscott)

Updated

10 years ago
Attachment #266916 - Flags: superreview?(mscott)
Attachment #266916 - Flags: review?(mscott)
Attachment #266916 - Flags: review?(mkmelin+mozilla)

Comment 10

10 years ago
Comment on attachment 266916 [details] [diff] [review]
updated version of patch to utilize mozilla symbolic names

Looks good. r=mkmelin+mozilla@iki.fi
Attachment #266916 - Flags: review?(mkmelin+mozilla) → review+

Updated

10 years ago
Attachment #266916 - Flags: superreview?(mscott) → superreview+

Updated

10 years ago
Assignee: mscott → patrick.bugs
Whiteboard: [checkin needed]

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]

Comment 11

10 years ago
Ginn Chen checked this in at 2007-06-08 00:22, FWIW.
Duplicate of this bug: 384306

Updated

10 years ago
Duplicate of this bug: 417238

Updated

9 years ago
Duplicate of this bug: 443104
You need to log in before you can comment on or make changes to this bug.