Last Comment Bug 387656 - Rename 'Unsent' folder to 'Outbox'
: Rename 'Unsent' folder to 'Outbox'
Status: VERIFIED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: Trunk
: All All
: P2 enhancement with 2 votes (vote)
: Thunderbird 3.0a3
Assigned To: Magnus Melin
:
Mentors:
: 85078 141986 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-11 01:17 PDT by Jeremy Morton
Modified: 2010-05-28 03:48 PDT (History)
8 users (show)
davida: blocking‑thunderbird3+
davida: wanted‑thunderbird3+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
proposed fix (25.66 KB, patch)
2008-07-13 03:37 PDT, Magnus Melin
mnyromyr: review+
mozilla: superreview+
Details | Diff | Splinter Review
fix the test failure (1.09 KB, patch)
2008-08-15 05:12 PDT, Magnus Melin
standard8: review+
Details | Diff | Splinter Review

Description Jeremy Morton 2007-07-11 01:17:04 PDT
This should be done because:
- Most other mail clients do it
- It's more specific.  'Drafts' also contain 'unsent' mail, but what is the intention for mail in that folder?  That it will be further edited.  The intention for mail in this folder is that it will be sent, hence the name, 'Outbox', much like an 'Out tray' in an office.

Could someone advise me as to what would be needed to get this translated into all of TB's languages?  Obviously I could do it for English, French, German, and anything else that Babelfish translates to, but... :-)
Comment 1 Axel Hecht [pto-Aug-30][:Pike] 2007-07-11 01:42:57 PDT
There are two occurences of 'unsent' in http://lxr.mozilla.org/mozilla/source/mail/locales/en-US/chrome/messenger/messenger.properties, both of which would need to be changed, I guess.

You should not only change the values, but the keys for those strings, too, so that they remain semantic names for the values. If you do that, localizers will automatically pick it up.

That's the technical l10n side, no idea if thunderbird devs commented on the actual change yet.
Comment 2 Andrew Hagen 2008-04-15 13:16:50 PDT
Important simplification. 
Comment 3 David Ascher (:davida) 2008-06-19 15:53:54 PDT
Low hanging fruit, but I also think this should be combined with promoting the folder to a higher prominence place in the UI, not buried under the (often collapsed) Local Folders tree.  is there a bug for that?
Comment 4 Jeremy Morton 2008-06-20 01:57:05 PDT
Whatsmore, there should be an option for 'Send' to place the mail into the outbox, instead of always instantly sending, IMHO.  I like to do that in case I click send and realise a minute later that I cocked something up, which happens surprisingly often.  Of course this would also necessitate the need for an additional OE-like "send and receive" button.
Comment 5 Magnus Melin 2008-07-13 01:33:39 PDT
(In reply to comment #3)
> Low hanging fruit, but I also think this should be combined with promoting the
> folder to a higher prominence place in the UI, not buried under the (often
> collapsed) Local Folders tree.  is there a bug for that?

That would be bug 104344 (at least for imap). 

Comment 6 Magnus Melin 2008-07-13 02:44:29 PDT
I'll take on the renaming, leaving bug 104344 to someone else. 
Comment 7 Magnus Melin 2008-07-13 03:37:06 PDT
Created attachment 329281 [details] [diff] [review]
proposed fix

Assuming seamonkey wants this as well...?

Cleaning up some related cruft while i'm in
 - there is no such thing as |specialFolder == 'Unsent'|
 - the seamonkey \n\n certainly doesn't seem to be needed (anymore?)
 - "netscape webmail" access through imap is no more is it

The "would you like to send..." wording needed changing, esp. if the future holds per account outboxes.
Comment 8 Magnus Melin 2008-07-13 03:40:51 PDT
sendMessagesLabel2 is a bit different between tb and sm now (just changed it to fit the tone that was there). Maybe they should be the same?
Comment 9 Magnus Melin 2008-07-13 06:47:54 PDT
*** Bug 85078 has been marked as a duplicate of this bug. ***
Comment 10 Karsten Düsterloh 2008-07-21 11:31:42 PDT
Comment on attachment 329281 [details] [diff] [review]
proposed fix

Looks good (mailnews + suite parts).
Comment 11 Bryan Clark (DevTools PM) [@clarkbw] 2008-07-21 12:05:44 PDT
this looks great

(In reply to comment #3)
> Low hanging fruit, but I also think this should be combined with promoting the
> folder to a higher prominence place in the UI, not buried under the (often
> collapsed) Local Folders tree.  is there a bug for that?

bug 446306 is for the new folder pane where the Outbox can be listed as a prominent folder when needed.
Comment 12 Magnus Melin 2008-08-13 10:53:22 PDT
David? sr ping
Comment 13 David :Bienvenu 2008-08-13 21:55:44 PDT
Comment on attachment 329281 [details] [diff] [review]
proposed fix

looks good, thx, Magnus.
Comment 14 Magnus Melin 2008-08-15 04:43:21 PDT
changeset:   101:50e6655f95eb
->FIXED
Comment 15 Magnus Melin 2008-08-15 05:12:28 PDT
Created attachment 333918 [details] [diff] [review]
fix the test failure

Should fix the test failure.
Comment 16 Magnus Melin 2008-08-15 05:22:12 PDT
changeset:   102:d511e5942a0c
Comment 17 Henrik Skupin (:whimboo) 2008-09-14 16:24:31 PDT
Verified with:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b1pre) Gecko/20080913035135 Shredder/3.0b1pre ID:20080913035135

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080913070841 Shredder/3.0b1pre
Comment 18 neil@parkwaycc.co.uk 2010-05-28 03:48:17 PDT
*** Bug 141986 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.