autocomplete dropdown has no border after 388317

VERIFIED FIXED in mozilla1.9beta2

Status

()

Toolkit
Themes
P3
normal
VERIFIED FIXED
11 years ago
9 years ago

People

(Reporter: logan, Assigned: Sylvain Pasche)

Tracking

({pp, regression})

Trunk
mozilla1.9beta2
x86
Linux
pp, regression
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

11 years ago
On gtk builds, the autocomplete dropdown is just plain white (no border). This blends into the background of most pages and generally looks bad. As stated in comment 5 of 388317, a "border: 1px solid black;" would take care of this.
Blocks: 388317
(Assignee)

Comment 1

11 years ago
Created attachment 275238 [details]
testcase
(Assignee)

Comment 2

11 years ago
Created attachment 275239 [details]
Linux screenshot
(Assignee)

Comment 3

11 years ago
Created attachment 275240 [details]
Windows XP screenshot
(Assignee)

Comment 4

11 years ago
The modification made in bug 388317 for the menulist does not apply on Linux, as the Linux theme has its own popup.css file. But for autocomplete.css, it is shared between between the two.

I see two options for fixing the Linux case:
1) Keep the old -moz-appearance for linux in gnomestripe
2) Fix the CSS on Linux to have the popup looks native (not sure why background-color: -moz-field and ThreeDDarkShadow do not look native).

Updated

11 years ago
Duplicate of this bug: 390880

Updated

11 years ago
Duplicate of this bug: 391097

Updated

11 years ago
Flags: blocking1.9?

Updated

11 years ago
Keywords: regression

Updated

11 years ago
Duplicate of this bug: 392668

Comment 8

11 years ago
Is these two bugs are related 
https://bugzilla.mozilla.org/show_bug.cgi?id=392655

Anyone has filed a bug with gtk team ?

Comment 9

11 years ago
(In reply to comment #8)
> Is these two bugs are related

No.
Duplicate of this bug: 395990
Duplicate of this bug: 398242
(Assignee)

Updated

11 years ago
Duplicate of this bug: 398497

Updated

11 years ago
Keywords: pp
+'ing.  Setting priority to P3.
Flags: blocking1.9? → blocking1.9+
Priority: -- → P3
(Assignee)

Comment 14

11 years ago
Created attachment 288230 [details] [diff] [review]
patch, v1

Well, ifdefs are bad, but this makes both panel and panel[type="autocomplete"] have a -moz-appearance set to menupopup on GTK (so they will have borders).
After bug 388317, panel and panel[type="autocomplete"] had their -moz-appearance set to menupopup and none respectively (see comment 4).
Attachment #288230 - Flags: review?
(Assignee)

Updated

11 years ago
Attachment #288230 - Flags: review? → review?(mano)
Comment on attachment 288230 [details] [diff] [review]
patch, v1

Neil should review this.
Attachment #288230 - Flags: review?(mano)
(Assignee)

Updated

11 years ago
Attachment #288230 - Flags: review?(neil)

Comment 16

11 years ago
Comment on attachment 288230 [details] [diff] [review]
patch, v1

I hope Mano means the other Neil.
Attachment #288230 - Flags: review?(neil) → review?(enndeakin)

Updated

11 years ago
Attachment #288230 - Flags: review?(enndeakin) → review+
(Assignee)

Updated

11 years ago
Keywords: checkin-needed
Assignee: nobody → sylvain.pasche
Checking in toolkit/themes/winstripe/global/autocomplete.css;
/cvsroot/mozilla/toolkit/themes/winstripe/global/autocomplete.css,v  <--  autocomplete.css
new revision: 1.20; previous revision: 1.19
done
Checking in toolkit/themes/winstripe/global/jar.mn;
/cvsroot/mozilla/toolkit/themes/winstripe/global/jar.mn,v  <--  jar.mn
new revision: 1.38; previous revision: 1.37
done
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9 M10
Pretty sure this bug's patch caused a regression.  

There's now a weird gray bar at the top of the dropdown, which pushes the last (or only) completion in the box out of view. See bug 403659 and the screenshots posted there.
(Assignee)

Updated

11 years ago
No longer blocks: 403659
(Assignee)

Comment 19

11 years ago
(In reply to comment #18)
> Pretty sure this bug's patch caused a regression.  
> 
> There's now a weird gray bar at the top of the dropdown, which pushes the last
> (or only) completion in the box out of view. See bug 403659 and the screenshots
> posted there.

-> regression of bug 118312
(Assignee)

Updated

11 years ago
Duplicate of this bug: 401489
(Assignee)

Updated

11 years ago
Duplicate of this bug: 405148
verified fixed using Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9b2) Gecko/2007121016 Firefox/3.0b2Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9b2) Gecko/2007121016 Firefox/3.0b2 on Fedora F8 by using the testcase from this bug and also testing the automcomplete dropdown.

-> Verified fixed
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey

Updated

9 years ago
Component: Themes → Themes
Product: SeaMonkey → Toolkit
QA Contact: themes → themes
You need to log in before you can comment on or make changes to this bug.