Closed Bug 397411 Opened 12 years ago Closed 12 years ago

Rename Places Organizer window to "Library"

Categories

(Firefox :: Bookmarks & History, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 3 beta3

People

(Reporter: faaborg, Assigned: beltzner)

References

Details

(Whiteboard: [places-ui])

Attachments

(1 file, 2 obsolete files)

Should "Places Organizer" be renamed to something more descriptive, like "Bookmarks and History Organizer."  Some localizers are not sure how to best translate "places" and I'm concerned that the word is too meta to trigger anything in the user's mental model of their Web browser.
Blocks: 393514
Whiteboard: [places-ui]
I think the menu "Bookmarks" should be renamed to "Places". It'd make more sense.
Well in the 'Bookmarks' menu it is "Organize Bookmarks" so why not just call it that?
(In reply to comment #2)
> Well in the 'Bookmarks' menu it is "Organize Bookmarks" so why not just call it
> that?
> 

Because doesn't manage only bookmarks but also history and downloads?
(In reply to comment #0)
> Should "Places Organizer" be renamed to something more descriptive, like
> "Bookmarks and History Organizer."  Some localizers are not sure how to best
> translate "places" and I'm concerned that the word is too meta to trigger
> anything in the user's mental model of their Web browser.
> 

Yes, i like that idea. I can confirm, that it isn't easy for us (localizers) to find the right term for "places". Of course, this word has equivalent in each language, but I am afraid users won't understand its meaning if we use it. We considered to traslate it exactly in the same way you mentioned (Bookmarks and History Organizer), but we have decided to let it untranslated and are still looking for the right term in sk locale. More descriptive title would really help us.
At first I was thinking about "Bookmarks and History Organizer" but that is kind of long, and you don't actually want to organize your history.  So Beltzner suggested shortening the name to just "Bookmarks and History."

We'll probably go with that for now.  Ways to invoke this window will include:

Bookmarks Menu > Show all Bookmarks (loads with the All Bookmarks UI displayed)
History Menu > Show all History (loads with the History UI displayed)
Download Manager > View History (loads with the Downloads UI displayed)
Why not simply call the entities historyAndBookmakrs~ and let the en-US string be "Places"?
Really two separate issues, making life easier for to localizers, and Places not being descriptive enough for en-us users to understand what it means.
What about "Bookmarks Library"
Flags: blocking-firefox3?
(In reply to comment #8)
> What about "Bookmarks Library"

No, Bookmarks & History is what we want to use, I think. Taking.
Assignee: nobody → beltzner
Status: NEW → ASSIGNED
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
Target Milestone: --- → Firefox 3 M10
1) Do we want to mention Tags in the title at all?
2) Should we rename the "Bookmarks | Organize Bookmarks..." menu item?
>2) Should we rename the "Bookmarks | Organize Bookmarks..." menu item?

Yes, filed bug# 404084
After talking with beltzner, we want to call the window "Library."

The name is sort, easy to remember, and it scales well. As we store more information in this window in the future the name won't turn into Bookmarks & History & Web Receipts & Locations, Events, and Contacts.
"Library" sounds good to me in English.

I was just thinking about a possible German translation, Library itself would be "Bücherei", which feels odd, "Archiv" would be the translation of "archive", and less bound-paper-centric.

Firstly, I should check that my assumption on the meaning is right. If so, would it make sense to add a few synonyms for Library to the localization task? I would think of "Library", "Archive", "Repository". I'm not necessarily suggesting a technical implementation of that suggestion list, but it seems like a concept for which different terms might be differently fitting in different languages.
Yeah, it certainly doesn't have to be a literal translation, anything that captures the notion of a collection of items in the general spirit of the term "Library" is fine.
Comment on attachment 289819 [details] [diff] [review]
rename "Places Organizer" to "Library", add l10n note

>+<!-- LOCALIZATION NOTE (library.organizer.title): use "Library", "Archive" or "Repository" -->
>+<!ENTITY library.organizer.title  "Library">
>+
>+<!ENTITY organize.label           "Organize">

Please put the comment before the entity like this?
Sure thing. Also, I'll remember to change the XUL reference to the new entity title ;)
Attachment #289819 - Attachment is obsolete: true
Attachment #289819 - Flags: review?(sspitzer)
Comment on attachment 289820 [details] [diff] [review]
rename "Places Organizer" to "Library", add l10n note (v2)

Seth: I kept the "places" references in the entity name since I figured changing it throughout the code would be a huge PITA :)
Attachment #289820 - Flags: review?(sspitzer)
Summary: Rename Places Organizer? → Rename Places Organizer window to "Library"
Nit, I'd prefer places.library.title to .winTitle.

l10n tools like to draw conclusions from the name suffix of an entity. I think that only affects .label and .accesskey, at least now, but .title is a nice common pattern that I'd rather preserve.
Attachment #289820 - Flags: review?(sspitzer) → review+
Why not simply "Bookmarks and History"? Why use "organizer or manager"? They are IMHO redundant and I think it is unimportant for a user if this is a manager or an organizer. The main thing is that the functionality exists. Also the word "Library" is vague. But "places" is, of course" a very empty word and therefore hardly translatable.
Web data center? 
I think "library" is OK. "Web data center" probably sounds too technical, but is better than "places" of course.
(In reply to comment #0)
> Some localizers are not sure how to best
> translate "places" and I'm concerned that the word is too meta to trigger
> anything in the user's mental model of their Web browser.

If so, "Places" folder in Bookmarks Toolbar should be also renamed?
> If so, "Places" folder in Bookmarks Toolbar should be also renamed?

that is covered by bug #399477
is this just needing check-in?
(In reply to comment #25)
> is this just needing check-in?

Comment #19 needs to be addressed.
Duplicate of this bug: 407622
Target Milestone: Firefox 3 M10 → Firefox 3 M11
fixes Axel's nit from comment 19
Attachment #289820 - Attachment is obsolete: true
Attachment #292552 - Flags: review?(gavin.sharp)
Attachment #292552 - Flags: review?(gavin.sharp) → review+
Adding keyword, as I don't have CVS access (ye gods, can you imagine the havoc I'd wreak?)
Keywords: checkin-needed
Thanks for the patch!

Checking in browser/locales/en-US/chrome/browser/places/places.dtd;
/cvsroot/mozilla/browser/locales/en-US/chrome/browser/places/places.dtd,v  <--  places.dtd
new revision: 1.39; previous revision: 1.38
done
Checking in browser/components/places/content/places.xul;
/cvsroot/mozilla/browser/components/places/content/places.xul,v  <--  places.xul
new revision: 1.99; previous revision: 1.98
done
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
I think it is needed to fix help document. I filed Bug 407891.
verified with: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b3pre) Gecko/2007121904 Minefield/3.0b3pre and the equivalent Win XP build
Status: RESOLVED → VERIFIED
Okay I must be missing something. I'm just wondering... how do you claim a bug# as a dupe and how do you verify a dupe?
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.