silent deletion of mails by GMail-IMAP: workarounds to protect Thunderbird's users

RESOLVED INVALID

Status

RESOLVED INVALID
10 years ago
2 years ago

People

(Reporter: helgehelge, Unassigned)

Tracking

(Blocks: 1 bug, {imap-interop})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: 3.0a1 (2008050715)

-




Reproducible: Always

Steps to Reproduce:
-
Actual Results:  
-

Expected Results:
Could you provide more detailed steps to reproduce?
This bug is spin-off of Bug 439216 Comment #2 and Comment #14.
Joshua Cranmer, please see Bug 439216 Comment #3 and Bug 439216 Comment #6 for example of "silent delete of mail by Gmail IMAP", till we prepare crisp description about "silent delete of mail by Gmail IMAP".  
Blocks: 402793
(Off-Topic) To Helge(bug opener):
Open new bug via "New" link at the bottom please, instead of via Bugzilla Helper.   
This is more Tech evangelism, Gmail should fix their mail handling, why should we we add workarounds for gmail ?
Should we add workaround for every stupid broken mail service in the world ?
(Reporter)

Comment 5

10 years ago
(In reply to comment #4)

> Should we add workaround for every stupid broken mail service in the world ?

Not for every one, but lots of people use GMail and I believe that the Thunderbird 3's planning is right that better IMAP support will increase Thunderbird's adoption because people want to have their email folders online (plans: https://wiki.mozilla.org/Thunderbird:Thunderbird3#Increased_Adoption )
(In reply to comment #4)
> This is more Tech evangelism, Gmail should fix their mail handling, why should
> we we add workarounds for gmail ?
> Should we add workaround for every stupid broken mail service in the world ?

I essentially agree with you on your opinion.
(please read my Bug 439216 Comment #3)

However, "account definition support for Gmail POP3" is already implemented by Tb 2, and attempt to add "account definition support for Gmail IMAP" is already in progress(see Bug 400931, please).
When enhancement by Bug 400931 is finished and released to public, I think many Tb users use Gmail IMAP without care for Gmail IMAP's special design/spec. I believe that it'll produce flood of bugs which shout "My mail is lost due to Tb's bug!!!" or "My mail is missing due to Tb's bug!!!".
(please read my Bug 439216 Comment #3)

I think at least documentation/guidance/help by Tb will be required before release of enhancement by Bug 400931.
(Needless to say, Googl have to provide good documentation/guide about Gmail IMAP to users before Tb will provide documentation/guide/help to users.)
Further, when "Copy from [Gmail]/Drafts" case(Bug 4392167's case), feature of "Disable COPY if Gmail IMAP's [Gmail]/Drafts" is possible and effective solution to avoide unwanted bug open. (This kind of feature was implemented for AOL account in the past.)

Helge(bug opener) says "to protect Thunderbird's users" only. But I believe something to avoid "flood of unwanted bugs" is required for developers and supporters(like us), in addition to "to protect Thunderbird's users". It's the reason why I recommended Helge to open this bug.

Matthias Versen, what do you think?
(please note that I'm not opposite to changing Evange bug or documentation bug.)  

Bug for "Copy from [Gmail]/Drafts" case was Bug 439216. Sorry for mistype & spam.
Currently known "silent deletion of mails by GMail-IMAP" cases.
(1) Copy/Move from Gmail IMAP folder to [Gmail]/Spam or [Gmail]/Trash folder
    (Bug 450376)
(2) Copy/Move of copies of a mail from Gmail IMAP folder
    to Gmail IMAP folder at where copy of the mail is already held
    (Externally same phenomenon as Bug 450368, so specific bug is not opened.
(3) Copy/Move of copies of a mail from local mail folder(other account's folder)
    to Gmail IMAP folder at where copy of the mail is already held
    (Bug 450368)
(4) Copy from [Gmail]/Drafts to other older
    (Bug 439216)
Keywords: interop

Updated

10 years ago
Blocks: 450368

Updated

10 years ago
Blocks: 450376

Comment 9

6 years ago
I'm going to call this a bug :)  assuming it is what I saw today ...

I drag and drop two messages from [Gmail]/Sent folder (or All Mail folder. I have to recheck my laptop**) to Inbox - one message moved, one message seems lost. 

** normally I move from Sent folder, and it always works. But perhaps I screwed up and dragged from All Mail?  Hopefully my imap log will tell me.
Severity: enhancement → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

2 years ago
invalid per previous comments

perhaps some items (comment 8?) should be included at https://support.mozilla.org/t5/Set-up-email/Thunderbird-and-Gmail/ta-p/14181

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.