Last Comment Bug 401513 - crash on startup with google desktop components [@ GoogleDesktopMozilla.dll@0x5500] [@ GoogleDesktopMozilla.dll@0x5512]
: crash on startup with google desktop components [@ GoogleDesktopMozilla.dll@0...
Status: RESOLVED INVALID
[crashkill][crashkill-thirdparty][cra...
: crash, user-doc-complete
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All Windows XP
: -- critical with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 440158 443787 447224 512602 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-28 19:38 PDT by bugs1m.wisefool
Modified: 2012-12-31 00:06 PST (History)
25 users (show)
mbeltzner: blocking‑firefox3.5-
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description bugs1m.wisefool 2007-10-28 19:38:54 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007102803 Minefield/3.0a9pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007102803 Minefield/3.0a9pre

This started when at the time I had Gran Paradiso alpha 8 installed on WinXP SP2. After I updated Google Desktop, the program crashes immediately after choosing a profile from the Profile Manager. I updated to the 10-28 nightly, and it still happened. I can prevent the crash by removing three files from the 'components' directory: GoogleDesktopMozilla.dll, GoogleDesktopMozillaStub.js, or GoogleDesktopMozillaStub.xpt. All have 'Date Modified' May 6th 2007 and the DLL says it's version 5.1.704.25560. The Google Desktop update listed in Google Updater says it was version 5.5.709.30344. I can always reproduce it right now, by putting the three files back inside the directory.

Reproducible: Always

Steps to Reproduce:
1. Paste the three GoogleDesktop* files into 'components'
2. Start Minefield's Profile Manager
3. Choose a profile
Actual Results:  
Crashpad appears
Comment 1 bugs1m.wisefool 2007-10-28 19:52:50 PDT
I mistyped; just adding/removing the DLL will cause the crash; the others don't have an effect.
Comment 2 Hasham 2008-05-30 15:23:48 PDT
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008053004 Minefield/3.1a1pre

I can't recreate this bug. I've tried Minefield nightly build, RC1, I've moved and removed the said files, but it won't crash. 
Comment 3 Mike Beltzner [:beltzner, not reading bugmail] 2008-05-30 15:37:13 PDT
When you remove those DLLs, does the Google Desktop stuff still work?

This is topcrash 18 on Windows:

http://crash-stats.mozilla.com/report/list?range_unit=weeks&version=Firefox%3A3.0&range_value=2&signature=GoogleDesktopMozilla.dll%400x5512

and as reporter infers, has existed for a long time. Crash stats go back. They all say the same thing:

GoogleDesktopMozilla.dll
xul.dll
(boom)
Comment 4 Mike Beltzner [:beltzner, not reading bugmail] 2008-05-30 15:43:23 PDT
(In reply to comment #2)
> I can't recreate this bug. I've tried Minefield nightly build, RC1, I've moved
> and removed the said files, but it won't crash. 

Have you tried with the older version DLL files, or the ones that you get when installing the Google Desktop client now? I think what's happening is that the update wasn't able to write the newer DLLs, so there's a mix of old version DLLs and the new version of Google Desktop
Comment 5 John J. Barton 2008-05-30 15:55:05 PDT
If you look at top crashers you will see more than one GoogleDesktopMozilla and
another googletoolbar. So this could be a top ten easy.

Unfortunately I reinstalled GDS on one machine before I realized the scope of
the problem. I can try it on another machine (with I think a similar old
version of GDS)

The scenario that broke for me was
  Old GDS + FF3 + FF3 + FF3,
  Uninstall all FF3,
  Install FF3rc1
  crash
Comment 6 Hasham 2008-05-30 16:07:20 PDT
I just installed GDS to check this bug so the DLL files are the ones that come with the install. I think the problem is with the update DLL files then.
Comment 7 John J. Barton 2008-05-30 16:15:01 PDT
(In reply to comment #6)
> I just installed GDS to check this bug so the DLL files are the ones that come
> with the install. I think the problem is with the update DLL files then.
> 
? The FF3 rc1 dlls? 

Comment 8 Hasham 2008-05-30 16:43:19 PDT
Sorry I misspoke. I meant that the DLL files that came with the install don't seem to be causing the problem. Thusly, I'm pointing the finger to the updates. :)
Comment 9 John J. Barton 2008-06-02 20:50:03 PDT
What this bug needs is an expert on windows dlls, how they register with windows, their caching and rebinding. The fact that my system worked for so long suggests that no analysis of FF3 itself will reveal a problem.  Except: I almost always used update or zip install, maybe the full windows installer does something?

Another big clue would be easier: does it happen with old GDS on a machine with no FF at FF3 install? Then a fix could be "abort in this case and require GDS update"

Has anyone talked to GDS team?  Don't be shy.
Comment 10 timeless 2008-06-03 05:39:07 PDT
i think that google's apps will update themselves.

there's nothing i'm going to do here. assign the bug to someone from the google desktop team.

for reference, here's a sample:

Signature	GoogleDesktopMozilla.dll@0x5512
UUID	10fbdf9e-3165-11dd-86be-001a4bd46e84
Time	2008-06-03 05:06:42-07:00
Uptime	101
Product	Firefox
Version	3.0
Build ID	2008051206
OS	Windows NT
OS Version	5.1.2600 Service Pack 2
CPU	x86
CPU Info	AuthenticAMD family 15 model 95 stepping 3
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x9
Comments	
Crashing Thread
Frame 	Module 	Signature 	Source
0 	GoogleDesktopMozilla.dll 	GoogleDesktopMozilla.dll@0x5512 	
1 	GoogleDesktopMozilla.dll 	GoogleDesktopMozilla.dll@0x4b7e 	
2 	xul.dll 	xul.dll@0x2afd54

note that xul.dll doesn't have a function name. this probably means that we don't have stack unwind information for googledesktop and so the stack is wrong. if you want to have fun you can abuse bp w/ windbg to learn all about this stuff....

http://developer.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg

you're free to try:
!analyze -v -f

but i doubt it'll help.

i think you'll want something like:

bp LoadLibrary "kp 3; g"
bp nsNativeModuleLoader::LoadModule "kp 3; g"
bp GoogleDesktopMozilla!DllMain "kp 3; g"

you should be able to add breakpoints to places somewhat randomly until you find the stack trace for the place where control enters but does not return from GoogleDesktop. You might be able to cheat and ask windbg to mark GoogleDesktopMozilla's memory pages as not readable and use that to find out each entry point (set a breakpoint, and then mark a portion readable, and continue from exception), with something like that you should be able to slowly create a map showing code flow through their module.
Comment 11 Tony Chung [:tchung] 2008-06-03 10:41:14 PDT
recommending for relnoting until google fixes this based on comment #10
Comment 12 John J. Barton 2008-06-03 10:48:51 PDT
(In reply to comment #10)
> i think that google's apps will update themselves.

But they don't.

> 
> there's nothing i'm going to do here. assign the bug to someone from the google
> desktop team.

It's not their app that crashes.

If FF3 broke GDS, or even if FF3 didn't work well with GDS, then sure, its their problem.  But the user experience here is not at all like that.  Rather the user installs FF3 and it crashes before coming up.  Nothing about GDS at all.  They have no recourse.  Why would they read the relnotes for a program that crashes out of the box?
Comment 13 Mike Beltzner [:beltzner, not reading bugmail] 2008-06-13 00:53:46 PDT
(relnote added, but a SUMO article would be better; I believe installing a fresh GDS fixes the issue)
Comment 14 Chris Ilias [:cilias] 2008-06-18 19:00:43 PDT
The relnote says to reinstalling Google Desktop Search. Does that mean that this happens with the latest version of the GDS? I'm asking because I'm wondering if it might be good to add it to the list under "Problematic or out of date extensions or themes" at <http://support.mozilla.com/en-US/kb/Firefox+crashes>.
Comment 15 John J. Barton 2008-06-18 22:18:25 PDT
I reinstalled GDS and have no crash.  

I started to write that this info would not matter. But your page is really excellent, so if people find it, it could make a difference. I suggest listing "Older versions of Google Desktop Search (update available)" with a link to the GDS site.
Comment 16 Brian 2008-06-19 02:07:00 PDT
1) I disabled GDS from tray, FF3 then starts fine. 
2) Upgraded GDS to current 5.7.0805.16405-en-pb, which requests reboot.
3) GDS asks for personal config, chose, saved.
4) FF3 runs fine with GDS.
Comment 18 Robert Strong [:rstrong] (use needinfo to contact me) 2008-06-26 12:54:24 PDT
*** Bug 440158 has been marked as a duplicate of this bug. ***
Comment 19 Matthias Versen [:Matti] 2008-07-22 18:56:13 PDT
*** Bug 447224 has been marked as a duplicate of this bug. ***
Comment 20 Mike Beltzner [:beltzner, not reading bugmail] 2008-12-22 21:03:01 PST
This doesn't block.

I believe it's actually tech-evang, if not INVALID or WORKSFORME. From what I recall/can tell, the issue is that for users with sufficiently old versions of GDS, some old and unused DLLs may be causing the crash on startup. Comments in this bug verify that if that happens, the solution is to uninstall GDS (which removes the old DLLs) and reinstall a fresh version. Simply updating through GDS itself doesn't seem to remove the offending DLLs.

Kev: do we know if anyone at Google cares to figure out if they can clean the old DLLs out through an automatic update?
Comment 21 Nochum Sossonko [:Natch] 2009-01-13 13:14:55 PST
*** Bug 443787 has been marked as a duplicate of this bug. ***
Comment 22 Shawn 2009-04-30 20:33:13 PDT
Uninstalled and re-installed Google desktop with the newest version and I still can't view Google desktop in FF3.0.10... Help!
Comment 23 Robert Strong [:rstrong] (use needinfo to contact me) 2009-08-25 19:44:50 PDT
*** Bug 512602 has been marked as a duplicate of this bug. ***
Comment 24 Henrik Skupin (:whimboo) 2009-11-04 11:21:18 PST
(In reply to comment #22)
> Uninstalled and re-installed Google desktop with the newest version and I still
> can't view Google desktop in FF3.0.10... Help!

Shawn, do you still get crashes with your current version of Google desktop? If yes, can you please tell me it's version number? If that's the case you should try the newest version 5.9.909.30391.

I tried it in different ways to reproduce the crash but I'm not able to until now. I have installed version 4 of Google Desktop and always crashed on startup (GoogleDesktopMozilla.dll@0x5824). After updating to the newest version I cannot see the crash anymore. 

Nearly all the crashes don't list a version number of the loaded modules from GDS which makes it harder to distinct which version people are using. If anyone knows where downloads for all the v5 minor versions can be downloaded I would appreciate the information.
Comment 25 Sheila Mooney 2011-12-06 14:35:34 PST
I can't find these signatures anymore. Also, isn't Google Desktop dead at this point. Seems to me like it's a candidate to be closed. If you feel otherwise, let me know. I am going to remove the top crash keyword in any event.
Comment 26 Matthias Versen [:Matti] 2012-12-31 00:06:56 PST
Google Desktop is gone

Note You need to log in before you can comment on or make changes to this bug.