Problems using default/shortened news url news:group

VERIFIED FIXED

Status

MailNews Core
Backend
P3
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: laurel, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

(Blocks: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Using 2000-05-31-08 commercial build

found while verifying bug #37464

When following a newsgroup link from browser or mail window which is in the
shortened/default server format (i.e. news:rec.music.gdead or news:<newsgroup>)
seamonkey does the following:

1.  Attempts to convert the url to a news server in the format of
news://hostname:119/.  This is easily seen if typing a short url such as
news:foobar in the browser window url/location edit box then pressing Enter.
2.  Adds the "server" (what you specified as the newsgroup name) to the folder
pane list
3.  Puts up one or two alert dialogs about the "server", the last one lingering
in the display after dismissing it, causing undue alarm since it looks like it
might hang.

Steps to reproduce:
1.  Launch a profile without a news account, go to browser.
2.  In the url/location box type news:foobar and press Enter.
3.  Notice what is happening in the location box; text changes to
news://foobar:119/
4.  Error displays (sometimes a previous error "foobar not found" will appear)
stating "Failed to connect to the server.   OK or using closebox or Esc will not
dismiss the alert dialog, it lingers.  However you are able to continue to do
other tasks in browser and once display is forced to refresh by loading another
page in browser, the alert will be gone.

Note:  this type of shortened url is relative to having a default news server.
In 4.x every profile always had at least a default "news" server. Since we don't
have this concept in seamonkey (user may not have any news accounts), we're not
handling such urls correctly.  Seth mentioned there may be existing bugs about
this and/or default news servers -- I only saw two relating to default servers
bug #16343 (M20) and bug #28364 (migrate default).  I thought it best to log
this for the short url problem, since I didn't see any specifically aimed at the
short/default server url format.
(Reporter)

Comment 1

18 years ago
meant to assign to Seth.
Assignee: mscott → sspitzer
QA Contact: lchiang → laurel
Summary: Problems using default/shortened news url news:group → Problems using default/shortened news url news:group
Status: NEW → ASSIGNED
Target Milestone: --- → M17
hmm.  

without a default news server, it is not clear how to handle this.

any idea how common news:<newsgroup> urls are?

Comment 3

18 years ago
moving to future milestone.
Target Milestone: M17 → Future

Comment 4

18 years ago
I just hit this bug.  In my experience, news: urls in general are not very
common.  However, of those that exist, the news:<newsgroup> form is much more
frequent than the form including the newsgroup server.

Comment 5

17 years ago
I would have thought that news:group URLs were quite common, but the fact that 
almost nobody's noticing this problem may suggest otherwise. One can use 
AltaVista to get an estimate:

Query             Pages
-----------------------
link:news:alt   107,432
link:news:comp   75,953
link:news:rec    51,475

The numbers are inflated, since they may include URLs with a server name, and 
some unrelated URLs (e.g. containing .../comp/news.html). A random sampling 
suggests that the large majority of hits are in fact from news:group URLs, but 
YMMV.

Many internet directories, including Yahoo and the Netscape-affiliated Open 
Directory Project (http://dmoz.org/), make frequent use of new:group URLs.

The current behavior (follow a new:group URL --> try to connect to a server 
named "group") is (in my opinion) very annoying, serves no possible use, and is 
incompatible with RFC 1738. If for whatever reason the correct behavior cannot 
be implemented, I think the only reasonable thing to do is to show a message box 
informing the user that this type of link is not supported.
Keywords: 4xp
getting complaints about this in the newsgroups.

I need to squash this.
Target Milestone: Future → mozilla1.0

Comment 7

17 years ago
1) A posability to specify a default newsserver.

2) A popup when clicking the link asking for a newserver if no default is
   configured. Possably with a list of all configured newserver to chose
   from (if ther are any).

EXTRA: A way to overide the default newserver for special herarkies.
   ie: netscape.* -> news.netscape.com

Comment 8

17 years ago
changing milestone to unknown.  It will get changed back when we figure out what
milestone to put this bug in.
Target Milestone: mozilla1.0 → ---
I've got a fix.  news:group urls will autosubscribe "group" on the first news
server the account mangager's FindServer() finds.  if there are none, I'll
create a news account on host "news" and add "group" to it.

if we add "default news account" functionality to the account manager, I can fix
that to autosubscribe to the default news server (like we did in 4.x)

I like the suggestion from larhal@gdpc.se to have a pop up to allow the user
pick a news server, and if none exist, allow the user to enter a news hostname
instead of assuming news.

when I marked this bug fixed, I'll open a new bug to track those RFEs / bugs.
I wrote:

"and if none exist, allow the user to enter a news hostname instead of assuming
news."

actually, this already works!  because we fire up the account wizard, you can
change the news server name when the account is created.

so all that needs to be done is either use the default news server or allow the
user to choose one.
Created attachment 21522 [details] [diff] [review]
fix.  happy new year!

Comment 12

17 years ago
Happy new decade
(nsCRT::strcmp("/",(const char *)path) == 0)
I'm not sure about nsCRT, but for (a == 0) use !a instead.
looks like you are using 2 space indent mostly, can you make that consistent?
Keywords: approval, patch, review
I've made the (a == 0) -> (!a) change.

seeking sr= from bienvenu.
Blocks: 40033
Created attachment 21556 [details] [diff] [review]
revised patch.

Comment 15

17 years ago
sr=bienvenu
fixed.  I'll go log a new bug to track the additional feature of allowing the
user to pick which server.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Blocks: 64142
(Reporter)

Updated

17 years ago
QA Contact: laurel → stephend
On NT 4.0 20001010804, doing this pulls up the Account Wizard, leaves the URL as
is in the browser window, and automatically uses server named News, and
subscribes two groups, foobar and hostname.  On Mac, build 2001010808, has News
subscribed with only one group: foobar.  My linux machine is unavailable at the
moment, so I'll check on that when it's back up.
Okay, on Linux, we also bring up the Account Wizard, just like Mac and Win32 do,
and like Mac, we have a News server with newsgroup foobar.  Should I open a new
bug for the trivial addition of:

News
 foobar
 hostname?
Should I open a new
bug for the trivial addition of:

News
 foobar
 hostname?

(This only applies to Win32).
VERIFIED FIXED, I'll open a new bug for the Win32 only problem.  
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.