Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Installing an add-on doesn't show the pop-up with Restart button

VERIFIED FIXED in mozilla1.9beta5

Status

()

Toolkit
Add-ons Manager
P2
normal
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: whimboo, Assigned: mossop)

Tracking

({regression, relnote})

Trunk
mozilla1.9beta5
regression, relnote
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

Created attachment 300455 [details]
Restart note without restart button shown

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008013004 Minefield/3.0b3pre

If you install an add-on under Windows the pop-up with the note to restart Firefox isn't shown. Seems to be a Windows only bug. At least it's visible on OS X.

Steps to reproduce:

1. Go to https://addons.mozilla.org/en-US/firefox/addon/1865
2. Install Adblock+
3. A note is shown under the add-on's name

But you don't get the pop-up with the restart button.
Flags: blocking-firefox3?
Blocks: 404024
Summary: Installing an add-on doesn't show the restart pop-up with Restart button → Installing an add-on doesn't show the pop-up with Restart button on Windows
After some test I noticed that the pop-up is shown when uninstalling an Add-on. So it only happens during the installation procedure.

Comment 2

10 years ago
Created attachment 300463 [details]
Missing Restart Minefield button on Linux screenshot

Comment 3

10 years ago
By the way, this does NOT repro on Mac OSX nightly.
Summary: Installing an add-on doesn't show the pop-up with Restart button on Windows → Installing an add-on doesn't show the pop-up with Restart button on Windows and Linux
OS: Windows XP → All

Comment 4

10 years ago
Nominating this to be fixed by beta 3.   We need this functionality be consistent across all 3 platforms. 
Priority: -- → P2
Target Milestone: --- → Firefox 3 beta3
Flags: blocking-firefox3? → blocking-firefox3+
Priority: P2 → P1

Comment 5

10 years ago
Created attachment 300630 [details]
screenshot

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008013102 Minefield/3.0b3pre ID:2008013102

WFM with some Add-ons.
(Assignee)

Comment 6

10 years ago
I can reproduce on all platforms, think I know what is going on here.
Assignee: nobody → dtownsend
Hardware: PC → All
Summary: Installing an add-on doesn't show the pop-up with Restart button on Windows and Linux → Installing an add-on doesn't show the pop-up with Restart button
(Assignee)

Updated

10 years ago
Depends on: 396129
As I understand things from talking with Mossop, this only happens with certain types of add-ons. I don't think this blocks beta 3; we can relnote it and get it fixed for beta 4. If Mossop disagrees, he should retarget to beta 3.
Keywords: relnote
Target Milestone: Firefox 3 beta3 → Firefox 3 beta4

Comment 8

10 years ago
Looks like that is the case.   And it happens on all platforms.

These are ones that i found so far, that install without any restart button.   There may be more out there.

- Adblock plus
- Adblock plus: Element Hiding Helper
- Toolbar Buttons

The majority of the other compatible ones i searched and installed always pop down the restart button.  So i would agree, this could be moved to beta 4.
Any connection with bug 351819?
Not really sure about this. As you can see Adblock is compatible with "Firefox: 1.5 – 3.0b3pre". There is no warning that I'm trying to install an incompatible extension at all. So it's an another issue.
Turning on the pref extensions.dss.switchPending shows the pop-up less than a second. So something is wired with gPendingActions?

http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/toolkit/mozapps/extensions/content/extensions.js&rev=1.161&mark=2073-2077&#2072
Blocks: 408116
No longer blocks: 404024
(Assignee)

Comment 12

10 years ago
(In reply to comment #9)
> Any connection with bug 351819?

Yes, it is the same issue rearing its head in the new system. 

Comment 13

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008020604 Minefield/3.0b4pre
(not running with Nightly Tester Tools)

I stumbled on the same issue too, with AdblockPlus 0.7.5.3. But I also noticed something else that might be related. After downloading the extension, while it was waiting for the restart, I can see that it is listed as "Not compatible with Minefield 3.0b4pre" (with the special icon), and you have the option to cancel the installation.

AdBlockPlus 0.7.5.3 does work though, after the restart.

Updated

10 years ago
Priority: P1 → P2

Comment 14

10 years ago
I have 3.0b3 on Linux, and when I installed ABP the restart button didn't show up in the addons dialog. However, after closing the dialog and reopening it from Tools -> Addons, the restart button was there. Not sure if that's of any help.
(Assignee)

Updated

10 years ago
Duplicate of this bug: 418824
(Assignee)

Updated

10 years ago
Status: NEW → ASSIGNED
Target Milestone: Firefox 3 beta4 → Firefox 3
(Assignee)

Updated

10 years ago
Whiteboard: [waiting on 396129 review]

Comment 16

10 years ago
Firefox Beta 3 Final version has this bug. This should be fixed in beta 4.
(Assignee)

Comment 17

10 years ago
(In reply to comment #16)
> Firefox Beta 3 Final version has this bug. This should be fixed in beta 4.

It will not be.
(Assignee)

Updated

10 years ago
Duplicate of this bug: 422663
This bug is already present in beta 5.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031205 Minefield/3.0b5pre
(In reply to comment #19)
> This bug is already present in beta 5.

Indeed. Please have a look at the status of this bug report. It is not marked as fixed yet.
I noticed also dictionary installs doesn't show the Restart bar. Sometimes the bar is displayed but immediately hided.

https://addons.mozilla.org/en-US/firefox/browse/type:3
(Assignee)

Comment 22

10 years ago
There really is no need for additional comments here. The problem is well known, there is a patch awaiting for review that will fix it.
(Assignee)

Updated

10 years ago
No longer depends on: 396129
(Assignee)

Comment 23

10 years ago
Fixed by bug 396129
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [waiting on 396129 review]
Target Milestone: Firefox 3 → Firefox 3 beta5
Flags: in-litmus?

Comment 24

10 years ago
Created attachment 309620 [details]
screenshot

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031423 Minefield/3.0b5pre

not fixed.
(In reply to comment #24)
> not fixed.

I confirm. Restart bar is showed but immediately hidden, **even if the extension is not compatible and so not installed**.

I tested it with Adblock Plus and dictionaries.
(Assignee)

Comment 26

10 years ago
(In reply to comment #24)
> Created an attachment (id=309620) [details]
> screenshot
> 
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031423
> Minefield/3.0b5pre

I'm unable to reproduce on today's nightly. Can you update and re-check. Are there particular extensions this happens with? Have you tested in a fresh profile? Do you have extension compatibility checking disabled?

Comment 27

10 years ago
(In reply to comment #26)

tested with Console2.
http://forums.mozillazine.org/viewtopic.php?t=577627

and with new/clean profile, all default setting (nothing change), no Add-ons.
Me too. However I must also say I downloaded Console2 from Mozilla extension site:

https://addons.mozilla.org/firefox/addon/1815/

I changed the maxversion to 3.* and installed it, and there's no bug with restart bar. On the contrary Pal-moz installed the version on mozdev.
(Assignee)

Comment 29

10 years ago
(In reply to comment #28)
> Me too. However I must also say I downloaded Console2 from Mozilla extension
> site:
> 
> https://addons.mozilla.org/firefox/addon/1815/
> 
> I changed the maxversion to 3.* and installed it, and there's no bug with
> restart bar. On the contrary Pal-moz installed the version on mozdev.

Right, which is what would have caused this bug in the past. But I am now unable to reproduce on windows or osx with that extension or adblock plus or any others I try.

What build are both of you on now?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031405 Minefield/3.0b5pre

I've installed the normal nightly build from Mozilla site for win32, no strange compilers or flags.
(Assignee)

Comment 31

10 years ago
(In reply to comment #30)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031405
> Minefield/3.0b5pre
> 
> I've installed the normal nightly build from Mozilla site for win32, no strange
> compilers or flags.

You are running a build from before this was fixed. Please update to today's nightly when it is available.
Mh. I've checked for updated and there's no one. I'll do this also with a clean profile. On ftp the latest nightly is the beta5... 

Could it be an update problem? What can I do?

Comment 33

10 years ago
(In reply to comment #29)
> What build are both of you on now?
> 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031423 Minefield/3.0b5pre ID:2008031423

will test with 0315 Nightly later.
(Assignee)

Comment 34

10 years ago
(In reply to comment #32)
> Mh. I've checked for updated and there's no one. I'll do this also with a clean
> profile. On ftp the latest nightly is the beta5... 

Today's nightly is not out yet, have some patience

Comment 35

10 years ago
Created attachment 309652 [details]
screenshot

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031506 Minefield/3.0b5pre ID:2008031506

no button.
1. Download Console2 from Mozilla
2. Change the maxversion
3. install it
4. notice that restart bar is not displayed
5. close the add-on window and reopen it without restart Firefox
6. restart bar now is displayed

https://addons.mozilla.org/firefox/addon/1815/

The only extension I tested that give me this error now is Console2 downloaded from Mozilla with changed version. Console2 from Mozillazine gives no error, and so Adblock Plus and dictionaries.
(Assignee)

Comment 37

10 years ago
(In reply to comment #36)
> 1. Download Console2 from Mozilla
> 2. Change the maxversion
> 3. install it

How exactly are you installing this?

> The only extension I tested that give me this error now is Console2 downloaded
> from Mozilla with changed version. Console2 from Mozillazine gives no error,
> and so Adblock Plus and dictionaries.

Which appears the opposite to what pal-moz sees unfortunately.
> How exactly are you installing this?

Only to test this bug (if it's still a bug)

> Which appears the opposite to what pal-moz sees unfortunately.

Well, simply I don't know why. I'm very sure I don't wrong. 
Pal-moz, do you have installed Console2 from Mozila or from Mozillazine this time?

PS: everyone knows snv or cvs commands to get latest trunk source?
(Assignee)

Comment 39

10 years ago
(In reply to comment #38)
> > How exactly are you installing this?
> 
> Only to test this bug (if it's still a bug)

You are misunderstanding my question. You say you install this extension that you have edited. I am asking how.
Ah, I've read "why" :-P

I set maxVersion to 3.0b5pre and to 3.*, same problem in both cases.
(Assignee)

Comment 41

10 years ago
(In reply to comment #40)
> Ah, I've read "why" :-P
> 
> I set maxVersion to 3.0b5pre and to 3.*, same problem in both cases.

You are still not providing me the information I need. Please tell me the precise physical steps you are taking from changing the data in the install.rdf to how you install the resulting xpi into the application.

Comment 42

10 years ago
(In reply to comment #38)
> Pal-moz, do you have installed Console2 from Mozila or from Mozillazine this
> time?

everytime from mozillazine.

[my step]
1-1) download xpi
1-2) nothing change (not rewrite/change maxversion etc...)
2) D&D xpi to install
(Assignee)

Comment 43

10 years ago
(In reply to comment #42)
> (In reply to comment #38)
> > Pal-moz, do you have installed Console2 from Mozila or from Mozillazine this
> > time?
> 
> everytime from mozillazine.
> 
> [my step]
> 1-1) download xpi
> 1-2) nothing change (not rewrite/change maxversion etc...)
> 2) D&D xpi to install
> 

Thank you for the full str, I can now reproduce this. Filed bug 423218
(In reply to comment #41)
> Please tell me the precise physical steps you are taking from changing the data
> in the install.rdf to how you install the resulting xpi into the application.

Ok :-) I have:

1. downloaded the Console2 ext. from Mozilla
2. unpacked it (with 7-zip)
3. changed the maxversion (with Notepad++)
4. repacked it (zip archive, normal compression with 7-zip)
5. changed the extension to .xpi
6. installed it

I tried the install with double click (with Fx opened), with D&D and with File -> open File, and with maxVersion == 3.* and 3.0b5. Every time I created a new blank profile.

(remainder: restart bar is displayed but suddenly hidden. On the contrary if you reopen the add-on window you can see the restart bar. rev 2008031506 winxp)
> Filed bug 423218
Ah, excuse me. I've skipped it because I think me and Pal-moz had two different bugs.
Depends on: 423218
(Assignee)

Updated

10 years ago
Duplicate of this bug: 424652
henrik, this has been marked as fixed.  can you verify please?   Thanks.
Litmus test: https://litmus.mozilla.org/show_test.cgi?searchType=by_id&id=5292
Flags: in-litmus? → in-litmus+
Verified fix on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008052903 Firefox/3.0
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.